Вход | Регистрация


Метод объекта не обнаружен (вывести)

Метод объекта не обнаружен (вывести)
Я
   Jalib
 
26.09.16 - 13:53
Здравствуйте! разрабатываю простую форму не могу понять в чем проблема
Процедура КнопкаСформироватьНажатие(Кнопка)
    // Вставить содержимое обработчика.

сообщить("тест");
СформироватьНаСервере(ТабДок);
КонецПроцедуры

Процедура ВыбПериодНажатие(Элемент)
    НастройкаПериода = Новый НастройкаПериода;
    НастройкаПериода.РедактироватьКакИнтервал = Истина;
    НастройкаПериода.РедактироватьКакПериод = Истина;
    НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Период;
    НастройкаПериода.УстановитьПериод(НачПериода, ?(КонПериода='0001-01-01', КонПериода, КонецДня(КонПериода)));
    Если НастройкаПериода.Редактировать() Тогда
        НачПериода = НастройкаПериода.ПолучитьДатуНачала();
        КонПериода = НастройкаПериода.ПолучитьДатуОкончания();
    КонецЕсли;
КонецПроцедуры
/////////////////////////////////////////////////////////////////////



//&НаКлиенте

//Процедура Сформировать(Команда)
//    СформироватьНаСервере(ТабДок);

//КонецПроцедуры

//&НаСервереБезКонтекста

Процедура СформироватьНаСервере(ТабДок);
    Макет          = ПолучитьМакет("ОтчетКонтрагенты");
    ОбластьШапка   = Макет.ПолучитьОбласть("Шапка");
    ОбластьСтрока  = Макет.ПолучитьОбласть("Строка");
    ОбластьДоговор = Макет.ПолучитьОбласть("Договор");
    
    ТабДок = Новый ТабличныйДокумент;
    ТабДок=ЭлементыФормы.ТабДок;
    ТабДок.Очистить();
    ТабДок.Вывести(ОбластьШапка);
    
    
    Выборка = Справочники.Контрагенты.Выбрать();
    Пока Выборка.Следующий() Цикл
        Если Выборка.ЭтоГруппа Тогда
            Продолжить;
        КонецЕсли;    
        ОбластьСтрока.Параметры.Заполнить(Выборка);
        ОбластьСтрока.Параметры.Контрагент = Выборка.Наименование;
        ОбластьСтрока.Параметры.КонтрагентСсылка = Выборка.Ссылка;
        ТабДок.Вывести(ОбластьСтрока);
        ВыборкаДоговор = Справочники.ДоговорыКонтрагентов.Выбрать(,Выборка.Ссылка);
        Пока ВыборкаДоговор.Следующий() Цикл
             ОбластьДоговор.Параметры.ИмяДоговора = ВыборкаДоговор.Наименование;
             ТабДок.Вывести(ОбластьДоговор);
        КонецЦикла;    
    КонецЦикла;    
        
КонецПроцедуры
 
 
   Jalib
 
1 - 26.09.16 - 13:55
пишет что метод Вывести не обнаружен
   Митяйский
 
2 - 26.09.16 - 13:55
ТабДок = Новый ТабличныйДокумент;
    ТабДок=ЭлементыФормы.ТабДок;
   Jalib
 
3 - 26.09.16 - 14:08
а как должно быть?
   Mankubus
 
4 - 26.09.16 - 14:12
(3) попробуй методом исключения убрать одну строку
   Jalib
 
5 - 26.09.16 - 14:15
попробывал и так и так
   aleks_default
 
6 - 26.09.16 - 14:24
А точно не на ЭлементыФормы ругается?
   МимохожийОднако
 
7 - 26.09.16 - 14:27
Посмотри в СП  в каких режимах это метод доступен.
   Jalib
 
8 - 26.09.16 - 14:30
написанно толстый клиент я в нем и запускаю
   МимохожийОднако
 
9 - 26.09.16 - 14:34
(8) А как насчет директивы НаСервере НаКлиенте..?
   Митяйский
 
10 - 26.09.16 - 14:39
(3) А если так?

    ТабДок = Новый ТабличныйДокумент;
    //

    ТабДок.вывести(ОбластьТакаято);
    ЭлементыФормы.ТабДок.Вывести(Табдок);
 
 Рекламное место пустует
   Jalib
 
11 - 26.09.16 - 14:48
9-директив нет
10-то же самое пишет
   Jalib
 
12 - 26.09.16 - 15:16
9-я разрабатываю простую форму не управляемое приложение поэтому без дериктив
   МимохожийОднако
 
13 - 26.09.16 - 15:24
А отладчик что показывает на Таб перед строкой с ошибкой?
   Jalib
 
14 - 26.09.16 - 17:21
13-показывает что это таблица значений
   aleks_default
 
15 - 26.09.16 - 17:28
Чукча, походу, копипаст
   Jalib
 
16 - 26.09.16 - 17:36
а с Юга чукчи бывают? если да то пусть буду Чукча с Юга)))что касается"копипаст" то я ученик и иногда пользуюсь им
   aleks_default
 
17 - 26.09.16 - 17:39
Ты осторожнее с ним, а то волосы на руках вырастут:)
   Jalib
 
18 - 26.09.16 - 17:47
aleks_default а не пойти ли тебе сам догадайся куда
   anatoly
 
19 - 26.09.16 - 18:14
(14) и какие вопросы???
у ТЗ нет метода вывести()!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует