Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Ошибка: Поле объекта недоступно для записи (Документы)

Ошибка: Поле объекта недоступно для записи (Документы)
Я
   Радим1987
 
26.09.16 - 10:10
День добрый.Проведенные документы не могу программно получить получаю такое сообщение Поле объекта недоступно для записи (Документы)? как исправить?
 
 
   Остап Сулейманович
 
1 - 26.09.16 - 10:12
(0) Не нужно пытаться присвоить переменной Документы какое-либо значение.
   Радим1987
 
2 - 26.09.16 - 10:12
    
Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    Начисления.Регистратор КАК Регистратор
        |ПОМЕСТИТЬ ВременнаяТаблица
        |ИЗ
        |    РегистрРасчета.Начисления КАК Начисления
        |
        |СГРУППИРОВАТЬ ПО
        |    Начисления.Регистратор
        |
        |ОБЪЕДИНИТЬ ВСЕ
        |
        |ВЫБРАТЬ
        |    Удержания.Регистратор
        |ИЗ
        |    РегистрРасчета.Удержания КАК Удержания
        |
        |СГРУППИРОВАТЬ ПО
        |    Удержания.Регистратор
        |
        |ОБЪЕДИНИТЬ ВСЕ
        |
        |ВЫБРАТЬ
        |    ЗарплатаКВыплатеОбороты.Регистратор
        |ИЗ
        |    РегистрНакопления.ЗарплатаКВыплате.Обороты(&Начало, &Конец, Регистратор, ) КАК ЗарплатаКВыплатеОбороты
        |
        |СГРУППИРОВАТЬ ПО
        |    ЗарплатаКВыплатеОбороты.Регистратор
        |;
        |
        ////////////////////////////////////////////////////////////////////////////////

        |ВЫБРАТЬ
        |    БольничныйЛист.Ссылка КАК Ссылка
        |ИЗ
        |    ВременнаяТаблица КАК ВременнаяТаблица
        |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.БольничныйЛист КАК БольничныйЛист
        |        ПО ВременнаяТаблица.Регистратор = БольничныйЛист.Ссылка";
    
    Запрос.УстановитьПараметр("Конец", ТекущаяДата());
    Запрос.УстановитьПараметр("Начало", '20160701');
    
    РезультатЗ = Запрос.Выполнить().Выгрузить();
    
        
    Для каждого Строка из РезультатЗ Цикл
            Документы = СтрокаДок.Ссылка.ПолучитьОбъект();             
    Попытка
        Документы.Записать(РежимЗаписиДокумента.Проведение);
        Сообщить("Создан документ " + Документы.Ссылка);
    Исключение
        Сообщить("Не удалось создать документ");
    КонецПопытки;

        
    КонецЦикла;

   Amra
 
3 - 26.09.16 - 10:13
(2) Перечитай (1) внимательно, до полного понимания
   Остап Сулейманович
 
4 - 26.09.16 - 10:15
(2) Вот здесь :
Для каждого Строка из РезультатЗ Цикл
    Документы = СтрокаДок.Ссылка.ПолучитьОбъект();             
    Попытка
        Документы.Записать(РежимЗаписиДокумента.Проведение);
        Сообщить("Создан документ " + Документы.Ссылка);
    Исключение
        Сообщить("Не удалось создать документ");
    КонецПопытки;

Просто для прикола попробуй изменить "Документы" на (например) "текущийДокумент".
   Радим1987
 
5 - 26.09.16 - 10:16
РезультатЗ = Запрос.Выполнить().Выбрать();
    
        
    пока РезультатЗ.Следующий() Цикл
            РезультатЗ.Ссылка.ПолучитьОбъект();             
    Попытка
        РезультатЗ.Ссылка.Записать(РежимЗаписиДокумента.Проведение);
        Сообщить("Создан документ " + Документы.Ссылка);
    Исключение
        Сообщить("Не удалось создать документ");
    КонецПопытки;

        
    КонецЦикла;
   Радим1987
 
6 - 26.09.16 - 10:17
получает объект только не перепроводит
   mehfk
 
7 - 26.09.16 - 10:18
Потому что в (5) - копрокод.
   Остап Сулейманович
 
8 - 26.09.16 - 10:19
(5) птля...

РезультатЗ = Запрос.Выполнить().Выбрать();
пока РезультатЗ.Следующий() Цикл
    Об = РезультатЗ.Ссылка.ПолучитьОбъект();             
    Попытка
        Об.Записать(РежимЗаписиДокумента.Проведение);
        Сообщить("Создан документ " + Об.Ссылка);
    Исключение
        Сообщить("Не удалось создать документ");
    КонецПопытки;
КонецЦикла;

И внимательно отследи где и вместо кого стало вот этовот "Об".
   Радим1987
 
9 - 26.09.16 - 10:20
решение

    РезультатЗ = Запрос.Выполнить().Выбрать();
    
    
    пока РезультатЗ.Следующий() Цикл
        
        Попытка
            РезультатЗ.Ссылка.ПолучитьОбъект().Записать(РежимЗаписиДокумента.Проведение);
            Сообщить("Создан документ " + РезультатЗ.Ссылка);
        Исключение
            Сообщить("Не удалось создать документ");
        КонецПопытки;
        
        
    КонецЦикла;
   Радим1987
 
10 - 26.09.16 - 10:21
(8) твой метод не работает
 
 Рекламное место пустует
   Радим1987
 
11 - 26.09.16 - 10:21
Поле объекта недоступно для записи (Документы) вот это ошибку выдает
   alexei366
 
12 - 26.09.16 - 10:24
(9) А чего в комментах "Создать", мы же не создаем)))) (10) Значит ты что-то не так делаешь, или код старый не потер
   Радим1987
 
13 - 26.09.16 - 10:28
надо было записать вот так Сообщить("?Док перепроведен? " + РезультатЗ.Ссылка);
   Радим1987
 
14 - 26.09.16 - 10:28
))) ладно тема закрыта всем Спасибо
   Timon1405
 
15 - 26.09.16 - 10:29
Ты хоть понял что делал не так?
   Остап Сулейманович
 
16 - 26.09.16 - 10:29
(11) А ну-ка найди в (8) хоть одно слово "Документы".
   Радим1987
 
17 - 26.09.16 - 10:30
Думаю в запросе надо было добавить "для изменения"
   aleks_default
 
18 - 26.09.16 - 10:31
Да нихрена он не понял. Ждем следующий тупой вопрос.
Потому что товарищи вместо того чтобы объяснить ему готовый код дали.
   Радим1987
 
19 - 26.09.16 - 10:31
ИзначальноБыло не документы а Док все равно выдавал такую ошибку
   iceman2112
 
20 - 26.09.16 - 10:31
его прет похоже
   Жан Пердежон
 
21 - 26.09.16 - 10:32
(19) чувак, программирование походу не твоё
   Радим1987
 
22 - 26.09.16 - 10:33
а нет вру
   Радим1987
 
23 - 26.09.16 - 10:33
Зарезирвированное слово
   Остап Сулейманович
 
24 - 26.09.16 - 10:35
(23) Ф-у-ух. Слава Тьюрингу и конечная машина пророк его.
   Радим1987
 
25 - 26.09.16 - 10:36
))) спасибо всем


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует