Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

КА1.1 Убрать лишние организации или оставить нужные

КА1.1 Убрать лишние организации или оставить нужные
Я
   МимохожийОднако
 
26.09.16 - 07:11
Есть база 5-летней давности. Требуется либо убрать лишние 3, либо оставить 2 нужные. Клиент-серверная версия. Мои попытки удалить лишние документы по организациями заткнулись на большом объеме и множестве связей. Второй попыткой попробовал использовать встроенный обмен между КА. Выгружает неполные документы и процесс не менее длительный. Помнится на БП2.0 удавалось решить эту проблему, используя РИБ с отбором по организации. Но в КА1.1 я такой возможности не нашёл. Поделитесь идеями или опытом.
 
 
   CepeLLlka
 
1 - 26.09.16 - 07:15
Обработкой "УдалениеВсехДанныхПоОрганизации"

Объём большой, да.. надо терпеть и делать..
   jsmith
 
2 - 26.09.16 - 07:15
Какие связи?
Что значит неполные?
   МимохожийОднако
 
3 - 26.09.16 - 07:17
(1) Это встроенная обработка? Или твоя? Или попытка пошутить? (2) Например, список в справочнике без наименований у Родителей, пустые реквизиты. Документы без табличных частей и т.п.
   hhhh
 
4 - 26.09.16 - 07:39
(3) выгрузка загрузка xml ?
   МимохожийОднако
 
5 - 26.09.16 - 07:42
(4) Поясни.
   hhhh
 
6 - 26.09.16 - 07:45
(5) типовая обработка такая. Ставишь отбор по организации и вперед.
   Lamer1C
 
7 - 26.09.16 - 08:17
(0) делал тоже самое с КА. Обработки по удалению - их много в сети, с небольшими правками. от выгрузок/загрузок отказался
   МимохожийОднако
 
8 - 26.09.16 - 08:21
(7) Может есть пару ссылок?
   Lamer1C
 
9 - 26.09.16 - 08:31
(8) в яндексе: "1с Удаление по организации". я брал несколько, на тестовой пробовал, потом одну оставил.в любом случае для КА бесплатной готовой не нашел, пришлось несколько регистров сведений чистить своими процедурами.
   sergeev-ag-1977
 
10 - 26.09.16 - 08:33
Могу подогнать обработку из 10 строк кода что бы это выполнить: удалить не нужные.
 
 Рекламное место пустует
   sergeev-ag-1977
 
11 - 26.09.16 - 08:33
Только за 5 лет - может лучше перенести с помощью конвертации в актуальную версию ....
   jsmith
 
12 - 26.09.16 - 08:35
У него какая-то неправильная конвертация. Табличные части не переносятся. Гы гы гы
   jsmith
 
13 - 26.09.16 - 08:36
Единственная закавыка может быть со связями. Типа там интеркампани.
   МимохожийОднако
 
14 - 26.09.16 - 08:38
(10) Написал в личку
   МимохожийОднако
 
15 - 26.09.16 - 08:39
(12) Я свои правила не писал. Пользовался типовыми. Пустые ТЧ скорее всего из-за того, что база затыкалась периодически. Спасибо за поддержку ветки.
   Lamer1C
 
16 - 26.09.16 - 08:47
(15) база большая?
   darius357
 
17 - 26.09.16 - 08:53
ну как всегда побакланили, и нифига толку. Сказочные бакланы
   jsmith
 
18 - 26.09.16 - 08:53
(10) А чо там?
Подключение через интернет?
   sergeev-ag-1977
 
19 - 26.09.16 - 08:54
Оправил на почту.
   jsmith
 
20 - 26.09.16 - 08:56
Кинь мне тоже, а.
   jsmith
 
21 - 26.09.16 - 08:56
Что за 10 строк - может, пригодится..
   sergeev-ag-1977
 
22 - 26.09.16 - 08:59
Для каждого Документ из Метаданные.Документы Цикл
        
        Выборка = Документы[Документ.Имя].Выбрать();
        
        Пока Выборка.Следующий() Цикл
            Попытка
                Если Найти(Выборка.Организации.Наименование , " ..." ) = 0 Тогда// Свои условия

                    Выборка.Ссылка.ПолучитьОбъект().УстановитьПометкуУдаления(Истина);
                    а = а + 1;
                    б = а - Окр(а, -2);
                    Если б = 0 Тогда
                        Сообщить("Номер " + а + " - " + Выборка.Ссылка, СтатусСообщения.Информация);
                    КонецЕсли;
                КонецЕсли;
            Исключение
                
            КонецПопытки;
        КонецЦикла;
        
    КонецЦикла;
   jsmith
 
23 - 26.09.16 - 09:00
Блин. Я думал, там что-то космическое.
Лучше удалять непосредственно.
   sergeev-ag-1977
 
24 - 26.09.16 - 09:01
Мой код не оптимален, но сойдет . Потому и писал 10 строк кода.
   oslokot
 
25 - 26.09.16 - 09:02
(24) а по факту 16 строк )
   Serg_1960
 
26 - 26.09.16 - 09:04
(0) РИБ; ручная регистрация изменений документов(алгоритм, подобный вышеуказанному); обмен; профит; фуршет :)
   sergeev-ag-1977
 
27 - 26.09.16 - 09:08
(23) Ну это очень смело, я всегда проверяю.
   МимохожийОднако
 
28 - 26.09.16 - 09:10
(19) Спасибо. Получил.
   sergeev-ag-1977
 
29 - 26.09.16 - 09:10
(25) а по сути 11
   sergeev-ag-1977
 
30 - 26.09.16 - 09:11
только проверять нужно равенство ссылок, а не текст
   МимохожийОднако
 
31 - 26.09.16 - 09:11
(23) Можно попробовать и так, а потом ТИИ.
   sergeev-ag-1977
 
32 - 26.09.16 - 09:11
Да я в 1С вообще не волоку - я же бухгалтер ... )))
   Azverin
 
33 - 26.09.16 - 09:16
(32) ну так призави программиста! будь мужиком!
 
 
   МимохожийОднако
 
34 - 26.09.16 - 09:18
(33) Ты мне кричи, а  у него всё в порядке.))
   aleks_default
 
35 - 26.09.16 - 09:21
(30)А договора например?
   sergeev-ag-1977
 
36 - 26.09.16 - 09:27
(35) А что не получается ?

Для каждого Справочник из Метаданные.Документы Цикл ...
   sergeev-ag-1977
 
37 - 26.09.16 - 09:29
(33) уже позвал
   Serg_1960
 
38 - 26.09.16 - 09:33
sergeev-ag-1977, без обид, но алгоритм неработоспособный для реальной конфигурации. Организация в документе может быть указана не только в реквизите "Организация".
Да и не только в документах есть информация, связанная с организациями, их тоже надо удалять.
   aleks_default
 
39 - 26.09.16 - 09:34
11 магических строк кода, которые могут все
   sergeev-ag-1977
 
40 - 26.09.16 - 09:40
(38) в моём случае хватало ...
У него типовая конфигурация.
Да и что Вы хотите от бухгалтера. )))
   Chameleon1980
 
41 - 26.09.16 - 09:44
(38)

"..документе может быть указана не только в реквизите "Организация".
Да и не только в документах есть информация, связанная с организациями, их тоже надо удалять..."

а поискСсылок не поможет вам чёль?
   sergeev-ag-1977
 
42 - 26.09.16 - 09:44
Ещё есть 2 способа:
- РИБ
- Конвертация данных
   yurikmellon2
 
43 - 26.09.16 - 09:45
(0) мы делили базу где учет велся по нескольким организациям на несколько разных баз обработкой РазделениеИнформационнойБазыПоОрганизациям.epf
   sergeev-ag-1977
 
44 - 26.09.16 - 09:45
(41) - поиск ссылок - зачетная идея !
   aleks_default
 
45 - 26.09.16 - 09:46
Чем (4) не устраивает?
   sergeev-ag-1977
 
46 - 26.09.16 - 09:51
Нанять 100 бухгалтеров которые никому не нужны (из др. темы) - пусть руками колотят за еду !!! ))) Тоже вариант
   МимохожийОднако
 
47 - 26.09.16 - 10:48
(42) РИБ в КА только полный. По организации нет.
   Serg_1960
 
48 - 26.09.16 - 11:21
(41) Чёль речь шла о конкретном алгоритме, а не об абстрактном "Как лучше сделать?".
   МимохожийОднако
 
49 - 26.09.16 - 11:33
(43) Есть ссылка? Или это самопал?
 
 Рекламное место пустует
   sh8ce
 
50 - 26.09.16 - 11:40
удалить напрямую в скуле
   yurikmellon2
 
51 - 26.09.16 - 11:48
(49) скинул в почту в профиле
   МимохожийОднако
 
52 - 26.09.16 - 11:53
(51) Спасибо. Уже смотрю. Но она только для БП 2.0
   yurikmellon2
 
53 - 26.09.16 - 12:12
(52) чем могу...


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует