Вход | Регистрация


Поиск по ссылкам не работает

Поиск по ссылкам не работает
Я
   ildarian
 
23.09.16 - 17:39
Добрый день.

Платформа 8.3.8.1747.
При использовании функции "ПолучитьПоСсылкам" выдает ошибку "не допустимое значение параметра 1".
Вот код 

&НаСервере
Процедура НайтиСсылкиНаСервере()
    
    Массив = Новый Массив();
    
    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ
    |    ПоступлениеТоваровУслуг.Ссылка
    |ИЗ
    |    Документ.ПоступлениеТоваровУслуг КАК ПоступлениеТоваровУслуг
    |ГДЕ
    |    ПоступлениеТоваровУслуг.Номер = &Номер";
    Запрос.УстановитьПараметр("Номер","ДО08-002887" );
    РезультатЗапроса = Запрос.Выполнить();
    
    Выборка = РезультатЗапроса.Выбрать();
    Пока Выборка.Следующий() Цикл
        
        Массив.Добавить(Выборка.Ссылка);

    КонецЦикла;
    
    а = НайтиПомеченныеНаУдаление();
    //Массив.Добавить(Документы.ПоступлениеТоваровУслуг.НайтиПоНомеру("КВ06-005349"));

    //Массив.Добавить(Документы.ПоступлениеТоваровУслуг.НайтиПоНомеру("ЖИ01-006885"));

    ТЗ = НайтиПоСсылкам(Массив);
    Для каждого стр Из ТЗ Цикл
        
        Сообщить(стр);
        
    КонецЦикла;
КонецПроцедуры

&НаКлиенте
Процедура НайтиСсылки(Команда)
    НайтиСсылкиНаСервере();
КонецПроцедуры
 
 
   ildarian
 
1 - 23.09.16 - 17:40
а бывает просто виснет 1с
   ildarian
 
2 - 23.09.16 - 17:43
находил в инете, что баг платформы. Може кто сталкивался.
   aleks_default
 
3 - 23.09.16 - 17:43
Массив пуст
   ildarian
 
4 - 23.09.16 - 17:44
не пуст
   ildarian
 
5 - 23.09.16 - 17:44
там 3 документа
   aleks_default
 
6 - 23.09.16 - 17:47
(5)3 документа с одним номером?
   ildarian
 
7 - 23.09.16 - 17:48
(6) да. В разных годах документы
   ildarian
 
8 - 23.09.16 - 17:53
база на sql, если что
   aleks_default
 
9 - 23.09.16 - 17:55
Код в (0) рабочий. Заскринь полный текст ошибки, а то что-то тебе на слово не верится.
   aleks_default
 
10 - 23.09.16 - 17:57
А, еще 
УстановитьПривилегированныйРежим(Истина) поставь
 
 Рекламное место пустует
   ildarian
 
11 - 23.09.16 - 18:03
Странно, сейчас тупо 1с виснет, и уже нечего не выдает. Код не менял
   jsmith
 
12 - 23.09.16 - 18:07
Для каждого стр Из ТЗ Цикл
        
        Сообщить(стр);
        
    КонецЦикла;

Это что за ужас

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует