Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Люди добрые помогите создать документ неопределенного вида

v7: Люди добрые помогите создать документ неопределенного вида
Я
   Zoeh
 
22.09.16 - 16:01
ДокДовер.ВыбратьПодчиненныеДокументы(Докум.ДатаДок-60,Докум.ДатаДок+5,Докум.ТекущийДокумент());
    Пока ДокДовер.ПолучитьДокумент()=1 Цикл

..........вот куда и че тут воткнут///

НазначитьВид(ДокДовер,"Доверенность")///не помогает

ДокДовер.Новый();
Не определен вид документа
 
 
   palpetrovich
 
1 - 22.09.16 - 16:03
(0) не надо так делать
   Zoeh
 
2 - 22.09.16 - 16:03
ну мне надо
   Господин ПЖ
 
3 - 22.09.16 - 16:04
не держи его так
   Zoeh
 
4 - 22.09.16 - 16:04
ДокДовер=СоздатьОбъект("Документ");
   Zoeh
 
5 - 22.09.16 - 16:05
ДокДовер=СоздатьОбъект("Документ");
    ДокДовер.ВыбратьПодчиненныеДокументы(Докум.ДатаДок-60,Докум.ДатаДок+5,Докум.ТекущийДокумент());
    Пока ДокДовер.ПолучитьДокумент()=1 Цикл
        Если (ДокДовер.Вид()="Доверенность")и(ДокДовер.ПометкаУдаления()=0) Тогда
            Прервать;
        КонецЕсли;
    КонецЦикла;
    Если ПустоеЗначение(ДокДовер)=1 Тогда
        ДокДовер.Вид()="Доверенность";
        ДокДовер.Новый();
        ДокДовер.ДокОснование=Докум;
        ДокДовер.ДатаДок = ДокДовер.ДатаДок;
        ДокДовер.Фирма = Докум.Фирма;
        ДокДовер.Контрагент = Докум.Контрагент;
        ДокДовер.Договор = Докум.Договор;
        глЗаполнитьШапку(ДокДовер,1);
        ДокДовер.Записать();
    КонецЕсли;
   palpetrovich
 
6 - 22.09.16 - 16:07
(5)
Если ПустоеЗначение(ДокДовер)=1 Тогда
ДокДовер=СоздатьОбъект("Документ.Доверенность");
...
   HawkEye
 
7 - 22.09.16 - 21:08
(2) тебе не надо ))

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует