Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Изменения в типовой конфигурации

Изменения в типовой конфигурации
Я
   TigraN1986
 
22.09.16 - 10:02
Доброе время суток!
Я совсем новичок в программировании, а тем более в 1С. По работе приходится делать изменения в конфигурации Розница 2.1.
Именно сейчас приходится дорабатывать обработку "подбор товаров". Есть табличная часть  "ПодборТаблицаНоменклатура", в которой при двойном клике переносится строка в табличную часть "Корзина". Но это неудобно, т.к. приходится делать двойной клик на каждую строку. Видел измененые конфигурации, где выбираются несколько строк и при нажатии на кнопку в корзину добавляются  выбранные строки. Я создал такую команду и в ней написал следующий код:
&НаКлиенте
Процедура ПодобратьВыделенные(Команда)
    
    Если Элементы.ПодборТаблицаНоменклатура.ВыделенныеСтроки.Количество() = 0 Тогда
        Возврат;
    ИначеЕсли Элементы.ПодборТаблицаНоменклатура.ВыделенныеСтроки.Количество() = 1 Тогда// И НЕ Элементы.ПодборТаблицаНоменклатура.ТекущиеДанные.ИспользованиеХарактеристик Тогда

        ПодборТаблицаНоменклатураВыбор(Элементы.ПодборТаблицаНоменклатура, Элементы.ПодборТаблицаНоменклатура.ТекущаяСтрока, Неопределено, Истина);
    Иначе
        Для Каждого ВыделеннаяСтрока Из Элементы.ПодборТаблицаНоменклатура.ВыделенныеСтроки Цикл
            Сообщить (ВыделеннаяСтрока);
            
            СтруктураПараметры = Новый Структура;
            СтруктураПараметры.Вставить("Номенклатура",               ВыделеннаяСтрока);
            СтруктураПараметры.Вставить("ТипНоменклатуры",            ПодборТекущаяНоменклатураТипНоменклатуры);
            СтруктураПараметры.Вставить("Характеристика",             ПредопределенноеЗначение("Справочник.ХарактеристикиНоменклатуры.ПустаяСсылка"));
            СтруктураПараметры.Вставить("ХарактеристикиИспользуются", Ложь);
            СтруктураПараметры.Вставить("Упаковка", ПредопределенноеЗначение("Справочник.УпаковкиНоменклатуры.ПустаяСсылка"));
            СтруктураПараметры.Вставить("Цена",    Цена);
            ДобавитьВКорзину(СтруктураПараметры, 1);
        КонецЦикла;
        
    КонецЕсли;

КонецПроцедуры

Проблема в том, что при переносе корзины в документ вместо цены поставляется цена последнего выбранного товара из таблицы "ПодборТаблицаНоменклатура".
Прошу вас просмотреть код и помочь мне исправить ошибку.
 
 
   jsmith
 
1 - 22.09.16 - 10:08
СтруктураПараметры.Вставить("Цена",    Цена)

Цена что это? Каково значение переменной?
   Kassius
 
2 - 22.09.16 - 10:38
(1) В цене последняя цена, сказали ж. Не обновлял он ее.
(0) Это просто год не счастливый =)
   TigraN1986
 
3 - 30.09.16 - 12:15
(1) Это цена товара выделенной строки. Но почему-то в Структуру поставляется цена последней выделенной строки.
   jsmith
 
4 - 30.09.16 - 12:18
>>новичок
Уф, пронесло, думал, "новичек" будет.
   jsmith
 
5 - 30.09.16 - 12:19
Стыд и срам. Я же был в этой ветке. Чукча не читатель.
   TigraN1986
 
6 - 01.10.16 - 12:08
"Уф, пронесло, думал, "новичек" будет."
может вместо этого просто подсказать как доработать обработку?
   hhhh
 
7 - 01.10.16 - 12:21
(6) ну, не подставляйте цену последнего выбранного товара. Зачем вы решили ее подставлять?

возьмите например из регистра ЦеныНоменклатуры. Или где у вас там в рознице цены находятся?
   Cyberhawk
 
8 - 01.10.16 - 13:38
"По работе приходится делать изменения в конфигурации Розница 2.1" // Во франче работаешь что ли?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует