Вход | Регистрация



Не установлен отбор по регистратору (Регистр накопления: ТоварыНаСкладах)

Не установлен отбор по регистратору (Регистр накопления: ТоварыНаСкладах)
Я
   Sv4org
 
21.09.16 - 11:16
Здравствуйте
Помогите разорбраться в чём ошибка

Процедура ОбработкаПроведения(Отказ, Режим)                                                                              
    
    Рег = РегистрыНакопления.ТоварыНаСкладах;                                                                           
    НаборЗаписей = Рег.СоздатьНаборЗаписей();                                                                       
    ТЗ_Движения = Ссылка.Товар.Выгрузить();                                                                    
    ТЗ = Новый ТаблицаЗначений;
    ТЗ.Колонки.Добавить("Материал", Новый ОписаниеТипов("СправочникСсылка.Номенклатура"));                               
    ТЗ.Колонки.Добавить("Количество", Новый ОписаниеТипов("Число"));                                                     
    ТЗ.Колонки.Добавить("Цена", Новый ОписаниеТипов("Число"));                                                           
    ТЗ.Колонки.Добавить("Сумма", Новый ОписаниеТипов("Число"));                                                             
    ТЗ.Колонки.Добавить("Склад", Новый ОписаниеТипов("СправочникСсылка.Склады"));                                      
    ТЗ.Колонки.Добавить("Организация", Новый ОписаниеТипов("СправочникСсылка.Организация"));                                                           
    ТЗ.Колонки.Добавить("СуммаНДС", Новый ОписаниеТипов("Число"));                                                       
    ТЗ.Колонки.Добавить("Итого",  Новый ОписаниеТипов("Число"));
    Для  Каждого  стр из ТЗ_Движения Цикл 
        Строка= ТЗ.Добавить();                     
        Строка.Материал = стр.Номенклатура;    
        Строка.Количество = стр.Номенклатура;
        Строка.Цена = стр.Номенклатура;
        Строка.Сумма = стр.Номенклатура;
        Строка.Склад = стр.Номенклатура;
        Строка.Организация = стр.Номенклатура;
        Строка.СуммаНДС = стр.Номенклатура;
        Строка.Итого = стр.Номенклатура;
    КонецЦикла;
    НаборЗаписей.Загрузить(ТЗ);    
    НаборЗаписей.Записать();    
    
КонецПроцедуры
 
 
   Spieluhr
 
1 - 21.09.16 - 11:18
давно такого ужаса не видел
   Господин ПЖ
 
2 - 21.09.16 - 11:19
Не установлен отбор по регистратору
   Господин ПЖ
 
3 - 21.09.16 - 11:20
ну и есть ощущение что РН имеется в коллекции движений документа откуда вызывается проведение. читать мурзилки как пишутся движения
   vicof
 
4 - 21.09.16 - 11:21
И копирование - это зло
   Sv4org
 
5 - 21.09.16 - 11:23
(2) а как установить отбор?
(4) в каком смысле копирование?
   ДемонМаксвелла
 
6 - 21.09.16 - 11:23
(1), (2) +
   lera01
 
7 - 21.09.16 - 11:24
(4) А может, так задумано? Одна сплошная номенклатура. Вирус на 1С человек пишет!
   Господин ПЖ
 
8 - 21.09.16 - 11:25
(5) >а как установить отбор?

читая мурзилки по языку
   Vanilla26
 
9 - 21.09.16 - 11:27
(0) Ну нафик) используй конструктор движений
   lera01
 
10 - 21.09.16 - 11:27
(0) А зачем вообще такие страсти? Не пробовали воспользоваться конструктором движений?
 
 Рекламное место пустует
   Sv4org
 
11 - 21.09.16 - 11:29
(10) условие было создать таблицу значиний и повести движение
   DDwe
 
12 - 21.09.16 - 11:30
Конструктор движений уже предлагали?
   vicof
 
13 - 21.09.16 - 11:30
(11) И как? повел?
   DDwe
 
14 - 21.09.16 - 11:30
(11) Куда ты его поведешь?
   Господин ПЖ
 
15 - 21.09.16 - 11:30
(11) допустим. но набор то зачем тут создавать
   Sv4org
 
16 - 21.09.16 - 11:33
(13) (14) Ошибся "провести"
   Vanilla26
 
17 - 21.09.16 - 11:34
(16) это в документе или вн обработке?
   Sv4org
 
18 - 21.09.16 - 11:35
(15) а как по другому сделать?
(17) в документе
   Господин ПЖ
 
19 - 21.09.16 - 11:36
у документа есть .Движения
   Vanilla26
 
20 - 21.09.16 - 11:37
(18) тогда (9) (10) (12)
   Sv4org
 
21 - 21.09.16 - 11:45
(20) я же написал что просили сделать не используя конструктор движений
   Vanilla26
 
22 - 21.09.16 - 11:50
(21) а ты пока никто не видит запусти его, посмотри хоть зачем он нужен
   Sv4org
 
23 - 21.09.16 - 11:54
(22) да я обработку проведения сделал через конструктор движений но попросили переделать
   Vanilla26
 
24 - 21.09.16 - 12:04
(23) а что им не понравилось?
   Sv4org
 
25 - 21.09.16 - 12:09
(24) Сказали что всё нормально но нужно переделать
   Sv4org
 
26 - 22.09.16 - 09:27
Ребята помогите разобраться
Процедура ОбработкаПроведения(Отказ, Режим)                                                                              
    
    Рег = РегистрыНакопления.ТоварыНаСкладах;  
          
    НаборЗаписей = РегистрыНакопления.ТоварыНаСкладах.СоздатьНаборЗаписей();  
    
    НаборЗаписей.Отбор.Регистратор.Установить(Ссылка);    
    ТЗ = Новый ТаблицаЗначений;
    ТЗ_Движения = Ссылка.Товар.Выгрузить();
    ТЗ.Колонки.Добавить("Период", Новый ОписаниеТипов("Дата"));
    ТЗ.Колонки.Добавить("Материал", Новый ОписаниеТипов("СправочникСсылка.Номенклатура"));                               
    ТЗ.Колонки.Добавить("Количество", Новый ОписаниеТипов("Число"));                                                     
    ТЗ.Колонки.Добавить("Цена", Новый ОписаниеТипов("Число"));                                                           
    ТЗ.Колонки.Добавить("Сумма", Новый ОписаниеТипов("Число"));                                                             
    ТЗ.Колонки.Добавить("Склад", Новый ОписаниеТипов("СправочникСсылка.Склады"));                                      
    ТЗ.Колонки.Добавить("Организация", Новый ОписаниеТипов("СправочникСсылка.Организация"));                             
    ТЗ.Колонки.Добавить("СтавкаНДС",  Новый ОписаниеТипов("ПеречислениеСсылка.СтавкиНДС"));                                  
    ТЗ.Колонки.Добавить("СуммаНДС", Новый ОписаниеТипов("Число"));                                                       
    ТЗ.Колонки.Добавить("Итого",  Новый ОписаниеТипов("Число"));
    
        Для  Каждого  стр из ТЗ_Движения Цикл 
        НоваяЗапись = НаборЗаписей.Добавить();
        НаборЗаписей.Прочитать(); 
        Строка = ТЗ.Добавить();
        Строка.Период = Ссылка.Дата;    
        Строка.Материал = стр.Номенклатура;    
        Строка.Количество = стр.Количество;
        Строка.Цена = стр.Цена;
        Строка.Сумма = стр.Сумма;
        Строка.Склад = Ссылка.Склад;
        Строка.Организация = Ссылка.Организация;
        Строка.СтавкаНДС = стр.СтавкиНДС;
        Строка.СуммаНДС = стр.СуммаНДС;
        Строка.Итого = стр.Итого;    
    КонецЦикла;
    НаборЗаписей.Загрузить(ТЗ);    
    НаборЗаписей.Записать(Истина);    
КонецПроцедуры

Подскажите кто-нибудь как сделать что-бы можно было провести движение ещё по одному регистру "Остатки Матералов"
   Sv4org
 
27 - 22.09.16 - 10:04
уже не надо сделал
всем спасибо


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует