Вход | Регистрация


Нестандартная расшифровка СКД

Нестандартная расшифровка СКД
Я
   N e o N
 
20.09.16 - 10:55
Необходимо, чтобы при двойном клике по ячейке формировалась расшифровка по регистратору в отдельной форме.

Пока удалось реализовать расшифровку в текущей форме.

&НаКлиенте
Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;    
    ОтработатьРасшифровку(Расшифровка);

КонецПроцедуры

&НаСервере
Процедура ОтработатьРасшифровку(Расшифровка)
    
    
    ОбработкаРасшифровки  = Новый ОбработкаРасшифровкиКомпоновкиДанных(ДанныеРасшифровки, Новый ИсточникДоступныхНастроекКомпоновкиДанных(Отчет));
    НастройкиКомпоновки = ОбработкаРасшифровки.Расшифровать(Расшифровка, Новый ПолеКомпоновкиДанных("Регистратор"));
        
    Если ТипЗнч(НастройкиКомпоновки) = Тип("НастройкиКомпоновкиДанных") Тогда
        Отчет.КомпоновщикНастроек.ЗагрузитьНастройки(НастройкиКомпоновки);
    ИначеЕсли ТипЗнч(НастройкиКомпоновки) = Тип("ПользовательскиеНастройкиКомпоновкиДанных") Тогда
        Отчет.КомпоновщикНастроек.ЗагрузитьПользовательскиеНастройки(НастройкиКомпоновки);
    КонецЕсли;
    
    СкомпоноватьРезультат();
    
КонецПроцедуры

Как сдлать, чтобы рашифровка открывалась в отдельной форме?
 
 
   aleks_default
 
1 - 20.09.16 - 11:04
Создавать отдельный объект отчета, а не изменять настройки текущего
   N e o N
 
2 - 20.09.16 - 11:10
Я, в принципе понимаю, что нужно создать отдельный объект. Ситуация усложняется тем, что это внешний отчет. Можно пример пожалуйста.

Пока у меня так.

&НаКлиенте
Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    
    АдресХранилища = "";
    Результат = ПоместитьФайл(АдресХранилища, "C:\Users\noviy1sadmintest\Desktop\ВаловаяПрибыльV6.erf", , Ложь);
    
    ОтработатьРасшифровку(Расшифровка, АдресХранилища);

КонецПроцедуры

&НаСервере
Процедура ОтработатьРасшифровку(Расшифровка, АдресХранилища)
    
    
    ОбработкаРасшифровки  = Новый ОбработкаРасшифровкиКомпоновкиДанных(ДанныеРасшифровки, Новый ИсточникДоступныхНастроекКомпоновкиДанных(Отчет));
    НастройкиКомпоновки = ОбработкаРасшифровки.Расшифровать(Расшифровка, Новый ПолеКомпоновкиДанных("Регистратор"));
    
    ИмяОтчета = ВнешниеОтчеты.Подключить(АдресХранилища, "ВаловаяПрибыль123");
    
    ОтчетДляРасшифровки = ВнешниеОтчеты.Создать(ИмяОтчета);
    Если ТипЗнч(НастройкиКомпоновки) = Тип("НастройкиКомпоновкиДанных") Тогда
        ОтчетДляРасшифровки.КомпоновщикНастроек.ЗагрузитьНастройки(НастройкиКомпоновки);
    ИначеЕсли ТипЗнч(НастройкиКомпоновки) = Тип("ПользовательскиеНастройкиКомпоновкиДанных") Тогда
        ОтчетДляРасшифровки.КомпоновщикНастроек.ЗагрузитьПользовательскиеНастройки(НастройкиКомпоновки);
    КонецЕсли;    
    ОтчетДляРасшифровки.СкомпоноватьРезультат();
    
КонецПроцедуры


Ругается на нехватку параметров при СкомпоноватьРезультат().
   vicof
 
3 - 20.09.16 - 11:11
(2) Продам СП. Дорого.
   N e o N
 
4 - 20.09.16 - 11:22
(3) Вопрос в том, что именно передать. Формы на сервере то нет.
   aleks_default
 
5 - 20.09.16 - 11:24
АдресХранилища тебе на что?
   N e o N
 
6 - 20.09.16 - 11:39
(5) Не могу разобраться. Есть возможность дать пример или изменить мой?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует