Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Программное восстановление настроек

v7: Программное восстановление настроек
Я
   victuan1
 
19.09.16 - 05:25
Как программно в отчете восстановить значение атрибутов формы из настроек, сохраненных пользователем (по кнопке "Сохранить настройку")?
 
 
   trdm
 
1 - 19.09.16 - 07:41
Распарсить *.lst файл настройки и вытянуть оттуда значения и востановить
   trdm
 
2 - 19.09.16 - 07:43
или можно тут поискать: http://www.1cpp.ru/forum/YaBB.pl
   victuan1
 
3 - 19.09.16 - 08:00
(1) Думал, есть простое "бюджетное" решение))
Спасибо, будем смотреть.
   Djelf
 
4 - 19.09.16 - 13:55
Сложно ищется, хорошо еще помнил что такое было...
http://catalog.mista.ru/public/16532/
   Djelf
 
5 - 19.09.16 - 14:15
Не совсем то...
Можно formex`ом перехватить ПриЧтенииНастройки(Имя, ФСО) и ПриЗаписиНастройки(Имя, ФСО)
Правда я еще ПослеЧтенияНастройки() сделал т.к. ПриЧтенииНастройки не достаточно для подмены значений.

Перем СобытиеПриЧтенииНастройки;

Процедура ПриЧтенииНастройки(ИмяНастройки,ФСО)
    СобытиеПриЧтенииНастройки=1;
КонецПроцедуры

Процедура ПослеЧтенияНастройки()

КонецПроцедуры

Процедура ПослеОбновленияФормы()
    Если СобытиеПриЧтенииНастройки=1 Тогда
        СобытиеПриЧтенииНастройки=0;    
        ПослеЧтенияНастройки();
    КонецЕсли;
КонецПроцедуры


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует