Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Программное создание Операции БУХ (СТОРНО) в программе 1С8:Бухгалтерия 3.0

Программное создание Операции БУХ (СТОРНО) в программе 1С8:Бухгалтерия 3.0
Я
   Bell
 
17.09.16 - 17:44
Программно создаю документ "Операция БУХ"/СТОРНО, заполняю поле "Сторнируемый документ" и т.д.
Но при программном создании не заполняются движения из сторнируемого документа.
Если в созданном документе ручками перевыбрать документ, тогда движения заполняются.

Как решить это программно?  Не сталкивался...
 
 
   hhhh
 
1 - 17.09.16 - 17:49
(0) посмотреть, что там происходит при нажатии кнопки, повторить у себя.
   Bell
 
2 - 17.09.16 - 17:53
(1) Сложное решение.
   jsmith
 
3 - 17.09.16 - 17:54
В форме документа

&НаКлиенте
Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)
    
    Если Элементы.СторнируемыйДокумент.ОграничениеТипа.СодержитТип(ТипЗнч(ВыбранноеЗначение)) Тогда
        КорректируемыйДокумент = ВыбранноеЗначение;
        СформироватьДвиженияСторноСервер();
        УстановитьВидимостьГруппыСторно();
    КонецЕсли;
    
КонецПроцедуры

&НаСервере
Процедура СформироватьДвиженияСторноСервер()
    
    Если НЕ ПроверитьЗаполнение() Тогда
        Возврат;
    КонецЕсли;
    
    Для каждого СтрокаРегистра Из Регистры Цикл
        Если Объект.Движения[СтрокаРегистра.Имя].Количество() = 0 Тогда
            Продолжить;
        КонецЕсли;
        Объект.Движения[СтрокаРегистра.Имя].Очистить();
    КонецЦикла;

    //Формирование движений

    Если ФлажокСписок Тогда
        ВыполнитьСторнированиеДокументов(Объект.ЗаполнениеДвижений);
    Иначе
        ТЗДокументов = новый ТаблицаЗначений;
        ТЗДокументов.Колонки.Добавить("Документ");
        ТЗДокументов.Добавить().Документ = КорректируемыйДокумент;
        ВыполнитьСторнированиеДокументов(ТЗДокументов);
    КонецЕсли;

    ОбновитьИтогиПоДокументу(ЭтотОбъект);
    
    УстановитьДоступностьСубконто();
    
    ОбновитьФорму();

КонецПроцедуры
   Bell
 
4 - 17.09.16 - 18:17
Исходно было написано следующее:

            ДокСт = Документы.ОперацияБух.СоздатьДокумент();
            ДокСт.Дата =ОбщийМодульТур.УстановитьВремяДокумента(ДатаОперации,16);
            ДокСт.СпособЗаполнения ="Сторно";        
            ДокСт.Организация = Объект.Организация;
            ДокСт.СторнируемыйДокумент  =  ТекДок.СвязанныйДок;
            
            ДокСт.Комментарий = "Сторнирование компоненты тура = "+Объект.Номер;
            ДокСт.Записать(РежимЗаписиДокумента.Запись);
   jsmith
 
5 - 17.09.16 - 18:28
(4) В чом и косяк, бро
Такшта давай, дописывай
   Bell
 
6 - 17.09.16 - 18:51
Так документы разные. Как я влезу в док.ОперацияБух из своего?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует