Вход | Регистрация


Подключение ОбработчикаОповещения

Подключение ОбработчикаОповещения
Я
   Hellbet
 
16.09.16 - 13:23
Процедура глОбработкаОповещения(Событие, Параметр, Источник) Экспорт
    Сообщить("глОбработкаОповещения ИмяСобытия = " + Событие);
КонецПроцедуры

&НаКлиенте
Процедура Команда4(Команда)
    
    ПодключитьОбработчикОповещения("глОбработкаОповещения");
 
    
КонецПроцедуры
Выходит ошибка:
{Документ.ПоступлениеТоваров.Форма.ФормаДокумента1.Форма(131)}: Ошибка при вызове метода контекста (ПодключитьОбработчикОповещения)
    ПодключитьОбработчикОповещения("глОбработкаОповещения");
по причине:
Недопустимое значение параметра (параметр номер '1')
 
 
   polosov
 
1 - 16.09.16 - 13:25
(0)
&НаКлиенте
Процедура глОбработкаОповещения(Событие, Параметр, Источник) Экспорт
    Сообщить("глОбработкаОповещения ИмяСобытия = " + Событие);
КонецПроцедуры
   polosov
 
2 - 16.09.16 - 13:27
(0) Ну и читай СП
   Hellbet
 
3 - 16.09.16 - 13:30
(2) я прочитал, но не понял
   Сильф
 
4 - 16.09.16 - 13:40
(0) Тщательнее читать надо:

Синтаксис:

ПодключитьОбработчикОповещения(<ИмяПроцедуры>)
Параметры:

<ИмяПроцедуры> (обязательный)

Тип: Строка.
Имя экспортируемой процедуры модуля управляемого приложения (модуля обычного приложения) или общего глобального модуля.
Процедура должна располагаться на клиенте.
Процедура не должна содержать параметров.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует