Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Заполнение табличной части из внешней обработки

Заполнение табличной части из внешней обработки
Я
   Alekzander Wolf
 
16.09.16 - 11:23
Процедура Инициализировать(Объект, ИмяТабличнойЧасти, ТабличноеПолеОбъекта) Экспорт
    ТабличнаяЧасть = Объект[ИмяТабличнойЧасти];
    Если ТабличнаяЧасть.Количество() > 0 Тогда
        Ответ = Вопрос("При заполнении табличную часть """ + ИмяТабличнойЧасти + """ очистить?", РежимДиалогаВопрос.ДаНет,, КодВозвратаДиалога.Нет);
        Если Ответ = КодВозвратаДиалога.Да Тогда
            ТабличнаяЧасть.Очистить();
        иначе
            Возврат;
        КонецЕсли;
    КонецЕсли;            
            
    Форма = ПолучитьФорму("Форма");
    Форма.Открыть();

КонецПроцедуры


Объект добавлен реквизитов во внешнюю обработку. При открытии формы я этого объекта не вижу, в чем дело (до этого также писал все было нормально)?
 
 
   Alekzander Wolf
 
1 - 16.09.16 - 11:24
Реквизит: Объект Тип: ДокументСсылка.ТребованиеНакладная
   Alekzander Wolf
 
2 - 16.09.16 - 11:36
В самой форме этого объекта нет, вынес реквизит на форму
   AceVi
 
3 - 16.09.16 - 11:41
(2) Да при чем тут это.
Ну посмотри по коду - что происходит когда ты нажимаешь на кнопку. проследи путь и посмотри что передается в качестве объекта в саму обработку.
   Alekzander Wolf
 
4 - 16.09.16 - 11:53
(3) ничего не передается
   Альбатрос
 
5 - 16.09.16 - 11:54
На вскидку не называть реквизит "Объект".
   Alekzander Wolf
 
6 - 16.09.16 - 12:28
я так понимаю инициализация не проходит Объекта?
   AceVi
 
7 - 16.09.16 - 12:32
(4) Ну так передай - ты вообще обработку внешней табличной части прикрепил как надо? Сервис - дополнительные обработки - обработки табличных частей.
или сам как то? если сам то и сам передавай.
Если не сам ищи где теряется объект по ходу кода в твоей конфигурации.
   hhhh
 
8 - 16.09.16 - 13:01
(6) а где объект этот передаешь в форму?
   SergTheGreat
 
9 - 16.09.16 - 15:45
(1) Из реквизитов и обработки, и формы удали "Объект". И будет тебе счастье.
   ZZBase
 
10 - 16.09.16 - 16:10
(9) Согласен.

(0) После того как ты добавил реквизит в обработку, ты его жестко типизировал в "ДокументСсылка.ТребованиеНакладная",

Но при вызове этого метода, ему передается не ссылк,а а именно объект, т.е. "ДокументОбъект.ТребованиеНакладная", и при попытке привести тип, реквизит "Объект" так и остается не заполненным

Необходимо убрать реквизит "Объект", как из обработки, так и из формы, чтобы у этой переменной не было жесткой типизации. Тогда можно будет передавать произвольный тип.
 
 Рекламное место пустует

Список тем форума
Рекламное место пустует  Рекламное место пустует
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует