Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Документ с заполнением из документа-основания.

v7: Документ с заполнением из документа-основания.
Я
   vadim777
 
15.09.16 - 14:53
Акт оприходования излишков заполняется на основании Акта инвентаризации.
Акт оприходования открыт.
Меняем что-то в Акте инвентаризации, закрываем его.
В Акте оприходования жмем заполнить - и ничего.
Даже перевыбор документа-основания не помогает.
Нужно закрыть и снова открыть Акт оприходования, только тогда его можно перезаполнить.
Почему?
 
 
   Ёпрст
 
1 - 15.09.16 - 14:54
(0) добрый дядюшка пофигуратор расскажет
   vadim777
 
2 - 15.09.16 - 14:55
(0) Вру, при перевыборе основания - перезаполняет.
   vadim777
 
3 - 15.09.16 - 14:58
Текст процедуры Заполнить:

Процедура Заполнить()
    Если ДокументОснование.Выбран() = 0 Тогда
        Предупреждение("Не выбран документ-основание");
        Возврат;
    КонецЕсли;
    УдалитьСтроки();
    ДокОснование = ДокументОснование;
    ДокОснование.ВыбратьСтроки();
    Пока ДокОснование.ПолучитьСтроку()=1 Цикл
        Если (ДокОснование.Количество > 0) И (ДокОснование.Количество < ДокОснование.ИнвКоличество) Тогда
            НоваяСтрока();
            Номенклатура=ДокОснование.Номенклатура;
            Размер = ДокОснование.Размер;
            Количество=ДокОснование.ИнвКоличество-ДокОснование.Количество;
            ЦенаПродажи = ДокОснование.ЦенаПродажи;
            Размер = ДокОснование.Размер;
            Стоимость = ЦенаПродажи * Количество;
            // Общие реквизиты

            ОбщаяСумма = Стоимость;
            ПродажнаяСумма = Стоимость;
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры
   vadim777
 
4 - 15.09.16 - 15:02
Хм, заменил строку
ДокОснование = ДокументОснование;
на
ДокОснование = ДокументОснование.ТекущийДокумент();
- заработало как надо.
Благодарю всех участников.
   trdm
 
5 - 15.09.16 - 15:40
(0) > Почему?

Кеширование переменных в памяти 1С на определенное время.
А в переменных сидят объекты.
В 8-ке та же самая херня, однако там рекомендация спасает: выбирать данные запросом, что-бы была актуальными.
   vadim777
 
6 - 15.09.16 - 18:54
(5) За основу был взят документ ОприходованиеИзлишков из украинской ТиС. Эта ошибка в ней - с самого первого релиза.
Посмотрел российскую - в ней сделано через запрос.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует