Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Автоматическое получение курсов валют

Автоматическое получение курсов валют
Я
   Darchick
 
15.09.16 - 08:01
Всем привет. Имею: самописная конфигурация, платформа 8.3.5.1248. С помощью следующей функции получаю курсы валют:

Функция КурсВалютыНаДату(КодВалюты="USD",НаДату = Неопределено) Экспорт

   Если (НаДату = Неопределено) ИЛИ (НаДату = '00010101') Тогда
            НаДату = ТекущаяДата();
    КонецЕсли;
    АдресЦБРФ = "http://www.cbr.ru/scripts/XML_daily.asp?date_req="; + Формат(НаДату,"ДФ=dd.MM.yyyy");
    Чт = Новый ЧтениеXML;
    Попытка
        Чт.ОткрытьФайл(АдресЦБРФ);
    Исключение
        Возврат Неопределено;
    КонецПопытки;
    Пока Чт.Прочитать() Цикл
            Если Чт.Значение = КодВалюты Тогда
            ИскомаяВалюта = Истина;    
        КонецЕсли;
        Если ИскомаяВалюта = Истина Тогда
            Если Чт.Имя = "Value" Тогда
                Чт.Прочитать();
                СтрокаКурса = Чт.Значение;
                Чт.Закрыть();
                Возврат СтрокаКурса;
            КонецЕсли;
        КонецЕсли;    
    КонецЦикла;      
КонецФункции

Обновляю платформу (причем без разницы на какую, делала несколько раз, сейчас стоит 8.3.8.2054). При вызове функции КурсВалютыНаДату получаю ошибку
{ОбщийМодуль.РаботаСВалютой.Модуль(32)}: Ошибка при вызове метода контекста (Прочитать)
    Пока Чт.Прочитать() Цикл
по причине:
Ошибка разбора XML:  - [1,1]
Фатальная ошибка:
Extra content at the end of the document
SystemId: http://www.cbr.ru/scripts/XML_daily.asp?date_req=15.09.2016
Файл тот же читается и разбирается.
Возращаюсь к платформе 8.3.5.1248 - все нормально.
Кто знает, может сталкивался с таким, что делать?
 
 
   butterbean
 
1 - 15.09.16 - 08:38
попробуй загрузить сначала файл через http-соединение, а потом уже разбирать его
   Darchick
 
2 - 15.09.16 - 09:13
(1) Спасибо попробую. Я вот думаю, не может быть проблема с кодировкой...

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует