Вход | Регистрация


результат запроса в таб часть

результат запроса в таб часть
Я
   ZloyRafa
 
13.09.16 - 07:49
Привет, есть запрос, результат таблица 2*2
как я могу поместить его в новый документ с таб.частью 2*2?
 
 
   DDwe
 
1 - 13.09.16 - 07:50
(0) Теперь подробнее.
   DDwe
 
2 - 13.09.16 - 07:51
(0) А отвечая на твой вопрос - с помощью программного кода.
   KODin1C
 
3 - 13.09.16 - 07:51
Если структура совпадает - загрузить
   ZloyRafa
 
4 - 13.09.16 - 07:54
(2) Это да, но как именно.
   ZloyRafa
 
5 - 13.09.16 - 07:55
Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    ВзаиморасчетыСПокупателямиОстатки.Контрагент КАК Контрагент,
        |    ВзаиморасчетыСПокупателямиОстатки.Документ КАК Документ,
        |    ВзаиморасчетыСПокупателямиОстатки.СуммаОстаток КАК СуммаОстаток
        |ИЗ
        |    РегистрНакопления.ВзаиморасчетыСПокупателями.Остатки(, Контрагент = &контрагент) КАК ВзаиморасчетыСПокупателямиОстатки";
    
    Запрос.УстановитьПараметр("контрагент", Объект.контрагент);
    //Запрос.УстановитьПараметр("МоментВремени", МоментВремени());

    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        Для каждого Элемент из ВыборкаДетальныеЗаписи Цикл
        Элементы.Накладные.Накладная=Элемент.Документ;
        Элементы.Накладные.Сумма=Элемент.СуммаОстаток;
    КонецЦикла;
    КонецЦикла;
   Mankubus
 
6 - 13.09.16 - 07:58
(5) ТабличнаяЧасть.Загрузить(Запрос.Выполнить().Выгрузить())
   ZloyRafa
 
7 - 13.09.16 - 08:12
(6) не понял. :(
   ZloyRafa
 
8 - 13.09.16 - 08:31
Есть кто может подсказать ?
   KODin1C
 
9 - 13.09.16 - 08:33
(8)

таблицаЗначенийСРезультатамиЗАпроса = Запрос.Выполнить().Выгрузить()
ТабличнаяЧасть.Загрузить(таблицаЗначенийСРезультатамиЗАпроса )
   vicof
 
10 - 13.09.16 - 08:36
(0) а книжки почитать не предлагать?
 
 Рекламное место пустует
   ZloyRafa
 
11 - 13.09.16 - 08:47
(10) Если есть подробно расписанное действо, то кидать
   Artificial
 
12 - 13.09.16 - 09:40
(11) Тебе в (6) сказали.
   1dvd
 
13 - 13.09.16 - 09:41
подробнее напиши что именно не получается
   ZloyRafa
 
14 - 13.09.16 - 10:05
&НаКлиенте
Процедура КонтрагентПриИзменении(Элемент)
    КонтрагентПриИзмененииНаСервере();
КонецПроцедуры

&НаСервере
Процедура КонтрагентПриИзмененииНаСервере()
          //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА

    // Данный фрагмент построен конструктором.

    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

    
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    ВзаиморасчетыСПокупателямиОстатки.Контрагент,
        |    ВзаиморасчетыСПокупателямиОстатки.Документ,
        |    ВзаиморасчетыСПокупателямиОстатки.СуммаОстаток
        |ИЗ
        |    РегистрНакопления.ВзаиморасчетыСПокупателями.Остатки(&МоментВремени, Контрагент = &Контрагент) КАК ВзаиморасчетыСПокупателямиОстатки";
    
    Запрос.УстановитьПараметр("Контрагент", Объект.Контрагент);
    Запрос.УстановитьПараметр("МоментВремени", МоментВремени());
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        // Вставить обработку выборки ВыборкаДетальныеЗаписи

    КонецЦикла;
    
    //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА


КонецПроцедуры

Начну с того, что МоментВремени() не определяется, результат запроса в ТЗ выгружу, нужно передать на клиент ТЗ? далее создать в пустой ТЧ таблицу точь-в-точь как ТЗ, как организовать уже не соображу, может от не знания или перебора с решением
   hhhh
 
15 - 13.09.16 - 10:17
Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    ВзаиморасчетыСПокупателямиОстатки.Контрагент,
        |    ВзаиморасчетыСПокупателямиОстатки.Документ,
        |    ВзаиморасчетыСПокупателямиОстатки.СуммаОстаток
        |ИЗ
        |    РегистрНакопления.ВзаиморасчетыСПокупателями.Остатки(&МоментВремени, Контрагент = &Контрагент) КАК ВзаиморасчетыСПокупателямиОстатки";
    
    Запрос.УстановитьПараметр("Контрагент", Объект.Контрагент);

ДокументОбъект = РеквизитФормыВЗначение("Объект");

    Запрос.УстановитьПараметр("МоментВремени", ДокументОбъект.МоментВремени());
    

  ДокументОбъект.ТвояТЧ.Загрузить(Запрос.Выполинть().Выгрузить();

ЗначениеВРеквизитФормы(ДОкументОбъект, "Объект");
 

ну еще - поля в запросе сделайте как в табличной части.
   ZloyRafa
 
16 - 13.09.16 - 10:49
(15) Спасибо большое!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует