Вход | Регистрация


Кнопка печать в 1с 8.3

Кнопка печать в 1с 8.3
Я
   Нач программист
 
13.09.16 - 07:37
&НаСервере
Процедура ПечатьНаСервере(ТабличныйДокумент, ПараметрКоманды)
    Документы.ВедомостьНачислений.Печать(ТабличныйДокумент, ПараметрКоманды);
КонецПроцедуры

&НаКлиенте
Функция СформироватьПечатнуюФорму(СсылкаНаОбъект, ОбъектыПечати)
    
    
    ТабличныйДокумент = Новый ТабличныйДокумент;
    МакетОбработки = РеквизитФормыВЗначение("Объект").ПолучитьМакет("МакетВедомостьНачислений");
    
    
    ОбластьШапки=МакетОбработки.ПолучитьОбласть("Шапка");
    
    ОбластьШапки.Параметры.НомерРеализации=СсылкаНаОбъект.Номер;
    ОбластьШапки.Параметры.ДатаРеализации=Формат(СсылкаНаОбъект.Дата, "ДЛФ=DD");
    
    ТабличныйДокумент.Вывести(ОбластьШапки);
    
    
    ОбластьСтроки=МакетОбработки.ПолучитьОбласть("СтрокаТЧ");
    
    Для Каждого ТекущаяСтрока Из СсылкаНаОбъект.ВедомостьНачислений Цикл
        
        ОбластьСтроки.Параметры.Номер=ТекущаяСтрока.1
        ОбластьСтроки.Параметры.ФИО=ТекущаяСтрока.Контрагент;
        ОбластьСтроки.Параметры.НомерКонтракта=ТекущаяСтрока.Количество;
        ОбластьСтроки.Параметры.ИНН=ТекущаяСтрока.Сумма;
        ОбластьСтроки.Параметры.НомерДоговора=ТекущаяСтрока.Сумма;
        ОбластьСтроки.Параметры.ДатаДоговора=ТекущаяСтрока.Сумма;
        ОбластьСтроки.Параметры.НомерАкта=ТекущаяСтрока.Сумма;
        ОбластьСтроки.Параметры.ДатаАкта=ТекущаяСтрока.Сумма;
        ОбластьСтроки.Параметры.СуммаВТенге=ТекущаяСтрока.Сумма;
        
        ТабличныйДокумент.Вывести(ОбластьСтроки);
                
    КонецЦикла;
    
    ОбластьПодвала=МакетОбработки.ПолучитьОбласть("Подвал");
    
    ОбластьПодвала.Параметры.ВсегоКОплате=СсылкаНаОбъект.Товары.Итог("Сумма");
    
    ТабличныйДокумент.Вывести(ОбластьПодвала);
    
    Возврат ТабличныйДокумент;
    
    
КонецФункции
 
 
   Нач программист
 
1 - 13.09.16 - 07:39
Впервые делаю можете помочь
   Mankubus
 
2 - 13.09.16 - 07:41
а в чем вопрос?
   Нач программист
 
3 - 13.09.16 - 07:42
Отладке есть кнопка печать но оно не работает
   Нач программист
 
4 - 13.09.16 - 07:46
Или можете дать ссылку похожую на эту тему
   Mankubus
 
5 - 13.09.16 - 07:46
(3) ок, будем знать
   Нач программист
 
6 - 13.09.16 - 07:55
Как получить данные из Документа ВедомостьНачислений и вывести при нажати кнопки Печать
   iceman2112
 
7 - 13.09.16 - 11:53
держи нас в курсе уточнения вопроса

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует