Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Отчет по счетам

v7: Отчет по счетам
Я
   MaxMelnikov
 
13.09.16 - 03:34
Доброго времени суток. Никогда не работал в бухгалтерии 1С 7.7.
Думал, что делается всё по аналогии с 1С Предприятие 8.2. Но не тут-то было. Нужна ваша помощь. Думаю задача простая:

В конфигурации есть документ "Счет" (в программе Журналы - Счета).
Нужно сформировать отчёт, содержащий следующие колонки:
Реквизиты шапки: Контрагент. Реквизиты табличной части: Товар, Количество, Сумма.

На форме отчета предоставить возможность выбора периода времени, контрагента и товара. За любую информацию или наставление буду очень благодарен. Спасибо.
 
 
   mehfk
 
1 - 13.09.16 - 04:03
Воспользуйся конструктором отчета.
   Dump
 
2 - 13.09.16 - 09:45
Делайте отчет по документам
   HawkEye
 
3 - 13.09.16 - 09:53
(0) надо открыть конфигуратор
   RoRu
 
4 - 13.09.16 - 10:00
(3) если без выбора товара - то и универсальным отчётом можно
точно не помню, может даже есть и с отбором по ТЧ
   HawkEye
 
5 - 13.09.16 - 10:03
(4) ты уверен, что именно я нуждаюсь в этой информации? )))
   Злопчинский
 
6 - 13.09.16 - 10:44
(0) Это тебе не галочки расставлять. тут квалификация нужна...
   Злопчинский
 
7 - 13.09.16 - 10:45
Типовой отчет с ИТС "Универсальная печать документов", ставится в наборе универсальных отчетов и обработок.

"... как низко пал секам..."
   MaxMelnikov
 
8 - 13.09.16 - 15:50
Использую конструктор бухгалтерских запросов. Схема "Произвольная". Ставлю галочку период в диалоге формы. Итоги по всем счетам. Также на форму вытащил ограничение по субконто "Контрагенты". Добавил колонку "Период - Месяц". В строку добавил "Субконто - Номенклатура". При формировании отчёта никаких строк нет. Хотя в номенклатуре для каждого Контрагента есть строки с наименованиями услуг.
   HawkEye
 
9 - 13.09.16 - 15:52
(8) какая связь документа счет и бухгалтерских запросов?
   Злопчинский
 
10 - 13.09.16 - 18:39
В бух 77 документ счёт всего лишь болванка и нигде в учете не фигурирует
 
 Рекламное место пустует
   Dump
 
11 - 13.09.16 - 18:57
(8)
Делайте отчет по документам
Делайте отчет по документам
Делайте отчет по документам
Делайте отчет по документам
...
   RoRu
 
12 - 13.09.16 - 19:25
(8) не смог осилить (7) ?
если надо именно сделать, то делай просто конструктором запросов
   vadim777
 
13 - 13.09.16 - 19:42
(0) Эххх...
Перем Счета, тзСчета;
тзСчета = СоздатьОбъект("ТаблицаЗначений");
тзСчета.ДобавитьКолонку("Контрагент");
тзСчета.ДобавитьКолонку("Товар");
тзСчета.ДобавитьКолонку("Количество");
тзСчета.ДобавитьКолонку("Сумма");
Счета = СоздатьОбъект("Документ.Счет");
Счета.ВыбратьДокумента(Дата1, Дата2);
Пока Счета.ПолучитьДокумент()=1 Цикл
    Счет=Счета.ТекущийДокумент();
    Если Счет.ПометкаУдаления() = 1 Тогда
        Продолжить;
    КонецЕсли;
    Если Счет.Контрагент <> ВыбКонтрагент Тогда
        Продолжить;
    КонецЕсли;
    Счет.ВыбратьСтроки();
    Пока Счет.ПолучитьСтроку()=1 Тогда
        Если Счет.Товар <> ВыбТовар Тогда
            Продолжить;
        КонецЕсли;
        тзСчета.НоваяСтрока();
        тзСчета.Контрагент=Счет.Контрагент;
        тзСчета.Товар=Счет.Товар;
        тзСчета.Количество=Счет.Количество;
        тзСчета.Сумма=Счет.Сумма;
    КонецЦикла;
КонецЦикла;
// Вывод отчета

Таб=СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Таблица");
тзСчета.ПолучитьСтрокуПоНомеру(1);
Таб.ВывестиСекцию("Шапка");
Таб.Опции(0,0,Таб.ВысотаТаблицы(),0,,,,);
тзСчета.ВыбратьСтроки();
Пока тзСчета.ПолучитьСтроку()=1 Цикл
    Таб.ВывестиСекцию("Строка");
КонецЦикла;
Таб.ТолькоПросмотр(1);
Таб.Показать("Заказы по контрагенту и товару","");

Устроит?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует