Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Исчезают данные в тонком клиенте

Исчезают данные в тонком клиенте
Я
   breezee
 
12.09.16 - 17:56
Добрый вечер! У меня есть ТЧ внешней обработки. С Формы я вызваю вот такие процедуры
&НаСервере
Процедура ЗаполнитьНаСервере()
    мОб = РеквизитФормыВЗначение("Объект");
    Моб.ЗаполнитьСписокОтчетовЭкспорт();
КонецПроцедуры

&НаКлиенте
Процедура Заполнить(Команда)    
    ЗаполнитьНаСервере();
КонецПроцедуры

В экспортной процедуре ЗаполнитьСписокОтчетовЭкспорт() - заполняется моя ТЧ. После этого обращаюсь из другой процедуры к моей ТЧ, которая была заполнена(я в отладке смотрел) - она уже не заполнена. Подскажите, что за магия?
 
 
   breezee
 
1 - 12.09.16 - 17:58
Вот конец процедуры где я добавляю строки в ТЧ моей внешней обработки
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        
        нСтрока = ОтчетыДляПересчета.Добавить();
        нСтрока.ПериодОтчета = стрПериод.Период;
        ЗаполнитьЗначенияСвойств(нСтрока, ВыборкаДетальныеЗаписи);
    
    КонецЦикла;
    
    КонецЦикла;

КонецПроцедуры
   DmitrO
 
2 - 12.09.16 - 18:04
мОб = РеквизитФормыВЗначение("Объект");
 Моб.ЗаполнитьСписокОтчетовЭкспорт();
 ЗначениеВРеквизитФормы(Моб, "Объект");
   DmitrO
 
3 - 12.09.16 - 18:06
>>что за магия?
мания управляемого интерфейса
   DmitrO
 
4 - 12.09.16 - 18:06
*магия
   breezee
 
5 - 12.09.16 - 18:06
(2) Спасибо большое!!!
   breezee
 
6 - 12.09.16 - 18:07
(4) Как по мне - колдунство довольно злое))
   breezee
 
7 - 12.09.16 - 18:08
(4) Точно пора спать. Сейчас 10 секунд пытался пальцем стереть "*" в твоем комментарии. Еще раз спасибо. Я пошел
   DmitrO
 
8 - 12.09.16 - 18:15
ога, наверно 99% объектов во всех работающих сейчас реальных конфигурациях (СправочникОбъект, ДокументОбъект, ОбработкаОбъект и т.п. те что живут только на сервере) имеют только сериализуемые данные в своем состоянии, соответственно теоретически могут быть переданы и обработаны на клиенте как родные, без преобразования в универсальные суррогаты типа ДанныеФормы..

Но 1С, вместо того чтобы попросту навесить ограничения, придумала вот такую модель, которую сейчас имеем.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Чтобы обнаруживать ошибки, программист должен иметь ум, которому доставляет удовольствие находить изъяны там, где, казалось, царят красота и совершенство.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует