Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Внешняя печатная форма для документа ПоступлениеТоваровУслуг в УТ11

Внешняя печатная форма для документа ПоступлениеТоваровУслуг в УТ11
Я
   Jalib
 
12.09.16 - 12:40
Здравствуйте,с праздником!необходимо для документа ПоступлениеТоваровУслуг создать  внешнюю печатную форму. за основу взять стандартную форму этого документа не много изменить её.вопрос в том что я не в модуле формы этого документа ни в модуле объекта не вижу процедуры или функции "Печать". она как то по другому называется или не там ищу?
 
 
   Boleev
 
1 - 12.09.16 - 12:42
Модуль менеджера
   Jalib
 
2 - 12.09.16 - 13:04
я правильно понимаю, функция СформироватьПечатнуюФормуНакладная это и есть функция которая отвечает за формирование печатной формы "ФормаДокумента"?
   Jalib
 
3 - 12.09.16 - 19:44
извиняюсь что то совсем забыл что внешние печатные формы делаются совсем по другому.теперь вопрос, как их отлаживать? ведь стандартный отладчик здесь не работает пишет, "в обработчике печати не был сформирован табличный документ для ПоступлениеТоваровиУслуг" и как тут понять где ошибка?
   C0oLZ3r0
 
4 - 12.09.16 - 20:18
Возьмите любую здесь: http://www.cheapepf.ru/items/index и посмотрите как сделано
   Jalib
 
5 - 12.09.16 - 20:48
вопрос не в том как их делать ,а в том как их отлаживать в пошаговом режиме если такое вообще возможно?
   Cyberhawk
 
6 - 12.09.16 - 21:15
(5) Если версия БСП ниже 2.2, то легко (подключаемые обработки там создаются как временный файл на диске). Если версия БСП не ниже 2.2, то без изменения конфигурации не отладишь (подключаемые обработки создаются там сразу в памяти), встраивай, например, ИР в конфигруацию
   Jalib
 
7 - 13.09.16 - 12:04
не могу понять где тут ошибка?игнорируются циклы заполнения областей макета"строкатаблицысоскидкой"и"строкатаблицы"
Запрос = Новый Запрос("ВЫБРАТЬ
|    ПоступлениеТоваровУслуг.Ссылка КАК Ссылка,
|    ПоступлениеТоваровУслуг.ВерсияДанных,
|    ПоступлениеТоваровУслуг.ПометкаУдаления,
|    ПоступлениеТоваровУслуг.Номер,
|    ПоступлениеТоваровУслуг.Дата,
|    ПоступлениеТоваровУслуг.Проведен,
|    ПоступлениеТоваровУслуг.Валюта,
|    ПоступлениеТоваровУслуг.Партнер как ПредставлениеПоставщика,
|    ПоступлениеТоваровУслуг.Соглашение,
|    ПоступлениеТоваровУслуг.ХозяйственнаяОперация,
|    ПоступлениеТоваровУслуг.Организация ПредставлениеПолучателя,
|    ПоступлениеТоваровУслуг.Подразделение,
|    ПоступлениеТоваровУслуг.Склад,
|    ПоступлениеТоваровУслуг.Контрагент ,
|    ПоступлениеТоваровУслуг.СуммаДокумента,
|    ПоступлениеТоваровУслуг.СуммаВзаиморасчетовПоЗаказу,
|    ПоступлениеТоваровУслуг.Менеджер,
|    ПоступлениеТоваровУслуг.ЗаказПоставщику,
|    ПоступлениеТоваровУслуг.ПодотчетноеЛицо,
|    ПоступлениеТоваровУслуг.ЦенаВключаетНДС,
|    ПоступлениеТоваровУслуг.ВалютаВзаиморасчетов,
|    ПоступлениеТоваровУслуг.Комментарий,
|    ПоступлениеТоваровУслуг.ДатаПлатежа,
|    ПоступлениеТоваровУслуг.ЗакупкаПодДеятельность,
|    ПоступлениеТоваровУслуг.ФормаОплаты,
|    ПоступлениеТоваровУслуг.Согласован,
|    ПоступлениеТоваровУслуг.НалогообложениеНДС,
|    ПоступлениеТоваровУслуг.ПредъявленСчетФактура,
|    ПоступлениеТоваровУслуг.НомерСчетаФактуры,
|    ПоступлениеТоваровУслуг.ДатаСчетаФактуры,
|    ПоступлениеТоваровУслуг.ВалютаСчетаФактуры,
|    ПоступлениеТоваровУслуг.СуммаВзаиморасчетов,
|    ПоступлениеТоваровУслуг.БанковскийСчетОрганизации,
|    ПоступлениеТоваровУслуг.НомерВходящегоДокумента,
|    ПоступлениеТоваровУслуг.ДатаВходящегоДокумента,
|    ПоступлениеТоваровУслуг.Грузоотправитель,
|    ПоступлениеТоваровУслуг.БанковскийСчетКонтрагента,
|    ПоступлениеТоваровУслуг.БанковскийСчетГрузоотправителя,
|    ПоступлениеТоваровУслуг.Сделка,
|    ПоступлениеТоваровУслуг.СуммаРасхождений,
|    ПоступлениеТоваровУслуг.СуммаИзлишков,
|    ПоступлениеТоваровУслуг.СуммаНедостачи,
|    ПоступлениеТоваровУслуг.СторонняяКомпания,
|    ПоступлениеТоваровУслуг.КонтрагентСтороннейКомпании,
|    ПоступлениеТоваровУслуг.ВалютаВзаиморасчетовСоСтороннейКомпанией,
|    ПоступлениеТоваровУслуг.СуммаРасчетовСоСтороннейКомпаниейПоРасхождениям,
|    ПоступлениеТоваровУслуг.СтатьяРасходовПоРасхождениям,
|    ПоступлениеТоваровУслуг.АналитикаРасходовПоРасхождениям,
|    ПоступлениеТоваровУслуг.СтатьяДоходовПоРасхождениям,
|    ПоступлениеТоваровУслуг.АналитикаДоходовПоРасхождениям,
|    ПоступлениеТоваровУслуг.ЕстьРасхождения,
|    ПоступлениеТоваровУслуг.Принял,
|    ПоступлениеТоваровУслуг.ПринялДолжность,
|    ПоступлениеТоваровУслуг.ПоступлениеПоЗаказам,
|    ПоступлениеТоваровУслуг.УдалитьЗакупкаПодДеятельностьОблагаемуюЕНВД,
|    ПоступлениеТоваровУслуг.ГруппаФинансовогоУчета,
|    ПоступлениеТоваровУслуг.РегистрироватьЦеныПоставщика,
|    ПоступлениеТоваровУслуг.Договор,
|    ПоступлениеТоваровУслуг.Автор,
|    ПоступлениеТоваровУслуг.Руководитель,
|    ПоступлениеТоваровУслуг.ПорядокРасчетов,
|    ПоступлениеТоваровУслуг.ВернутьМногооборотнуюТару,
|    ПоступлениеТоваровУслуг.ДатаВозвратаМногооборотнойТары,
|    ПоступлениеТоваровУслуг.СостояниеЗаполненияМногооборотнойТары,
|    ПоступлениеТоваровУслуг.ИспользуетсяОбособленноеОбеспечение,
|    ПоступлениеТоваровУслуг.СтаршийМенеджерПоЗакупкам,
|    ПоступлениеТоваровУслуг.Товары.(
|        Ссылка,
|        НомерСтроки,
|        Номенклатура,
|        НоменклатураПоставщика как Артикул,
|        Характеристика,
|        Упаковка,
|        КоличествоУпаковок,
|        Количество,
|        Цена,
|        УсловиеЦеныПоставщика,
|        ПроцентРучнойСкидки,
|        СуммаРучнойСкидки,
|        Сумма,
|        СтавкаНДС,
|        СуммаНДС,
|        СуммаСНДС,
|        СтатьяРасходов,
|        АналитикаРасходов,
|        КодСтроки,
|        НомерГТД,
|        Склад,
|        ЗаказПоставщику,
|        НомерСтрокиДокументаПоставщика,
|        Сертификат,
|        НомерПаспорта,
|        СтатусУказанияСерий,
|        Сделка,
|        СуммаВзаиморасчетов,
|        СуммаНДСВзаиморасчетов,
|        ВидЗапасов,
|        ИдентификаторСтроки,
|        АналитикаУчетаПартий,
|        Назначение
|    ),
|    ПоступлениеТоваровУслуг.ТоварыПоДаннымПоставщика.(
|        Ссылка,
|        НомерСтроки,
|        НоменклатураПоставщика,
|        Номенклатура,
|        Характеристика,
|        Упаковка,
|        КоличествоУпаковок,
|        Количество,
|        Цена,
|        УсловиеЦеныПоставщика,
|        Сумма,
|        СтавкаНДС,
|        СуммаНДС,
|        СуммаСНДС,
|        НомерГТД
|    ),
|    ПоступлениеТоваровУслуг.Расхождения.(
|        Ссылка,
|        НомерСтроки,
|        НоменклатураПоставщика,
|        Номенклатура,
|        Характеристика,
|        Упаковка,
|        КоличествоУпаковок,
|        Количество,
|        УсловиеЦеныПоставщика,
|        Цена,
|        Сумма,
|        СтавкаНДС,
|        СуммаНДС,
|        СуммаСНДС,
|        КодСтроки,
|        Склад,
|        ЗаказПоставщику,
|        ВариантРасхождений,
|        ВариантОтраженияРасхождений,
|        СуммаВзаиморасчетов,
|        СуммаНДСВзаиморасчетов,
|        АналитикаУчетаПартий,
|        ИдентификаторСтроки
|    ),
|    ПоступлениеТоваровУслуг.ДополнительныеРеквизиты.(
|        Ссылка,
|        НомерСтроки,
|        Свойство,
|        Значение,
|        ТекстоваяСтрока
|    ),
|    ПоступлениеТоваровУслуг.РасшифровкаПлатежа.(
|        Ссылка,
|        НомерСтроки,
|        Заказ,
|        Сумма,
|        ВалютаВзаиморасчетов,
|        СуммаВзаиморасчетов
|    ),
|    ПоступлениеТоваровУслуг.Серии.(
|        Ссылка,
|        НомерСтроки,
|        Серия,
|        Количество,
|        Номенклатура,
|        Характеристика,
|        Склад
|    ),
|    ПоступлениеТоваровУслуг.Представление,
|    ПоступлениеТоваровУслуг.МоментВремени
|ИЗ
|    Документ.ПоступлениеТоваровУслуг КАК ПоступлениеТоваровУслуг
|ГДЕ
|    ПоступлениеТоваровУслуг.Ссылка В(&МассивДокументов)
|
|УПОРЯДОЧИТЬ ПО
|    Ссылка
|;
|
////////////////////////////////////////////////////////////////////////////////

|ВЫБРАТЬ
|    ВложенныйЗапрос.Ссылка КАК Ссылка,
|    ВложенныйЗапрос.НомерСтроки КАК НомерСтроки,
|    ВложенныйЗапрос.Номенклатура,
|    ВложенныйЗапрос.НоменклатураПоставщика,
|    ВложенныйЗапрос.Характеристика,
|    ВложенныйЗапрос.Упаковка,
|    ВложенныйЗапрос.КоличествоУпаковок,
|    ВложенныйЗапрос.Количество,
|    ВложенныйЗапрос.Цена,
|    ВложенныйЗапрос.УсловиеЦеныПоставщика,
|    ВложенныйЗапрос.ПроцентРучнойСкидки,
|    ВложенныйЗапрос.СуммаРучнойСкидки,
|    ВложенныйЗапрос.Сумма,
|    ВложенныйЗапрос.СтавкаНДС,
|    ВложенныйЗапрос.СуммаНДС,
|    ВложенныйЗапрос.СуммаСНДС,
|    ВложенныйЗапрос.СтатьяРасходов,
|    ВложенныйЗапрос.АналитикаРасходов,
|    ВложенныйЗапрос.КодСтроки,
|    ВложенныйЗапрос.НомерГТД,
|    ВложенныйЗапрос.Склад,
|    ВложенныйЗапрос.ЗаказПоставщику,
|    ВложенныйЗапрос.НомерСтрокиДокументаПоставщика,
|    ВложенныйЗапрос.Сертификат,
|    ВложенныйЗапрос.НомерПаспорта,
|    ВложенныйЗапрос.СтатусУказанияСерий,
|    ВложенныйЗапрос.Сделка,
|    ВложенныйЗапрос.СуммаВзаиморасчетов,
|    ВложенныйЗапрос.СуммаНДСВзаиморасчетов,
|    ВложенныйЗапрос.ВидЗапасов,
|    ВложенныйЗапрос.ИдентификаторСтроки,
|    ВложенныйЗапрос.АналитикаУчетаПартий,
|    ВложенныйЗапрос.Назначение
|ИЗ
|    (ВЫБРАТЬ
|        ПоступлениеТоваровУслугТовары.Ссылка КАК Ссылка,
|        ПоступлениеТоваровУслугТовары.НомерСтроки КАК НомерСтроки,
|        ПоступлениеТоваровУслугТовары.Номенклатура КАК Номенклатура,
|        ПоступлениеТоваровУслугТовары.НоменклатураПоставщика КАК НоменклатураПоставщика,
|        ПоступлениеТоваровУслугТовары.Характеристика КАК Характеристика,
|        ПоступлениеТоваровУслугТовары.Упаковка КАК Упаковка,
|        ПоступлениеТоваровУслугТовары.КоличествоУпаковок КАК КоличествоУпаковок,
|        ПоступлениеТоваровУслугТовары.Количество КАК Количество,
|        ПоступлениеТоваровУслугТовары.Цена КАК Цена,
|        ПоступлениеТоваровУслугТовары.УсловиеЦеныПоставщика КАК УсловиеЦеныПоставщика,
|        ПоступлениеТоваровУслугТовары.ПроцентРучнойСкидки КАК ПроцентРучнойСкидки,
|        ПоступлениеТоваровУслугТовары.СуммаРучнойСкидки КАК СуммаРучнойСкидки,
|        ПоступлениеТоваровУслугТовары.Сумма КАК Сумма,
|        ПоступлениеТоваровУслугТовары.СтавкаНДС КАК СтавкаНДС,
|        ПоступлениеТоваровУслугТовары.СуммаНДС КАК СуммаНДС,
|        ПоступлениеТоваровУслугТовары.СуммаСНДС КАК СуммаСНДС,
|        ПоступлениеТоваровУслугТовары.СтатьяРасходов КАК СтатьяРасходов,
|        ПоступлениеТоваровУслугТовары.АналитикаРасходов КАК АналитикаРасходов,
|        ПоступлениеТоваровУслугТовары.КодСтроки КАК КодСтроки,
|        ПоступлениеТоваровУслугТовары.НомерГТД КАК НомерГТД,
|        ПоступлениеТоваровУслугТовары.Склад КАК Склад,
|        ПоступлениеТоваровУслугТовары.ЗаказПоставщику КАК ЗаказПоставщику,
|        ПоступлениеТоваровУслугТовары.НомерСтрокиДокументаПоставщика КАК НомерСтрокиДокументаПоставщика,
|        ПоступлениеТоваровУслугТовары.Сертификат КАК Сертификат,
|        ПоступлениеТоваровУслугТовары.НомерПаспорта КАК НомерПаспорта,
|        ПоступлениеТоваровУслугТовары.СтатусУказанияСерий КАК СтатусУказанияСерий,
|        ПоступлениеТоваровУслугТовары.Сделка КАК Сделка,
|        ПоступлениеТоваровУслугТовары.СуммаВзаиморасчетов КАК СуммаВзаиморасчетов,
|        ПоступлениеТоваровУслугТовары.СуммаНДСВзаиморасчетов КАК СуммаНДСВзаиморасчетов,
|        ПоступлениеТоваровУслугТовары.ВидЗапасов КАК ВидЗапасов,
|        ПоступлениеТоваровУслугТовары.ИдентификаторСтроки КАК ИдентификаторСтроки,
|        ПоступлениеТоваровУслугТовары.АналитикаУчетаПартий КАК АналитикаУчетаПартий,
|        ПоступлениеТоваровУслугТовары.Назначение КАК Назначение
|    ИЗ
|        Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслугТовары) КАК ВложенныйЗапрос
|
|УПОРЯДОЧИТЬ ПО
|    Ссылка,
|    НомерСтроки");
    Запрос.УстановитьПараметр("МассивДокументов",                 МассивОбъектов);

    ТабличныйДокумент = Новый ТабличныйДокумент;
    ТабличныйДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ПоступлениеТоваровУслуг";           
    
    ТабличныйДокумент = Новый ТабличныйДокумент;
    МассивРезультатов             = Запрос.ВыполнитьПакет();
    ДанныеПечати            = МассивРезультатов[0].Выбрать();
    ВыборкаПоДокументам     = МассивРезультатов[1].Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    
    ПервыйДокумент = Истина;
    Макет = ПолучитьМакет("Макет");
//    

    Пока ДанныеПечати.Следующий() Цикл
        
        // Найдем в выборке товары по текущему документу

        СтруктураПоиска = Новый Структура("Ссылка", ДанныеПечати.Ссылка);
        НайденСледующий = ВыборкаПоДокументам.НайтиСледующий(СтруктураПоиска);
        
        // Если в накладной только услуги - перейдем к следующему документу

        
        Если НайденСледующий Тогда
            ВыборкаПоТоварам = ВыборкаПоДокументам.Выбрать();
            ВыборкаПоТоварам.Сбросить();
        Иначе
            Продолжить;
        КонецЕсли;
        
        Если Не ПервыйДокумент Тогда
            ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
        КонецЕсли;
        
        ПервыйДокумент    = Ложь;
        НомерСтрокиНачало = ТабличныйДокумент.ВысотаТаблицы + 1;
        
//////////////////////////////////////////////////////////////////////////////////////////////////

        //Штамп  

        ОбластьМакета = Макет.ПолучитьОбласть("ОбластьШтрихкода");
        ОбластьМакета.Параметры.Заполнить(ДанныеПечати);
        ТабличныйДокумент.Вывести(ОбластьМакета);
                                 
/////////////////////////////////////////////////////////////////////////////////////////////////////////////////Заголовок

                        ///////////////////////////////////Заголовок

          ОбластьМакета = Макет.ПолучитьОбласть("Заголовок");
          ТекстЗаголовка = ОбщегоНазначенияУТКлиентСервер.СформироватьЗаголовокДокумента(ДанныеПечати, НСтр("ru='ПоступлениеТоваровУслуг'"));
          //ОбластьМакета.Параметры.Заполнить(ДанныеПечати);

          ОбластьМакета.Параметры.ТекстЗаголовка = ТекстЗаголовка;
          //ОбластьМакета.Параметры.Заполнить(ДанныеПечати);

          ТабличныйДокумент.Вывести(ОбластьМакета);
          
        ///////////////////////////////////Поставщик

          ОбластьМакета = Макет.ПолучитьОбласть("Поставщик");
          ОбластьМакета.Параметры.Заполнить(ДанныеПечати);
          ТабличныйДокумент.Вывести(ОбластьМакета);
          
          ///////////////////////////////////Покупатель

          ОбластьМакета = Макет.ПолучитьОбласть("Покупатель");
          ОбластьМакета.Параметры.Заполнить(ДанныеПечати);
          ТабличныйДокумент.Вывести(ОбластьМакета);
          //шапка таблицы

          ОбластьМакета = Макет.ПолучитьОбласть("ШапкаТаблицы");
          ОбластьМакета.Параметры.Заполнить(ДанныеПечати);
          ТабличныйДокумент.Вывести(ОбластьМакета);
          
         
        // Выводим строки таблицы Товары со скидкой

            
        ОбластьМакета = Макет.ПолучитьОбласть("СтрокаТаблицыСоСкидкой");
        НомерСтроки = 0;
        Пока ВыборкаПоТоварам.Следующий() Цикл
            сообщить("мы в строкетаблицысоскидкой");

            НомерСтроки = НомерСтроки + 1;
            
            ОбластьМакета.Параметры.НомерСтроки = НомерСтроки;
            ОбластьМакета.Параметры.Артикул=  ВыборкаПоДокументам.Артикул;
            //ОбластьМакета.Параметры.Заполнить(ВыборкаПоТоварам);

            сообщить(НомерСтроки);
            сообщить(ВыборкаПоДокументам.Артикул);
            ТабличныйДокумент.Вывести(ОбластьМакета);

        КонецЦикла;
        
        //подвал со скидкой таблицы

          ОбластьМакета = Макет.ПолучитьОбласть("ПодвалТаблицыСоСкидкой");
          ОбластьМакета.Параметры.Заполнить(ДанныеПечати);
          ТабличныйДокумент.Вывести(ОбластьМакета);
////////////cтрока таблицы

        ОбластьМакета = Макет.ПолучитьОбласть("СтрокаТаблицы");
        НомерСтроки = 0;
        Пока ВыборкаПоТоварам.Следующий() Цикл
            
            НомерСтроки = НомерСтроки + 1;
            
            ОбластьМакета.Параметры.НомерСтроки = НомерСтроки;
            ОбластьМакета.Параметры.Артикул=  ВыборкаПоДокументам.Артикул;
            ОбластьМакета.Параметры.Заполнить(ВыборкаПоТоварам);
            ТабличныйДокумент.Вывести(ОбластьМакета);

        КонецЦикла;
        //подвал со скидкой таблицы

          ОбластьМакета = Макет.ПолучитьОбласть("ПодвалТаблицы");
          ОбластьМакета.Параметры.Заполнить(ДанныеПечати);
          ТабличныйДокумент.Вывести(ОбластьМакета);

          //ПодвалТаблицыНДС

          ОбластьМакета = Макет.ПолучитьОбласть("ПодвалТаблицыНДС");
          ОбластьМакета.Параметры.Заполнить(ДанныеПечати);
          ТабличныйДокумент.Вывести(ОбластьМакета);
 
        //СуммаПрописью

          ОбластьМакета = Макет.ПолучитьОбласть("СуммаПрописью");
          ОбластьМакета.Параметры.Заполнить(ДанныеПечати);
          ТабличныйДокумент.Вывести(ОбластьМакета);
 
          //Подписи

          ОбластьМакета = Макет.ПолучитьОбласть("Подписи");
          ОбластьМакета.Параметры.Заполнить(ДанныеПечати);
          ТабличныйДокумент.Вывести(ОбластьМакета);
 
          
    конеццикла;      
     
ТабличныйДокумент.АвтоМасштаб = Истина;

    Если ПривилегированныйРежим() Тогда
        УстановитьПривилегированныйРежим(Ложь);
    КонецЕсли;
    
    
   
    Возврат ТабличныйДокумент;    


КонецФункции
   hhhh
 
8 - 13.09.16 - 12:12
ВыборкаПоДокументам     = МассивРезультатов[1].Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

почему по группировкам? модное слово что ли? в запросе никаких группировок нет.
   Jalib
 
9 - 13.09.16 - 12:26
изменил эту строку на
ВыборкаПоДокументам = МассивРезультатов[1].Выбрать();
ничего не изменилось
   Jalib
 
10 - 13.09.16 - 13:28
все с этим разобрался идем дальше
 
 Рекламное место пустует
   Jalib
 
11 - 14.09.16 - 10:55
не хочет "единица измерения цены" заполняться как исправить?
   Jalib
 
12 - 14.09.16 - 11:17
с этим тоже разобрался не везде в документах указанна"единица измерения цены"
   aleks_default
 
13 - 14.09.16 - 11:21
Может бложек уже заведешь, а то нам ООООчень интересно.
   МимохожийОднако
 
14 - 14.09.16 - 11:22
(6) Жёстко
   Jalib
 
15 - 14.09.16 - 16:33
у нас страна свободного выбора не интересно не читай)))
   Jalib
 
16 - 14.09.16 - 16:36
а вообще я эту внешнюю форму закончил. тема не актуальна и её можно закрывать

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует