Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Групповая печать

Групповая печать
Я
   Slava685
 
12.09.16 - 09:34
Всем доброе утро.Столкнулся с проблемой.
Не могу прописать групповую печать доков.
Ругается при открытии документа на то что метод объекта не обнаружен (КоличествоЭкземпляров).Это понятно, т.к. я не знаю команды выбора.Но какая команда отвечает за количество выбранных доков?Как сделать выборку?Там ведь вроде цикл нужен,т.е. каждый документ будет обрабатываться в цикле и выводиться.Объясните полному чайнику.Искал в типовых документах, но в силу моего опыта,а точнее бессилии, ничего путного не нашёл. Кто может помогите, пожалуйста с кодом.Желательно разжевать:)


Вот код

&НаСервере
Функция ПоказатьФормуНаСервере(ТекДок)
         
        ОбработкаОбъект = РеквизитФормыВЗначение("Объект");
         Макет = ОбработкаОбъект.ПолучитьМакет(Макет);
         ТабДок = Новый ТабличныйДокумент;
         ТабДок.Вывести(Макет);
         Табдок.ОтображатьСетку = Ложь;
         ТабДок.ТолькоПросмотр = Истина;
         ТабДок.Защита=Истина;
      Возврат ТабДок;
          
    
КонецФункции

&НаКлиенте


&НаКлиенте
Функция ПоказатьФорму(ТабДок,Команда)
     ТекДок= Новый ТабличныйДокумент; 
    Если ТекДок.КоличествоЭкземпляров() = 1 Тогда
        
        ПараметрыФормы = Новый Структура;
        ПараметрыФормы.Вставить("Ключ", ТекДок[0]);
        
        ОткрытьФорму(
                "Документ.ТранспортнаяНакладная.ФормаПропуск", 
                ПараметрыФормы);
                
    ИначеЕсли ТекДок.КоличествоЭкземпляров > 1 Тогда
        
        ПараметрыФормы = Новый Структура;
        ПараметрыФормы.Вставить("ТранспортныеНакладные", ТекДок);
        
        ОткрытьФорму(
                "Документ.ТранспортнаяНакладная.ФормаПропуск", 
                ПараметрыФормы);

    КонецЕсли;

    
КонецФункции
 
 
   Slava685
 
1 - 12.09.16 - 09:34
Что нужно убрать а что добавить и куда.
   Slava685
 
2 - 12.09.16 - 10:26
Кто-нибудь!)
   Slava685
 
3 - 12.09.16 - 10:26
Отзовитесь!))))
   hhhh
 
4 - 12.09.16 - 10:28
(1) философский вопрос, почему
    Если ТекДок.КоличествоЭкземпляров() = 1 Тогда

тут скобки?

а  ИначеЕсли ТекДок.КоличествоЭкземпляров > 1 Тогда
  
тут без скобок? это бзик такой у вас или глубокая задумка какая-то?
   Slava685
 
5 - 12.09.16 - 10:39
Я делал так.Ругается что "метод Количество экземпляров не определено".
   Slava685
 
6 - 12.09.16 - 10:39
(4) А скобки для параметров.Каких не знаю)Я же сказал что я чайник))
   Альбатрос
 
7 - 12.09.16 - 10:41
(6) Нет там параметров, ибо самого метода не существует.
   Slava685
 
8 - 12.09.16 - 10:49
(6) Я же сказал что его не существует в самом вопросе.Так как же написать? описать отдельной функцией в модуле объекта а потом вызывать с клиента?Тогда как таким образом?
   Slava685
 
9 - 12.09.16 - 10:50
(7) Перепутал)
   zak555
 
10 - 12.09.16 - 10:51
посмотри, как сделано в любой типовой на уф
 
 Рекламное место пустует
   Slava685
 
11 - 12.09.16 - 10:58
(10) Смотрел я.Говорю же не могу найти ничего толком.Можно код в студию копипастнуть?Попробую разгребсти.
   Slava685
 
12 - 12.09.16 - 11:01
Всё нашёл.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует