Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

УФ. Как вызвать процедуру модуля документа из его формы?

УФ. Как вызвать процедуру модуля документа из его формы?
Я
   megabax
 
10.09.16 - 19:15
Добрый день. В модуле документа объявил процедуру:
Процедура РассчитатьСкидку() экспорт
    СуммаСкидки=Позиции.Итог("Всего")*ПроцентСкидки/100;
    СуммаСкидкиЗамена=Позиции.Итог("ВсегоЗамена")*ПроцентСкидки/100;
    СуммаПослеСкидки=Позиции.Итог("Всего")-СуммаСкидки;
    СуммаПослеСкидкиЗамена=Позиции.Итог("ВсегоЗамена")-СуммаСкидкиЗамена;
КонецПроцедуры

Вызываю ее из модуля формы, например, так:
&НаКлиенте
Процедура ПозицииПриИзменении(Элемент)
    Объект.РассчитатьСкидку();
КонецПроцедуры

И говорит:
"{Документ.шапИзменениеПозицийЗаявкиПокупателя.Форма.ФормаДокумента.Форма(468)}: Метод объекта не обнаружен (РассчитатьСкидку)
    Объект.РассчитатьСкидку();"
Подскажите пожалуйста, как лечить?
 
 
   zak555
 
1 - 10.09.16 - 19:19
на сервере объектформывзеачение и вызывай
   RomanYS
 
2 - 10.09.16 - 19:21
эээ... это УФ.
1. уходим на сервер
2. получаем объект (реквизитформывзначение)
3. вызываем процедуру
4. возвращаем изменения из объекта в данные формы (какая-то функция с похожим названием, но наоборот)
   megabax
 
3 - 10.09.16 - 19:23
(1) Сделал так
&НаСервере
Процедура РассчитатьСкидку()
    Объект.РассчитатьСкидку();
КонецПроцедуры
 

&НаКлиенте
Процедура ПозицииПриИзменении(Элемент)
    РассчитатьСкидку();
КонецПроцедуры

тоже самое
   megabax
 
4 - 10.09.16 - 19:24
(2) "2. получаем объект (реквизитформывзначение) " - это как?
   RomanYS
 
5 - 10.09.16 - 19:26
(4) найди в СП, или поиском по любой типовой
   megabax
 
6 - 10.09.16 - 19:29
(5) Это что то типа этого что ли:
"Функция ВыполнитьКомандуИзФормыВнешнегоОбъекта(ИдентификаторКоманды, ПараметрыКоманды, ЭтаФорма) Экспорт
    
    ВнешнийОбъект = ЭтаФорма.РеквизитФормыВЗначение("Объект");
    
    РезультатВыполнения = ВыполнитьКомандуВнешнегоОбъекта(ВнешнийОбъект, ИдентификаторКоманды, ПараметрыКоманды, Неопределено);
    
    Возврат РезультатВыполнения;
    
КонецФункции
"
То есть, сейчас в УФ нельзя нормально вызвать процедуры модуля объекта, только вот так извратившись???
   Torquader
 
7 - 10.09.16 - 19:58
(4) Очень классное решение, особенно, если учесть, что модуль объекта при его создании каждый раз компиляется - и потом будут вопрос - а чего это всё так сильно тормозит.
   Рэйв
 
8 - 10.09.16 - 20:00
(6)Чукча не читатель.Чукча писатель...:-)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует