Вход | Регистрация


Выделенные строки сбивается идентификатор

Выделенные строки сбивается идентификатор
Я
   myr4ik07
 
09.09.16 - 13:14
ТЗ. УФ. Объект.Отчет.

код

&НаКлиенте
Процедура ДействиеОтчетПоИзменениям(Команда)
    
    ВыделенныеСтроки = Элементы.СписокВерсий.ВыделенныеСтроки;
    
    Список = Новый СписокЗначений;
    
    Для Каждого ВыделеннаяСтрока Из ВыделенныеСтроки Цикл
        Список.Добавить(СписокВерсий.Получить(ВыделеннаяСтрока).НомерВерсии);
    КонецЦикла;
    
    Если Список.Количество() = 2 Тогда
        СформироватьОтчетНаСервере(ТЧОтчета, Список);
    Иначе
        Предупреждение("Для сравнения необходимо выбрать две версии",, "Сравнение версий");
    КонецЕсли;
    
КонецПроцедуры

Процедура СформироватьОтчетНаСервере(ТЧОтчета,Список)
    РеквизитФормыВЗначение("Отчет").СформироватьОтчет(ТЧОтчета, Список);
КонецПроцедуры

выделяю две строки, нажимаю кнопку все норм, далее нажимаю еще одну кнопку которая заполняет ТЗ еще раз и потом еще раз нажимаю предыдущую кнопку, выше код и уже пишется

{Отчет.ИсторияИзмененийОбъектов.Форма.ФормаОтчетаУФ.Форма(79)}: Ошибка при вызове метода контекста (Получить)
        Список.Добавить(СписокВерсий.Получить(ВыделеннаяСтрока).НомерВерсии);
по причине:
Недопустимое значение параметра (параметр номер '1')

я смотрю ВыделеннаяСтрока а там уже идентификатор полез дальше увеличивать ВыделеннаяСтрока, т.е., нажал а он с 3 на 4, 5,6, хотя выделенные строки уже отсутствуют
 
 
   Метранпаж
 
1 - 09.09.16 - 13:17
Rybub gj bcgjkmpetvjq nt[yjkjubb xbnfnm e;t yt vjlyj&
   Метранпаж
 
2 - 09.09.16 - 13:17
Блин...

Книги по используемой технологии читать уже не модно? методом научного тыка можно получить только удовольствие, но не знания.
   myr4ik07
 
3 - 09.09.16 - 13:18
я ж не думаю что так нужно

    Для Каждого ВыделеннаяСтрока Из ВыделенныеСтроки Цикл
        Список.Добавить(СписокВерсий.Получить(ВыделенныеСтроки.Найти(ВыделеннаяСтрока)).НомерВерсии);
    КонецЦикла;
   myr4ik07
 
4 - 09.09.16 - 13:19
капец, да, по индексу норм

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует