Вход | Регистрация

  1  2  3  4

Тестовое задание

Тестовое задание
Я
   Одинесю
 
09.09.16 - 12:08
Не, ну не могу устроиться на работу и все. Все предложения типа таких -
Написать программу на 1С. Программа должна выводить пирамиду простых чисел, как показано на рисунке ниже.

Перед выводом программа должна запросить число N – высоту пирамиды.

http://hostingkartinok.com/show-image.php?id=d525a93e0c235c5073c4fc15174321ed

На...я это в 1с, может я не догоняю.
 
 
   igork1966
 
301 - 13.09.16 - 16:09
(300) Поскольку я знал КАК, то мне проще было в запросе сразу обработать.
   ViSo76
 
302 - 13.09.16 - 16:16
(301) ПОДСТРОКА рулит при известном формате
   Fragster
 
303 - 13.09.16 - 16:19
(301) представляю печальную скорость, с которой это работало. ну и всякие соединения, таблицы с цифрами, которые для этого необходимы....
сложность доработки, опять же. через год, или просто другому программисту разбираться в этом доставит незабываемое удовольствие
   Fragster
 
304 - 13.09.16 - 16:20
(302) без формата тоже можно. но делать произведение таблиц ради замены символов - несколько странно
   igork1966
 
305 - 13.09.16 - 16:21
(302) не известный заранее формат
   igork1966
 
306 - 13.09.16 - 16:24
(303) Не заметил сколько бы существенного замедления. ВТ использовал для справочника, индексированную.
   igork1966
 
307 - 13.09.16 - 16:25
(306) + данных не слишком много.
   ifso
 
308 - 13.09.16 - 17:32
(278) типа, из средств незапросы не исключаются?

(293) угу, и тут алгоритмисту поступает от вышестоящего: "Сделать фсё!"
   Fragster
 
309 - 13.09.16 - 17:44
(308).1 ну, если в тестовом задании написано "запросом" то незапросы исключаются. а если это отчет и надо данные вытянуть из внешнего источника - то вполне предобработку данных можно сделать перед запросом
   ifso
 
310 - 13.09.16 - 17:58
(309)
> если в тестовом задании написано "запросом" то незапросы
> исключаются
а если в тестовом "стоя на голове" и/или "с закрытыми глазами" и/или "без рук"?
ну а чё, для в некий цирк вполне себе требования, не?
 
 Рекламное место пустует
   ViSo76
 
311 - 13.09.16 - 18:02
(310) Бывает что таскать на клиента, а потом обратно не айс
   Fragster
 
312 - 13.09.16 - 18:27
(310) да, тестовое задание надо сделать точно так, как в задании, а потом написать в комментарии, почему так делать не надо.
   Fragster
 
313 - 13.09.16 - 18:27
на то оно и тестовое
   ifso
 
314 - 13.09.16 - 18:40
(212)
> тестовое задание надо сделать ..., а потом написать в
> комментарии
а потом упасть и отжаться, не?)

(313) угу, тестовое - визитка тестирующей стороны

зы злые языки клевещут, мол коегдеунаспорой путают тесты, экзамены и конкурсы
   iceman2112
 
315 - 13.09.16 - 18:46
(212( Если бы ты интегралы решать умел, вопросы такие не постил.
   Fragster
 
316 - 13.09.16 - 19:00
(314).1 тогда у тебя будет как в (0)
   ifso
 
317 - 13.09.16 - 19:30
(316) вангуешь или накаркиваешь?)
всенепременные злые языки клевещут, что на подобный (0) бдсм согласятся либо с амбициями попользовать самих тестировщиков, либо "тряпки"

http://www.anekdot.ru/id/-10093341/
   DomovoiAtakue
 
318 - 14.09.16 - 02:08
(308)2)Кто такой алгоритмист? Понапридумывали делений для дворников, как менеджеров 100500 делений, а по русски просто продавец. Ну и поступит задача "Сделать все" ну и сделает все, ибо прог это человек, который может решить все.
   Никулин Леонид
 
319 - 14.09.16 - 09:18
Немного накрыло...

КоличествоСтрокВСтроке = 1;
    СчетчикЧисел = 1;
    ЭтоПерваяИтерация = Истина;
    НужноСделатьПереносСтроки = Ложь;
    
    Для СчетчикСтрок=1 По КоличествоСтрок Цикл    //КоличествоСтрок-это реквизит формы

        
        Если Не ЭтоПерваяИтерация Тогда        
            КоличествоСтрокВСтроке = КоличествоСтрокВСтроке + 2;
            Для Количество=1 По КоличествоСтрокВСтроке Цикл
                СчетчикЧисел = СчетчикЧисел+1;
                Сообщить(СчетчикЧисел);
                //

                                НужноСделатьПереносСтроки = Ложь;
            КонецЦикла; 
        Иначе 
            Сообщить(СчетчикЧисел);    
            
            НужноСделатьПереносСтроки = Истина;
                        НужноСделатьПереносСтроки = Ложь;
            
            ЭтоПерваяИтерация = Ложь;    
    
        КонецЕсли; 
        
    Сообщить("*");        
    НужноСделатьПереносСтроки = Истина;
   Никулин Леонид
 
320 - 14.09.16 - 09:19
(319) + КонецЦикла;
конечно)
  1  2  3  4

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует