Вход | Регистрация

  1  2  3  4   

Тестовое задание

Тестовое задание
Я
   Одинесю
 
09.09.16 - 12:08
Не, ну не могу устроиться на работу и все. Все предложения типа таких -
Написать программу на 1С. Программа должна выводить пирамиду простых чисел, как показано на рисунке ниже.

Перед выводом программа должна запросить число N – высоту пирамиды.

http://hostingkartinok.com/show-image.php?id=d525a93e0c235c5073c4fc15174321ed

На...я это в 1с, может я не догоняю.
 
 
   Fragster
 
201 - 09.09.16 - 19:43
(195) Ну, не умея - тоже ;)
   Fragster
 
202 - 09.09.16 - 19:43
а относить на затраты или увеличивать себестоимость - это вопрос не к программисту, вообще.
   Fragster
 
203 - 09.09.16 - 19:43
а (196) - вполне
   ifso
 
204 - 09.09.16 - 19:46
(198),(199) угу, дефицита принимальщиков решений нет
   Fram
 
205 - 09.09.16 - 19:51
(204) во во! сделать заключение, что двор грязный и его неплохо бы подмести людей хватает, а вот подмести нормально некому )))
   ProgAL
 
206 - 09.09.16 - 20:02
Все еще проще. Если высота пирамиды N  переменная цикла m от 1 до N означает номер строки пирамиды, то номер самого правого элемента строки равен m*m, количество элементов в строке (2*m - 1). Печатаем строки справа налево в диапазоне от (m*m - (2*m - 2)). Номер самой средней ячейки для симметрии N. Никаких поисков простых чисел, максимальное быстродействие.
   ProgAL
 
207 - 09.09.16 - 20:05
Номер самой правой ячейки для строки m = m+m-1.
   Garykom
 
208 - 09.09.16 - 20:06
(196) Было недавно такое тут, но представительница заказчика сказала нужно начальство подождать.

Задачка вполне решаемая но только путем ВК для скорости пересчета при изменениях (новые точки доставки или машины).
   ProgAL
 
209 - 09.09.16 - 20:13
(207) Номер (горизонтальный) самой правой ячейки для строки m равен N+m-1.
   ViSo76
 
210 - 09.09.16 - 20:14
(209) Лучше код напиши и выложи
 
 Рекламное место пустует
   ProgAL
 
211 - 09.09.16 - 20:16
Сорри, прочитал что надо искать простые числа, думал просто пирамиду напечатать.
   Одинесю
 
212 - 09.09.16 - 20:29
Я согласен решать интересную задачу, практическую, но это полный дебилизм - решать то, не зная зачем. У меня еще в годы учебы сложилось, учишь интегралы, дифференциалы, физику, химию, а кто-то задумывался - зачем? Ну да, для общего развития, ну так зачем тогда ставить отметки, проводить срез знаний? Сейчас, особенно сейчас, на первый план выходит точечное знание, т.к. всего не охватишь с этим объемом информации.
   МимохожийОднако
 
213 - 09.09.16 - 20:51
(212) ОФФ: Да ладно..Пятница кончилась, не напрягайся.
   Dmitry77
 
214 - 09.09.16 - 21:18
Ещё можно нарисовать руками сотню макетов
С одной строкой, с двумя строками, с тремя строками до ста строк.
И в зависимости от введённого числа строк выводить нужный макет.
   Новиков
 
215 - 09.09.16 - 21:53
>> меня еще в годы учебы сложилось, учишь интегралы, дифференциалы, физику, химию, а кто-то задумывался - зачем?

Тебя как туда занесло то хоть? На какой хер ты туда поперся? Пошел бы после 9-ти классов на сантехника, да и дело с концом.
   Garykom
 
216 - 09.09.16 - 22:08
   Garykom
 
217 - 09.09.16 - 22:09
(216) к (215)
   ifso
 
218 - 09.09.16 - 22:21
   Tarzan_Pasha
 
219 - 09.09.16 - 22:27
(0)не там работу ищешь. Ищи там, где тебя возьмут по рекомендации, а не по собеседованию.

Лично я слал всех на! когда меня пытались тестировать.
   Fram
 
220 - 09.09.16 - 22:36
(219) А лучше не ищи, жди пока она сама тебя найдет. А если там вдруг предложат работать, беги оттуда сразу.
   PR
 
221 - 09.09.16 - 22:40
(220) А если догонят, вшей в воротник цианистый калий, всё, лишь бы не работать!
   bolder
 
222 - 10.09.16 - 00:30
(0) Задание на программиста.У меня заняло час - многовато наверное.Вот результат до 99 уровня (10 с на моей машинке).
http://itmages.ru/image/view/4861336/69eed377
   bolder
 
223 - 10.09.16 - 00:33
(222) +Наверное перемудрил: у меня пирамида только из простых состоит.
   Garykom
 
224 - 10.09.16 - 01:03
(223) угу настоящий программист, с 1-го раза ТЗ нифига не понял ))

на 3-ку решил, ибо раскраску ячеек не использовал...
   Torquader
 
225 - 10.09.16 - 01:06
(224) Нет - покрасил он как раз всё правильно, только заполнил - не так, как было в задании.
   Garykom
 
226 - 10.09.16 - 01:07
(225) Вот именно что не так покрасил... цвет только 1... а должно быть по ТЗ два разных ))
   Garykom
 
227 - 10.09.16 - 01:10
Гм подумалось а это случаем не какая то формула? Кол-во чисел на ступеньке это арифметическая прогрессия с шагом 2.

Т.е. "кол-во ячеек на ступени" = "номер ступени" * 2 - 1

А дальше?
   Garykom
 
228 - 10.09.16 - 01:14
(227)+ Далее для каждой ступени:
"номер ступени" - "значения 1-я ячейки"
1 - 1
2 - 2
3 - 5
4 - 10
5 - 17
6 - 26
7 - 37

Какая формула?
   Torquader
 
229 - 10.09.16 - 01:25
A(N)=SUMi=1..N
   Torquader
 
230 - 10.09.16 - 01:25
A{N}=SUM{i=1..N}{2*i-1}
   Torquader
 
231 - 10.09.16 - 01:27
Вообще-то, сумма арифметической прогрессии с шагом 2.
   Garykom
 
232 - 10.09.16 - 01:30
(231) Ты не умничай ты через "номер ступени" и "номер ячейки на ступени" вырази ))
   Garykom
 
233 - 10.09.16 - 01:32
(232)+ Тогда задачка в 2 простейших вложенных цикла... И функцию определения простоты.
 
 
   Torquader
 
234 - 10.09.16 - 01:37
A{N}={N*N}+1
   Torquader
 
235 - 10.09.16 - 01:39
Вообще-то, там ничего делать не надо.
Рисуем пирамиду исходя из N.
То есть таблица шириной 2N+1 и высотой N
И просто циклом идём и заполняем.
Для каждого вызываем проверку АНеПростоеЛиОно - и меняем фон.
   Fram
 
236 - 10.09.16 - 01:41
(235) эээ.. а почему ширина 2N+1?
   Torquader
 
237 - 10.09.16 - 01:43
(236) Ну, может быть, 2N-1.
   Fram
 
238 - 10.09.16 - 01:43
(235) может все таки 2N-1?
   Torquader
 
239 - 10.09.16 - 01:44
(238) Я тоже из тех программистов, которые ТЗ до конца не читают.
   Garykom
 
240 - 10.09.16 - 01:56
Итого формула значения ячейки f(НомерСтупени,НомерЯчейкиНаСтупени) = (НомерСтупени-1)^2+1+НомерЯчейкиНаСтупени
   Garykom
 
241 - 10.09.16 - 01:57
(240)+ Сорри лишняя единица
f(НомерСтупени,НомерЯчейкиНаСтупени) = (НомерСтупени-1)^2+НомерЯчейкиНаСтупени
   Garykom
 
242 - 10.09.16 - 02:01
КоличествоСтупеней = ..
Для НомерСтупени = 1 По КоличествоСтупеней Цикл
  КоличествоЯчеекНаСтупени = НомерСтупени * 2 - 1;
  Для НомерЯчейкиНаСтупени = 1 По КоличествоЯчеекНаСтупени Цикл
    ЗначениеЯчейки =  (НомерСтупени-1)*(НомерСтупени-1) + НомерЯчейкиНаСтупени;
    // делаем шо нуна

  КонецЦикла;
КонецЦикла

   Torquader
 
243 - 10.09.16 - 02:27
Функция ЭтоПростоеЧисло(пчЧисло,пмПростыеЧисла)
    Если пчЧисло=1 Тогда
        Возврат ИСТИНА;
    КонецЕсли;
    лчКорень=Exp(Log(пчЧисло)0.5);
    лчМакс=пмПростыеЧисла.Количество();
    Для лч=1 По лчМакс Цикл
        лчПростое=пмПростыеЧисла[лч-1];
        Если лчКорень<лчПростое Тогда
            Прервать;
        КонецЕсли;
        лчРезультат=пчЧисло/лчПростое;
        Если(Цел(лчРезультат)лчПростое)=пчЧисло Тогда
            Возврат ЛОЖЬ;
        КонецЕсли;
    КонецЦикла;
    пмПростыеЧисла.Добавить(пчЧисло);
    Возврат ИСТИНА;
КонецФункции

Процедура КнопкаВыполнитьНажатие(Кнопка)
    // Вставить содержимое обработчика.

    Если фчВысота<1 Тогда
        Сообщить("(!)Это разве высота:"+Строка(фчВысота));
        Возврат;
    КонецЕсли;
    лтд=Новый ТабличныйДокумент;
    лчЧисло=1;
    лмПростыеЧисла=Новый Массив;
    Для лчСтрока=1 По фчВысота Цикл
        Для лчПозиция=(фчВысота-лчСтрока+1)По(фчВысота+лчСтрока-1)Цикл
            лобл=лтд.Область(лчСтрока,лчПозиция);
            лобл.Текст=Формат(лчЧисло);
            Если ЭтоПростоеЧисло(лчЧисло,лмПростыеЧисла)=ИСТИНА Тогда
                лобл.ЦветФона=Новый Цвет(255,255,0);
            КонецЕсли;
            лчЧисло=лчЧисло+1;
        КонецЦикла;
    КонецЦикла;
    лтд.Показать("Пирамида");
КонецПроцедуры
   Salimbek
 
244 - 10.09.16 - 09:51
(243) Сугубо имха, т.к. мы все равно пробегаем все числа, то проще использовать "Решето Эратосфена".
   Одинесю
 
245 - 10.09.16 - 09:57
О как, даже сильные форума сего затруднения испытали...
   Salimbek
 
246 - 10.09.16 - 10:14
(245) Придумать задачку много проще, чем ее сделать. Например, дана строка С, состоящая из цифр, и число К - показывающее - сколько цифр можно заменить. Нужно в ответе вывести или максимальный палиндром, получаемый за K замен, или "-1", если палиндром получить нельзя.
Длина(С) и К<10^5
Например
К=1
С="3493"
Ответ: "3993"
К=3
С="092282"
Ответ: "992299"
К=1
С="0011"
Ответ: "-1"
   Одинесю
 
247 - 10.09.16 - 10:49
(246) Так в том и вопрос - кто такие задачки придумывает и нужны ли они реально работодателю.
   Starhan
 
248 - 13.09.16 - 14:32
Ну вот для примера рабочая задачка

Нужно что бы по определенному признаку допустим галка в справочнике номенклатура

Пользователь мог видеть эту номенклатуру в списке, Но не мог изменять ее и выбирать в любом документе.
   xafavute
 
249 - 13.09.16 - 14:39
(247) смотря сколько кандидатов у них.
Если чрезмерно, как в гугле, то можно и такие задачки давать
 
 Рекламное место пустует
   Торин
 
250 - 13.09.16 - 14:40
Вот еще для примера совершенно реальная задача -- есть координаты точки -- широта и долгота. Есть координаты точек МКАДа, требуется определить находится ли точка внутри МКАДа или снаружи... Точки на МКАДе заданы через каждый километр...
   Торин
 
251 - 13.09.16 - 14:42
Задачка решается десятью строчками кода...
   Torquader
 
252 - 13.09.16 - 14:46
(250) Ну, если человек сплайны умеет строить - то проблем нет, а если не умеет, то пусть отрезками мучается.
   igork1966
 
253 - 13.09.16 - 14:46
(251) Нет смысла в такой задаче на собеседовании с программистом 1С. Очень специфическая задача.
   DomovoiAtakue
 
254 - 13.09.16 - 14:53
(252)Вы так говорите как будто сплайнами легче)))
(253)Не знает что такое система координат?

Если у программиста проблемы с задачами на мышление, может стоит задуматься что он за программист и прокачать немного логику, математику, кругозор?
   Fragster
 
255 - 13.09.16 - 14:53
(253) да ты что? автоматизировать тарифную зону по адресу, координаты из адреса получить через api яндекс карт...
   DomovoiAtakue
 
256 - 13.09.16 - 14:54
+(254)А не только зазубренными шаблона писать.
   DomovoiAtakue
 
257 - 13.09.16 - 14:54
*шаблонами
   igork1966
 
258 - 13.09.16 - 14:56
(255) На собеседовании нет смысла.
   DomovoiAtakue
 
259 - 13.09.16 - 14:57
(258)А что на собеседовании спрашивать, чтоб узнать умеет человек думать?
   DomovoiAtakue
 
260 - 13.09.16 - 14:59
На Экзамене в универ по информатике какие задачи дают?
   igork1966
 
261 - 13.09.16 - 15:01
(259) Запрос написать средней сложности как вариант

А задача в (250) решается с помощью гугла, не очень долго.
Но требовать чтобы прог обязательно сталкивался с такой задачей и помнил алгоритм, лишнее...
   Fragster
 
262 - 13.09.16 - 15:05
(261) в этом и проблема - решается она не с помощью гугла, а с помощью бумажки и ручки
   DomovoiAtakue
 
263 - 13.09.16 - 15:06
(261)"Но требовать чтобы прог обязательно сталкивался с такой задачей и помнил алгоритм, лишнее..."
Вот такие программисты - не есть программисты и их пытаются отсеять. Мозг дан чтоб не зубрить алгоритмы, а чтоб самому за секунды придумывать решения.
   xafavute
 
264 - 13.09.16 - 15:06
(262) это уже больше математическая задача а не программерская
   DomovoiAtakue
 
265 - 13.09.16 - 15:08
Все что в этой задаче надо знать это что такое система координат и я зык программирования. Все остальное чисто ваш уровень логики.
   igork1966
 
266 - 13.09.16 - 15:09
(262) И решишь это не оптимально.
   Fragster
 
267 - 13.09.16 - 15:11
(266) критерий "оптимальности"? оптимизировать надо после замеров. навскидку есть два пути - через площади треугольников (тут надо знать, да. ну, или нарисовать и придумать) и через отрезки (более очевидный). и оба этих способа вполне себе работают.
надо только знать их ограничения
   DailyLookingOnASunse
 
268 - 13.09.16 - 15:11
(111)
Запрос про два последних курса валюты есть на партнерском форуме, он простой как 3 копейки.
Но в реальной работе он мне понадобился 1 раз за десяток лет.
Поэтому и знают его 3 человека из 200.
   Fragster
 
269 - 13.09.16 - 15:13
(268) его не надо "знать". надо придумать, как имеющимися средствами подучить нужный результат.
   Fragster
 
270 - 13.09.16 - 15:14
(267)+ способ с треугольниками работает для выпуклых многоугольников, с отрезками - для любых
   igork1966
 
271 - 13.09.16 - 15:16
(268) Можно определить как знает SQL. А в (250) определишь сталкивался ли с подобной задачей и как давно.
   DomovoiAtakue
 
272 - 13.09.16 - 15:17
Эх гуманитарии)))) Вас вот и проверяют способны ли вы придумать что-то, когда закончатся шаблоны?
   Nuobu
 
273 - 13.09.16 - 15:18
(272) Моё внутреннее чутьё подсказывает, что это не случится никогда.
   DomovoiAtakue
 
274 - 13.09.16 - 15:19
У меня был предмет методы алгоритмизации. Там было около 40 алгоритмов на 40-60 строк каждый. Так вот особо одаренные вызубрили эти алгоритмы) Никто из них не стал программистом)
   Торин
 
275 - 13.09.16 - 15:19
Ззадачка из 250 легко решается если вспомнить что интеграл по контуру от точки внутри контура равен нулю. Это т.н. "интегральная теорема Коши"
   ifso
 
276 - 13.09.16 - 15:20
(269)
> имеющимися средствами
средства не ограничиваются?
   DailyLookingOnASunse
 
277 - 13.09.16 - 15:21
(271)
И с такой сталкивался, только не по работе.
Или во время школы, когда занимательные задачи по математике решал, или в вузе.
   Fragster
 
278 - 13.09.16 - 15:27
(276) ручка, бумага, комп с одноэской
   igork1966
 
279 - 13.09.16 - 15:28
(268) А там знать нечего. Если ты знаешь SQL и представляешь что такое регистр сведений, то он пишется без труда. Причем по мне бы достаточно было описать способ решения. И это проверят знание в принципе одного из основных инструментов 1С программиста...
   xafavute
 
280 - 13.09.16 - 15:28
(278) А может задачку ту самую по геометрии задать, где нужноугол в треугольнике найти?
   DomovoiAtakue
 
281 - 13.09.16 - 15:30
(273)Ну все еще держится благодаря мисте и таким прогам которые за всех всё делают)
   ViSo76
 
282 - 13.09.16 - 15:32
(281) ..., ну вы держитесь :)
   DomovoiAtakue
 
283 - 13.09.16 - 15:33
(280)Трупроги и ту решат)
   DailyLookingOnASunse
 
284 - 13.09.16 - 15:36
(279)
"Если ты знаешь SQL" (C)
Ну так я B пишу, что это знание, а со мной спорят.
   DailyLookingOnASunse
 
285 - 13.09.16 - 15:37
я и пишу
   DomovoiAtakue
 
286 - 13.09.16 - 15:38
(284)Тебе говорят что надо знать язык запросов но не каждый запрос под задачу. Запрос надо придумывать, а не заранее знать.
   DailyLookingOnASunse
 
287 - 13.09.16 - 15:44
Я и смотрю, как 150 постов придумывали, что простое число нужно делить на другие простые. А это чуть ли не школьная классика.
   DomovoiAtakue
 
288 - 13.09.16 - 15:45
(287)Так вроде тема не о том смогут ли решить проги эту задачу, а о том надо ли ее решать.
   DomovoiAtakue
 
289 - 13.09.16 - 15:46
*надо ли ее решать на собеседовании, что проверяют таки образом.
   Fragster
 
290 - 13.09.16 - 15:47
(289) таким образом проверяют, что ты немного знаешь синтаксис языка 1с, работу с табличными документами и формами. Ну и можешь логически мыслить.
   DailyLookingOnASunse
 
291 - 13.09.16 - 15:47
На хабре есть довольно большое обсуждение про то, что нужно уметь прогу, и не одно.
По результатам вроде алгоритмы не на первом месте.
   DomovoiAtakue
 
292 - 13.09.16 - 15:48
(291)Поэтому на хабре и нет программистов) Есть ходячие энциклопедии, а что делать с этими знаниями они не знают)
   DomovoiAtakue
 
293 - 13.09.16 - 15:49
Прог - это человек составляющий алгоритмы. Как может это быть не главным?) Это то без чего он не прог)
   igork1966
 
294 - 13.09.16 - 15:51
Вот кстати задача, вроде и по языку запросов... но на собеседование я бы ее не дал...

Получить из справочника запросом коды справочника без разделителя. (например, там точка в коде)

PS. Модификация задачи получения некого текстового поля (содержащего значения с разделителями) в виде списка.
   Fragster
 
295 - 13.09.16 - 15:59
(294) вопрос в вырезании текста из строки запросом, или фильтрации данных?
   igork1966
 
296 - 13.09.16 - 16:01
(295) получить из:

123.334.1
123.334.2

вот такое:

1233341
1233342
   igork1966
 
297 - 13.09.16 - 16:02
(296) + в запросе конечно
   Fragster
 
298 - 13.09.16 - 16:04
(296)(297) вот это как раз забивание гвоздей микроскопом. гораздо эффективнее сделать это другими средствами
   igork1966
 
299 - 13.09.16 - 16:06
(298) Ну мне понадобилось в отчете... где один из источников данных формируется из внешнего источника. Их потом соединить нужно было...
   Fragster
 
300 - 13.09.16 - 16:07
(299) ну так ничего не мешает сделать сначала отфильтрованные данные, а потом запихать их как набор данных в СКД. причем из СКД даже фильтры можно брать
  1  2  3  4   

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует