Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Не выдает результаты клюшки

↓ [zak555, 08.09.16 - 11:52]
v7: Не выдает результаты клюшки
Я
   program345
 
08.09.16 - 09:28
Добрый день!

Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос

    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)

    |Период с ВыбНачПериода по ВыбКонПериода;
    |Без итогов;
    |Товар = Документ.РасходнаяНакладная.Товар, Документ.ПоступлениеТоваров.Товар;
    |Количество = Документ.РасходнаяНакладная.Количество, Документ.ПоступлениеТоваров.Количество;
    |СуммаРеализации = Документ.РасходнаяНакладная.Всего;
    |ТекущийДокумент = Документ.РасходнаяНакладная.ТекущийДокумент, Документ.ПоступлениеТоваров.ТекущийДокумент;
    |НомерДок = Документ.РасходнаяНакладная.НомерДок;
    |ДатаДок = Документ.РасходнаяНакладная.ДатаДок;
    |Цена = Документ.РасходнаяНакладная.Цена, Документ.ПоступлениеТоваров.Цена;
    |Сумма = Документ.РасходнаяНакладная.Сумма, Документ.ПоступлениеТоваров.Сумма;
    |Функция КоличествоСумма = Сумма(Количество);
    |Функция СуммаРеализацииСумма = Сумма(СуммаРеализации);
    |Группировка ТекущийДокумент без групп;
    |Группировка Товар без групп;
    |"//}}ЗАПРОС

    ;
    // Если ошибка в запросе, то выход из процедуры

    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;

    // Подготовка к заполнению выходных форм данными запроса

    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"

    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка() = 1 Цикл
        // Заполнение полей Сформировать

        Таб.ВывестиСекцию("Сформировать");
    КонецЦикла;
    // Вывод заполненной формы

    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
КонецПроцедуры


не попадает в цикл  Пока Запрос.Группировка() всегда =0

как победить?
 
 
   Рэйв
 
1 - 08.09.16 - 09:29
у тебя ж их две.попробуй
Пока Запрос.Группировка(1)
   Метранпаж
 
2 - 08.09.16 - 09:30
(1) У него без итогов. Читай внимательней
   Ёпрст
 
3 - 08.09.16 - 09:31
(0) за выбранный период нет проведенных документов.
(2) Почитай СП на ночь.
   program345
 
4 - 08.09.16 - 09:47
(3) да, оказалось все доки распроведены
   Ёпрст
 
5 - 08.09.16 - 09:58
(4) можешь добавить ОбрабатыватьДокументы Все; в текст, в таком случае.
   Ёпрст
 
6 - 08.09.16 - 09:58
и еще условие, что не помеченные на удаление
   mkalimulin
 
7 - 08.09.16 - 10:01
(0) "Без итогов" добавь в запрос.
   Ёпрст
 
8 - 08.09.16 - 10:10
(7) ты не поверишь, он там и так есть
   mkalimulin
 
9 - 08.09.16 - 10:11
(8) Уже увидел.
   program345
 
10 - 08.09.16 - 10:18
(5) а куда этот код вставить? я не бум бум в клюшках.
 
 Рекламное место пустует
   пипец
 
11 - 08.09.16 - 10:54
Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)

    |ОбрабатыватьДокументы все;
    |Документы = Документ.АктРазногласия.ТекущийДокумент;
    |"//}}ЗАПРОС

    

тип таво
   пипец
 
12 - 08.09.16 - 10:55
после периода строчку добавь
   big
 
13 - 08.09.16 - 10:58
Пока Запрос.Группировка("ТекущийДокумент") = 1 Цикл    <<== имя группировки
        // Заполнение полей Сформировать


        Таб.ВывестиСекцию("Сформировать");
КонецЦикла;
   Ёпрст
 
14 - 08.09.16 - 11:02
(13) Тоже, почитай СП на ночь :)
Или вспомни, что есть Без Итогов в тексте запроса
   MariNew
 
15 - 08.09.16 - 11:27
а что хотел "получить" группировкой "ТекущийДокумент", и в ней вложенная группировка "Товар" ?
   MariNew
 
16 - 08.09.16 - 11:31
К тому же, в запросе смешаны виды документов РНК и ПНК ?
   MariNew
 
17 - 08.09.16 - 11:36
У группировки  Группировка ТекущийДокумент без групп - не может быть "группы" как таковой. Это же просто документы за указанный период
   program345
 
18 - 20.09.16 - 09:32
всем спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует