Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Перейти на найденную строку т.ч. документа

v7: Перейти на найденную строку т.ч. документа
Я
   vadim777
 
07.09.16 - 13:50
Фрагмент обработки т.ч. документа:
ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
   Если Номенклатура = Ном Тогда
      // Сделать найденную строку текущей

      Прервать;
   КонецЕсли;
КонецЦикла;
Как перейти на найденную строку?
 
 
   Метранпаж
 
1 - 07.09.16 - 13:51
Активировать() ?
   aka AMIGO
 
2 - 07.09.16 - 13:53
Есть "ПолучитьСтрокуПоНомеру()" - глянь в СП, может и примеры в конфе есть..
   Метранпаж
 
3 - 07.09.16 - 13:54
(2) не прокатит
   silent person
 
4 - 07.09.16 - 13:56
АктивизироватьСтроку(<?>);
Синтаксис:
АктивизироватьСтроку(<НомСтроки>)
Назначение:
Установить курсор на указанной строке  многострочной части документа.
   aka AMIGO
 
5 - 07.09.16 - 13:56
(3) Ну, может быть..
Если Номенклатура = Ном Тогда
...
ПолучитьСтрокуПоНомеру(НомерСтроки);
...
   Метранпаж
 
6 - 07.09.16 - 13:56
(5) ПолучиьтСтроку... это для программного перемещения по объекту, а по элеемнту формы
   aka AMIGO
 
7 - 07.09.16 - 13:57
(6) Ты прав :)
   Метранпаж
 
8 - 07.09.16 - 13:57
(7) я знаю ))
   vadim777
 
9 - 07.09.16 - 14:01
Вот такое работает:
ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
   Если Номенклатура = Ном.ТекущийЭлемент() Тогда
      ПолучитьСтрокуПоНомеру(НомерСтроки);
      Прервать;
   КонецЕсли;
КонецЦикла;
   Это_mike
 
10 - 07.09.16 - 14:01
(0) СП украли?
 
 Рекламное место пустует
   Метранпаж
 
11 - 07.09.16 - 14:01
(9) Как именно работаеет?
   vadim777
 
12 - 07.09.16 - 14:04
(9) Активна любая строка т.ч. документа.
Жмем Insert, выбираем ТМЦ. Если выбранный ТМЦ есть в т.ч., то эта строка становится текущей, если нет - добавляется новая.
   Это_mike
 
13 - 07.09.16 - 14:04
(11) получает строку по номеру.... :-)
   Метранпаж
 
14 - 07.09.16 - 14:06
   Это_mike
 
15 - 07.09.16 - 14:08
(14) букву "т" пропустил...
   vadim777
 
16 - 07.09.16 - 14:08
Пардоньте, правильно:
АктивизироватьСтроку(НомерСтроки);
   Это_mike
 
17 - 07.09.16 - 14:10
(16) ты все-таки открыл для себя СП?
   vadim777
 
18 - 07.09.16 - 14:18
(17) В СП слишком мелкие буквы - пользуюсь 1CPRG.HLP

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует