Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Обновить данные Табличной части документа.

Обновить данные Табличной части документа.
Я
   dred999
 
07.09.16 - 11:19
Всем Привет!
Столкнулся с такой проблемой: В Бухгалтерия 8.3 есть документ "Инвентаризация Товаров". Тк вот, открываю этот документ, обработкой вношу в табличную часть изменения (колонка количество) обработкой же записываю документ но в открытом документе данные таб части не меняются. Только после того как закроешь документ и заново откроешь изменения отображаются.
Как сказать в этой же обработке или в документе (т.к. кусок кода открывающий обработку находится в модуле формы этого документа) обновлять данные табличной части документа?
 
 
   aka AMIGO
 
1 - 07.09.16 - 11:29
А что, открыть заново той-же обработкой не получится?
   aka AMIGO
 
2 - 07.09.16 - 11:31
Или уж сказать юзеру, что требуется док закрыть и открыть заново.. Этого требует алгоритм
   dred999
 
3 - 07.09.16 - 11:31
(1) На сервере получать форму документа а затем открывать ее на клиенте?
   Nuobu
 
4 - 07.09.16 - 11:32
ОбновитьОтображениеДанных,
ФормаДокумента.Таблица.Обновить,
ФормаДокумента.Обновить.
Пробуй разные варианты.
   aka AMIGO
 
5 - 07.09.16 - 11:33
(3) Ммм.. пардон :)
   dred999
 
6 - 07.09.16 - 11:39
(4) Пробую
   Cyberhawk
 
7 - 07.09.16 - 11:41
Из (4) сработает, насколько помню, только метод формы (первый)
   Cyberhawk
 
8 - 07.09.16 - 11:42
Метод таблицы (почему-то) не срабатывает
   dred999
 
9 - 07.09.16 - 11:43
(8) Хмммм. как же быть..
   MishaD
 
10 - 07.09.16 - 11:49
(9) Если все равно документ открываешь, то может внешнюю обработку заполнения табличной части использовать ?
 
 Рекламное место пустует
   dred999
 
11 - 07.09.16 - 12:08
(10) Ну тк вот как ее использовать?
   hhhh
 
12 - 07.09.16 - 12:37
(8) обновить точно не сработает, данные которые уже закружены, обновляются на экране. А надо загрузить данные из базы.
   Метранпаж
 
13 - 07.09.16 - 12:38
оповеститьОбИзменении) не поможет?
   DefMB
 
14 - 07.09.16 - 12:43
В типовой БП30 делается через оповещение, смотри в общих модулях процедуру 
// Процедура вызывается из модуля формы документов при обработке оповещения

//
// Параметры:

//   Форма - Управляемая форма, для которой производится обработка оповещения
//   ДокументСсылка - ссылка на документ формы

//   ИмяСобытия - имя обрабатываемого события
//   Параметр - параметр, переданный в обработку оповещения

//   Источник - источник, переданный в обработку оповещения
Процедура ОбработкаОповещенияФормыДокумента(Форма, ДокументСсылка, ИмяСобытия, Параметр, Источник) Экспорт
    Если ИмяСобытия = "ВыполненаЗаписьДокумента" Тогда
        Если ДокументСсылка = Параметр.ДокументСсылка Тогда 
            Форма.Прочитать();
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры
   dred999
 
15 - 07.09.16 - 12:51
(13) Нет не помогает
   dred999
 
16 - 07.09.16 - 14:32
(14) Все отработало. Спасибо!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует