Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Не запускается внеш печ форма поле объекта не обнаружено Движения

Не запускается внеш печ форма поле объекта не обнаружено Движения
Я
   1сЮлия
 
06.09.16 - 18:57
Добрый вечер! Написала одну печ фррму всё нормально,а вторую написала  для дока ВводВЭксплуатацию приказНаВводВЭксплуатацию пишут поле объекта не обнаружено Движения
Функция ПодготовитьТаблицуОС(СтруктураШапкиДокумента)
    
    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ
    |    Док.НомерСтроки                                         КАК НомерСтроки,
    |    &ПустойДоговор                                          КАК ДоговорКонтрагента,
    |    Док.Ссылка.ОтражатьВУправленческомУчете                 КАК ОтражатьВУправленческомУчете,
    |    Док.Ссылка.Склад                                        КАК Склад,
    |    Док.Ссылка.Номенклатура                                 КАК Номенклатура,
    |    Док.Ссылка.ХарактеристикаНоменклатуры                    КАК ХарактеристикаНоменклатуры,
    |    Док.Ссылка.СерияНоменклатуры                            КАК СерияНоменклатуры,
    |    Док.Ссылка.Организация                                  КАК Организация,
    |    Док.Ссылка.Подразделение                                КАК Подразделение,
    |    Док.Ссылка.Номенклатура.Услуга                          КАК Услуга,
    |    Док.ОсновноеСредство                                    КАК ОсновноеСредство,
    |    Док.ИнвентарныйНомер                                    КАК ИнвентарныйНомер,
    |    1                                                       КАК Количество,
    |    Док.Ссылка.СчетУчетаБУВнеоборотногоАктива               КАК СчетУчетаБУ,
    |    Док.Ссылка.СчетУчетаБУ                                  КАК КорСчетСписанияБУ,
    |    Док.ОсновноеСредство                                    КАК КорСубконтоСписанияБУ1,
    |    &НомерЖурнала                                           КАК НомерЖурналаБУ,
    |    НЕОПРЕДЕЛЕНО                                            КАК ДокументОприходования,
    |    Док.Ссылка.НалоговоеНазначениеОборудования              КАК НалоговоеНазначение,
    |    Док.Ссылка.НалоговоеНазначение                          КАК НалоговоеНазначениеНовое
    |ИЗ
    |    Документ.ВводВЭксплуатациюОС.ОС КАК Док
    |ГДЕ
    |    Док.Ссылка = &Ссылка";
    
    Запрос.УстановитьПараметр("Ссылка"       , СтруктураШапкиДокумента.Ссылка );
    Запрос.УстановитьПараметр("ПустойДоговор", Справочники.ДоговорыКонтрагентов.ПустаяСсылка());
    Запрос.УстановитьПараметр("НомерЖурнала" , "ОС");
    
    Результат = Запрос.Выполнить();
    ТаблицаПоОС = Результат.Выгрузить();
    ТаблицаПоОС.Колонки.Добавить("Регистратор");
    ТаблицаПоОС.ЗаполнитьЗначения(ЭтотОбъект, "Регистратор");
    ТаблицаПоОС.Колонки.Добавить("СчетДоходовБУ");
    
    Возврат ТаблицаПоОС;

КонецФункции// ПодготовитьТаблицуОС()


Функция Печать() Экспорт 
    Запрос = Новый Запрос();
    Запрос.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект.Ссылка);
    Запрос.УстановитьПараметр("ТекДата",     СсылкаНаОбъект.МоментВремени());
    Запрос.УстановитьПараметр("ТекОрганизация", СсылкаНаОбъект.Ссылка.Организация);
    
    Запрос.Текст = 
    "ВЫБРАТЬ
    |    Док.Дата КАК Дата,
    |    Док.Организация.НаименованиеПолное КАК Организация,
    |    Док.Организация КАК ОрганизацияСсылка,
    |    Док.Дата КАК ДатаВвода,
    |    Док.СрокПолезногоИспользованияБУ КАК СрокЭксплуатации,
    |    Док.НалоговаяГруппаОС КАК НалоговаяГруппаОС,
    |    Док.СпособНачисленияАмортизацииБУ КАК МетодАмортизации,
    |    Док.ЛиквидационнаяСтоимостьБУ КАК ЛиквидационнаяСтоимость,
    |    Док.СтоимостьБУ КАК ПервоначальнаяСтоимость
    //|    Док.Комментарий КАК Заголовок

    |ИЗ
    |    Документ.ВводВЭксплуатациюОС КАК Док
    |ГДЕ
    |    Док.Ссылка = &ТекущийДокумент";
    ВыборкаПоШапке = Запрос.Выполнить().Выбрать();
    ВыборкаПоШапке.Следующий();

    СписокОС = СсылкаНаОбъект.Ссылка.ОС.ВыгрузитьКолонку("ОсновноеСредство");                                                
    Запрос = Новый Запрос();
    Запрос.УстановитьПараметр("Ссылка", СсылкаНаОбъект.Ссылка);
    Запрос.УстановитьПараметр("ТекДата", СсылкаНаОбъект.Ссылка.Дата);
    Запрос.УстановитьПараметр("СписокОС", СписокОС);
    Запрос.УстановитьПараметр("ТекОрганизация", СсылкаНаОбъект.Ссылка.Организация);
    Запрос.УстановитьПараметр("СостояниеВвода", Перечисления.СостоянияОС.ВведеноВЭксплуатацию);

    
    Запрос.Текст = "ВЫБРАТЬ
                   |    ВводВЭксплуатациюОСОС.ИнвентарныйНомер,
                   |    ВводВЭксплуатациюОСОС.ОсновноеСредство.НаименованиеПолное КАК НаименованиеОС,
                   |    ВводВЭксплуатациюОСОС.ОсновноеСредство КАК ОсновноеСредство
                   |ИЗ
                   |    Документ.ВводВЭксплуатациюОС.ОС КАК ВводВЭксплуатациюОСОС
                   |ГДЕ
                   |    ВводВЭксплуатациюОСОС.Ссылка = &Ссылка";
                
    
    Результат = Запрос.Выполнить();
    ВыборкаПоОС = Результат.Выгрузить();
    
    
    // Сформируем структуру реквизитов шапки документа

    СтруктураШапкиДокумента = ОбщегоНазначения.СформироватьСтруктуруШапкиДокумента(СсылкаНаОбъект.Ссылка);
                                     
    СтруктураШапкиДокумента.Вставить("ВидСклада",
                                     СтруктураШапкиДокумента.Склад.ВидСклада);
    
    ТаблицаПоОС = ПодготовитьТаблицуОС(СтруктураШапкиДокумента);
    Если СтруктураШапкиДокумента.ВидОперации = Перечисления.ВидыОперацийПринятияКУчетуОсновныхСредств.Оборудование Тогда
        УправлениеЗапасамиПартионныйУчет.ДвижениеПартийТоваров(СсылкаНаОбъект.Ссылка, ТаблицаПоОС, , Ложь, СтруктураШапкиДокумента.ОтражатьВБухгалтерскомУчете, , , Ложь, , "Ввод в эксплуатацию объекта ОС");
    КонецЕсли;
    
    ТабДокумент   = Новый ТабличныйДокумент();
    ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_СписаниеОС_ОЗ3";
    Макет = ПолучитьМакет("Приказ");
    
    Руководители = ОбщегоНазначения.ОтветственныеЛица(ВыборкаПоШапке.ОрганизацияСсылка, ВыборкаПоШапке.Дата);
        
    //ВалютаРегламентированногоУчета = Константы.ВалютаРегламентированногоУчета.Получить();

    
    //ОбластьМакета = Макет.ПолучитьОбласть("Приказ");

    //Параметры     = ОбластьМакета.Параметры;

    //Параметры.Заполнить(ВыборкаПоШапке);

    //Параметры.НомерАкта = ОбщегоНазначения.ПолучитьНомерНаПечать(ЭтотОбъект) + "/ОЗ";

    //ТабДокумент.Вывести(ОбластьМакета);

    
    Для Каждого ТекСтрока Из ВыборкаПоОС Цикл

        ОбластьМакета = Макет.ПолучитьОбласть("Приказ");
        Параметры     = ОбластьМакета.Параметры;
        Параметры.Заполнить(ВыборкаПоШапке);
        Параметры.Заголовок = "Наказ № " + ВыборкаПоШапке.Дата;
        параметры.ДатаВвода = Формат(ВыборкаПоШапке.ДатаВвода, "ДФ='dd.MM.yyyy'");
        Параметры.НаименованиеОС = ТекСтрока.НаименованиеОС;
        Параметры.ИнвентарныйНомер = ТекСтрока.ИнвентарныйНомер;
        Если СтруктураШапкиДокумента.ВидОперации = Перечисления.ВидыОперацийПринятияКУчетуОсновныхСредств.Оборудование Тогда
            Стр = ТаблицаПоОС.Найти(ТекСтрока.ОсновноеСредство);
            Если  Стр <> Неопределено Тогда
                Параметры.ПервоначальнаяСтоимость = Стр.СписанныеПартииБУ.Итог("СуммаСписания");
            КонецЕсли;
        КонецЕсли;
        
        Если ЗначениеЗаполнено(Руководители.РуководительФИО) Тогда
            Параметры.Директор = ОбщегоНазначения.ПолучитьФамилиюИмяОтчество(Руководители.РуководительФИО.Фамилия, Руководители.РуководительФИО.Имя, Руководители.РуководительФИО.Отчество, Истина);// Кратко

        КонецЕсли;

        ТабДокумент.Вывести(ОбластьМакета);
        
        ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
    КонецЦикла;
    //ОбластьМакета = Макет.ПолучитьОбласть("Дно");

    //Параметры     = ОбластьМакета.Параметры;

    //Параметры.Заполнить(ВыборкаПоШапке);

    //Если ЗначениеЗаполнено(Руководители.РуководительФИО) Тогда

    //    Параметры.Директор = ОбщегоНазначения.ПолучитьФамилиюИмяОтчество(Руководители.РуководительФИО.Фамилия, Руководители.РуководительФИО.Имя, Руководители.РуководительФИО.Отчество, Истина); // Кратко

    //КонецЕсли;

    //ТабДокумент.Вывести(ОбластьМакета);

    
    ТабДокумент.ОбластьПечати = ТабДокумент.Область(2, 2, ТабДокумент.ВысотаТаблицы, ТабДокумент.ШиринаТаблицы);
    Возврат ТабДокумент;

КонецФункции// ПечатьПриказ()

что не так отладчик вродибы все значения передаются?
 
 
   Жан Пердежон
 
1 - 06.09.16 - 19:04
УправлениеЗапасамиПартионныйУчет.ДвижениеПартийТоваров(СсылкаНаОбъект.Ссылка, ТаблицаПоОС, , Ложь, СтруктураШапкиДокумента.ОтражатьВБухгалтерскомУчете, , , Ложь, , "Ввод в эксплуатацию объекта ОС");

- это точно должно быть в печатной форме?
   1сЮлия
 
2 - 06.09.16 - 19:21
Да нет,получается из за этой строки,в не проведенном доке  форма открывается в проведенном ругается  поле объекта не обнаружено Движения
   1сЮлия
 
3 - 06.09.16 - 19:27
открывает печатную форму заполняет и ругается в служ  в сообщениях это в непровед доке
Бух. учет. Строка :1
Не списано 1  товара , счет учета 1521 , налог. назначение:
в провед доке пишет

Бух. учет. Строка :1
Не списано 1  товара , счет учета 1521 , налог. назначение:
Не удалось сформировать внешнюю печатную форму!
Поле объекта не обнаружено (Движения)
   Жан Пердежон
 
4 - 06.09.16 - 19:55
(3) спрошу по-другому,
зачем ты этот код вставила в печатную форму?

Первоначальная стоимость уже рассчитана должна быть, ее заново рассчитывать совсем не обязательно.
   1сЮлия
 
5 - 06.09.16 - 21:30
Как мне правильно получить Первоначальная стоимость,я убрала эту строку теперь нормально все но нету первоначальной стоимости?
   1сЮлия
 
6 - 06.09.16 - 23:12
Я доделала,спасибо!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует