Вход | Регистрация


Как в обычном приложении открыть обработку с диска?

Как в обычном приложении открыть обработку с диска?
Я
   DTX 4th
 
06.09.16 - 14:59
В интернете нашёл для УФ:
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    //Помещаем обработку во временном хранилище

    АдресХранилища = "";
    Результат = ПоместитьФайл(АдресХранилища, "C:\ВнешняяОбработка.epf", , Ложь);           
    ИмяОбработки = ПодключитьВнешнююОбработку(АдресХранилища);
    
    // Откроем форму подключенной внешней обработки

    ОткрытьФорму("ВнешняяОбработка."+ ИмяОбработки +".Форма");
КонецПроцедуры
&НаСервере
Функция ПодключитьВнешнююОбработку(АдресХранилища)
    Возврат ВнешниеОбработки.Подключить(АдресХранилища); 
КонецФункции 


Пытался так:
Процедура НачислениеЗарплатыНажатие(Элемент)
     
    ИмяОбработки = ПодключитьВнешнююОбработку("N:\Обработки\1.epf");
    
    // Откроем форму подключенной внешней обработки

    ОткрытьФорму("ВнешняяОбработка."+ ИмяОбработки +".Форма");

КонецПроцедуры

Функция ПодключитьВнешнююОбработку(АдресХранилища)

    Возврат ВнешниеОбработки.Подключить(АдресХранилища);

КонецФункции

И так
Процедура НачислениеЗарплатыНажатие(Элемент)
    //Документы.НачислениеЗарплатыРаботникамОрганизаций.ПолучитьФормуСписка(, ЭтаФорма).Открыть();

    АдресХранилища = "";
    Результат = ПоместитьФайл(АдресХранилища, "N:\Обработки\1.epf", , Ложь);           
    ИмяОбработки = ПодключитьВнешнююОбработку(АдресХранилища);
    
    // Откроем форму подключенной внешней обработки

    ОткрытьФорму("ВнешняяОбработка."+ ИмяОбработки +".Форма");

КонецПроцедуры

Функция ПодключитьВнешнююОбработку(АдресХранилища)

    Возврат ВнешниеОбработки.Подключить(АдресХранилища);

КонецФункции

ЧЯДНТ?
 
 
   Метранпаж
 
1 - 06.09.16 - 15:02
Извините, а зачем в ОФ обработку в хранилище помещать? Она всё равно на клиенте работать будет..
   DTX 4th
 
2 - 06.09.16 - 15:08
(1) Можно и не помещать - лишь бы работало)
   Метранпаж
 
3 - 06.09.16 - 15:11
имяФайла = "c:\rm-rf.ert";
форма = ВнешниеОбработки.ПолучитьФорму(имяФайла, ИмяФормы);

форма.Открыть()
   DTX 4th
 
4 - 06.09.16 - 15:24
(3) Спасибо!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует