Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Заполнение нового документа из внешней обработки

Заполнение нового документа из внешней обработки
Я
   alekowks
 
06.09.16 - 12:25
Приветствую.

Снова я обращаюсь к вам со странным вопросом)
Суть следующая: Для бухгалтерии 3.0 написала обработку поиска номенклатуры по коду и вывод ее в ТЧ, далее хочу эты найденную и выбранную номенклатуру загрузить в ТЧ создаваемого документа.
Документ и заполнение его происходит с помощью кнопки на форме этой же внешней обработки.

Выборка и поиск работают, по кнопке даже создается документ, но он пустой.
Предполагаю, что при заполнении не получаются данные из ТЧ обработки.

Сам вопрос ткнуть в какую сторону смотреть. В гугле есть множество заполнений ТЧ, но там только данные берут из документа. Спасибо

код простой на заполнение:
 Основание = ССылкаНаОбъект;
          
     Для каждого СтрТЗ Из НайтиНоменклатуруПоШтрихкоду() Цикл
       НовСтрока = Основание.ИнвентарьИХозяйственныеПринадлежности.Добавить(); 
        ЗаполнитьЗначенияСвойств(НовСтрока, СтрТЗ);
    
ПолучитьФорму("Документ.ПередачаМатериаловВЭксплуатацию.ФормаОбъекта",Новый Структура("Ключ",ССылкаНаОбъект),);
             
        ЭтаФорма.Отбор.Выгрузить(Элементы.ТаблицаОтбора.ТекущиеДанные);
        Основание.ИнвентарьИХозяйственныеПринадлежности.Загрузить(Отбор.Выгрузить());
    
          Сообщить("");
        
        КонецЦикла;
КонецЕсли;
       КонецЦикла;
 
 
   Timon1405
 
1 - 06.09.16 - 12:31
http://its.1c.ru/db/bspdoc#content:429:1:issogl2_загрузка_данных_в_табличную_часть_документа_или_справочника
   alekowks
 
2 - 06.09.16 - 12:40
(1) спасибо, но ксожалению мне не доступно это, никак
   alekowks
 
3 - 06.09.16 - 15:07
может есть еще идеи?
   Ivan86
 
4 - 06.09.16 - 15:28
(3)Может я что не понял но почему не такая конструкция?
Док = Документы.МойДок.СоздатьДокумент()

Для каждого Строка из ТЧОткудаБеремНоменклатуру цикл
НоваяСтрока = Док.ТЧ.Добавить();
НоваяСтрока.Номенклатура = Строка.Номенклатура;
Конеццикла;

Док.Записать()
   Лефмихалыч
 
5 - 06.09.16 - 15:36
(0) этот код не может документ создавать, он может открывать форму существующего документа только
   alekowks
 
6 - 06.09.16 - 15:59
(4) делала вот так
Для каждого СТРТЧ из  Отбор Цикл
НовСТР =  Основание.ИнвентарьИХозяйственныеПринадлежности.Добавить();
НовСтр.Номенклатура =  СТРТЧ.Номенклатура;
НовСтр.Количество =  СТРТЧ.Количество; 
Основание.ИнвентарьИХозяйственныеПринадлежности.Загрузить(НовСтр, СТРТЧ );
КонецЦикла; 
так же пустой документ
возможно это из-за того, что потом идет Форма.Открыть?
(5) однако, тот код создавал документ новый..
   Ivan86
 
7 - 06.09.16 - 16:03
(6) Форма.Открыть - может быть пустой если вы некорректно передали ключ ссылку документа открытия формы.

Вы посмотрите документ который у вас создается - вне зависимости от форма.открыть - заполнен?
   alekowks
 
8 - 06.09.16 - 16:09
(7) спасибо)
документ заполнен. Действительно получалось, что я сделала много документов, которые видны только в журнале. Убрала форма.открыть)
еще раз спасибо)
   alekowks
 
9 - 06.09.16 - 16:13
возник вопрос как открывать тот документ что я создаю? открывать после заполнения.

например 
Если ЗначениеЗаполнено(МойДок, сртч) Тогда
МойДок.Открыть?
   Ivan86
 
10 - 06.09.16 - 16:19
(9) Если вы создаете документ, то ЗначениеЗаполнено(МойДок) всегда будет Истина.
я не в курсе как в УФ, в обычных было
Документ = Документы.МойДок.СоздатьДокумент();

Форма = Документ.ПолучитьФорму("Форма");

Форма.Открыть();
 
 Рекламное место пустует
   LordCMEPTb
 
11 - 06.09.16 - 16:30
Если нужно заполнение табличной части открытого документа, то тут имеет смысл пройтись по открытым окнам через "ПолучитьОкна()", найти среди них нужное окно, взять из него "Объект", и уже его заполнять.
   alekowks
 
12 - 06.09.16 - 16:45
(11) увы, но необходимо заполнить документ, а после заполнения открыть или заполнять при открытии
   LordCMEPTb
 
13 - 06.09.16 - 16:50
Поиск существующих решений не помог?
http://catalog.mista.ru/public/118784/
   Ivan86
 
14 - 06.09.16 - 16:54
(13) да она вроде бы его записывает. тут проще ситуация
   Ivan86
 
15 - 06.09.16 - 16:55
(13) (14) туплю там записанного тоже есть. недочитал
   alekowks
 
16 - 06.09.16 - 16:59
(13) спасибо. по похожему решению делала, но в итоге открывал просто пустую форму
   alekowks
 
17 - 06.09.16 - 17:16
(13) собственно открывает пустую форму.
работает только Док.Записать
   alekowks
 
18 - 06.09.16 - 17:22
всем огромное спасибо) разобралась где затупила...
   alekowks
 
19 - 07.09.16 - 12:37
Появился новый вопрос по этой теме.
Когда открывается форма документа, то часть реквизитов этой формы нельзя изменять.
ТолькоПросмотр = Ложь не могу никуда применить

как быть в этой ситуации?
   alekowks
 
20 - 07.09.16 - 12:47
(19) ой! не актуально))

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует