Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Интерактивные операции недоступны

Интерактивные операции недоступны
Я
   ZloyRafa
 
05.09.16 - 09:55
&НаСервере
Процедура получитьссылку()

Ссылка=Объект.Ссылка;
    Контрагент=Объект.Контрагент;
    ДокЗаявка = Документы.ЗаявкиНаТранспорт.НайтиПоРеквизиту("Основание",Ссылка);
    Если ДокЗаявка = Документы.ЗаявкиНаТранспорт.ПустаяСсылка() тогда
Сообщить("Заявка не созданна")
иначе

Ссылка=Объект.Ссылка;
    Контрагент=Объект.Контрагент;
    ДокЗаявка = Документы.ЗаявкиНаТранспорт.НайтиПоРеквизиту("Основание",Ссылка);
    
    
    ДокЗаявка.ПолучитьФорму("ФормаДокумента").Открыть();

КонецЕсли;
Конецпроцедуры

Данный код выполняется только в толстом клиенте, как опитимизировать под любой клиента?
 
 
   vicof
 
1 - 05.09.16 - 09:58
Разнести на клиент и сервер
   Остап Сулейманович
 
2 - 05.09.16 - 10:00
(0)
&НаСервере
Процедура получитьссылку()
    ...
    ДокЗаявка.ПолучитьФорму("ФормаДокумента").Открыть();
Конецпроцедуры

Открыть форму на сервере... Кому? Зачем?
Разделите код на две части. Собственно получение ссылки (на сервере) и открытие формы (на клиенте). И БуитВамМногаСчастия.
   ZloyRafa
 
3 - 05.09.16 - 10:07
&НаКлиенте
Процедура ЗаявкаНаДоставкуНажатие(Команда)
    получитьссылку();
ДокЗаявка.ПолучитьФорму("ФормаДокумента").Открыть();
КонецПроцедуры

&НаСервере
Процедура получитьссылку()

Ссылка=Объект.Ссылка;
    Контрагент=Объект.Контрагент;
    ДокЗаявка = Документы.ЗаявкиНаТранспорт.НайтиПоРеквизиту("Основание",Ссылка);
    Если ДокЗаявка = Документы.ЗаявкиНаТранспорт.ПустаяСсылка() тогда
Сообщить("Заявка не созданна")
иначе

Ссылка=Объект.Ссылка;
    Контрагент=Объект.Контрагент;
    ДокЗаявка = Документы.ЗаявкиНаТранспорт.НайтиПоРеквизиту("Основание",Ссылка);
    
    
    

КонецЕсли;
Конецпроцедуры
   ZloyRafa
 
4 - 05.09.16 - 10:08
Я наверное уже переусердствовал с изучением, голова не работает, но это явно не работает.
   Остап Сулейманович
 
5 - 05.09.16 - 10:29
(4) Таки да.
&НаКлиенте
Процедура ЗаявкаНаДоставкуНажатие(Команда)
    ДокЗаявка = получитьссылку();
    Если ЗначениеЗаполнено(ДокЗаявка) Тогда
        ...
    Иначе
        Сообщить("Заявка не созданна");
    КонецЕсли;
КонецПроцедуры

&НаСервере
Функция получитьссылку()
    Возврат Документы.ЗаявкиНаТранспорт.НайтиПоРеквизиту("Основание",Объект.Ссылка);
КонецФункции
   ZloyRafa
 
6 - 05.09.16 - 11:55
Спасибо Вам, Остап!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует