Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

переоценка товара принятого не на комиссию

переоценка товара принятого не на комиссию
Я
   glebkhil
 
03.09.16 - 23:43
Добрый вечер, интересует такой вопрос: Стоит последняя версия управлении торговым предприятием для Украины. В данной конфиграции делается документ переоценки товара принятого на комиссию только в случае если есть договор комиссии с поставщиком. Нужно убрать это ограничение и сделать что б можно было делать данный документ независимо от вида договора с поставщиком. Как это сделать? Можно создать аналогичный документ в конфигураторе, но что в нем следует изменить? может уже есть готовое решение?
 
 
   Горогуля
 
1 - 04.09.16 - 04:52
>товара принятого на комиссию только в случае если есть договор комиссии
внезапно!
>Нужно убрать это ограничение
технически это будет выглядеть как отсутствие проверки на договор у контрагента
>может уже есть готовое решение?
есть. понять, что комитенты - это тоже люди^W контрагенты и создать соответствующий договор
   mistеr
 
2 - 04.09.16 - 09:53
(0) А какой у вас договор?
   glebkhil
 
3 - 04.09.16 - 09:58
Схема учета в договоре идет "по первому событию".
   glebkhil
 
4 - 04.09.16 - 10:04
>технически это будет выглядеть как отсутствие проверки на договор у контрагента
Ну вот это бы и подходило.
С данным поставщиком мы часть товара берем на реализацию, а часть на отсрочку. Все приходовалось по одному договору, сейчас сильно стал колебаться курс в Украине, вот и встряли с этим договором. У меня в базе есть интересное самописное решение прайс листа (можно точно проставлять цены на любую позицию, документы переоценки создаются автоматом). Как с этим разберусь то могу поделиться ком нужно
   Александр_Тверь
 
5 - 04.09.16 - 10:52
Интересно, когда 1С запретят на Украине? Не порядок же...
   glebkhil
 
6 - 04.09.16 - 11:08
>Интересно, когда 1С запретят на Украине? Не порядок же...
А по существу что то сказать?
   Александр_Тверь
 
7 - 04.09.16 - 11:16
(6) Так вам уже все по существу сказали, еще в первом посте.
Знаете, можете сами - приступайте к реализации. Не можете сами? Позовите специалиста.

Чего еще вы ожидаете?
   glebkhil
 
8 - 04.09.16 - 11:41
>Так вам уже все по существу сказали, еще в первом посте.
Знаете, можете сами - приступайте к реализации. Не можете сами? Позовите специалиста.

Чего еще вы ожидаете?

Я ожидал помощи о том как реализовать это. У меня есть наброски кода, может кто его изменит от оригинала? Для бухгалтерии важно что б это была сторонняя разработка. Спасибо.
   Злопчинский
 
9 - 04.09.16 - 12:01
Возможно , чего-то не понял
Но у автора в голове шлак
Товар пр пятый на комиссию может быть переоценке только потому что это забаланс и переоценка изменит лишь величину вашей матответсвенности в случае порчи утери товара
Остальные товары находящиеся в вашей собственности - независимо от того как вы их получили от поставщика по предомлате или на отсрочке - они все находятся в вашей собственности и стоят на вашем балансе. Себестоимость данного товара не может быть изменена по прихоти бухгалтера или учредителя или самого главного шефа. Такова экономика и учёт
   Злопчинский
 
10 - 04.09.16 - 12:04
Переоценить можно лишь прайсовые цены то есть мечту о продаже товаров по такой прайсовой цене
Такой Прайс не имеет никакого отношения ни к бухучету ни к отношению с поставщиками
Совершенно аналогично про розничные цены
 
 Рекламное место пустует
   Злопчинский
 
11 - 04.09.16 - 12:06
(8) свои наброски кода принеси в бухию а бухия платит пусть любому франчу просто так
Те будут довольны
   glebkhil
 
12 - 04.09.16 - 12:07
>Возможно , чего-то не понял 
Но у автора в голове шлак 
Товар пр пятый на комиссию может быть переоценке только потому что это забаланс и переоценка изменит лишь величину вашей матответсвенности в случае порчи утери товара
Остальные товары находящиеся в вашей собственности - независимо от того как вы их получили от поставщика по предомлате или на отсрочке - они все находятся в вашей собственности и стоят на вашем балансе. Себестоимость данного товара не может быть изменена по прихоти бухгалтера или учредителя или самого главного шефа. Такова экономика и учёт

Все верно Вы указали, но договора комиссии нет с поставщиком, есть обычный договора с прописаными условиями проплат за товар. За товар платится на условиях реализации. Вот бухгалтерия и ищет решение с переоценкой товара. Им просто нужно что б документ "переоценка товара принятого на комиссию" мог переоценять любой товар, не только тот который пришел по договору комиссии.
   mistеr
 
13 - 04.09.16 - 12:08
(9) Возможно, они хотят переоценивать задолженность, выраженную в у.е. Я поэтому и спросил про договор, но ТС не колется.
   mistеr
 
14 - 04.09.16 - 12:11
(12) Значит договор купли-продажи? Взаиморасчеты в чем прописаны?
   Злопчинский
 
15 - 04.09.16 - 12:11
Ещё раз для тупых
Товар находящийся в вашей собственности не переоцегивается
Купили когда доллар был дорогой и теперь попа -акова экономика сами лохи
   glebkhil
 
16 - 04.09.16 - 12:19
>Возможно, они хотят переоценивать задолженность, выраженную в у.е. Я поэтому и спросил про договор, но ТС не колется.
Вы же знаете как в Украине оно работает, Товар взяли в у.е. для бухгалтерии предоставляются документы в гривне, вот и у бухов встал вопрос переоценки товара не на договоре комиссии. Просто в данном документе необходимо снять проверку наличия договора комиссии.
   Джинн
 
17 - 04.09.16 - 12:29
(0) ТМЦ не переоцениваются. Они учитываются по цене приобретения. Исключения - розница (при учете в розничных ценах) и комиссия (которая по жизни в розничных ценах). Все остальной ересь и блуд.
   Джинн
 
18 - 04.09.16 - 12:31
(16) Да НА Украине это не соответствует нормам бухучета. Верните товар поставщику и приобретите но новой цене.
   Злопчинский
 
19 - 04.09.16 - 12:34
(16) у вас там на/в - вообще не осталось вменяемых? ;-)
смотри:
товар купленный у поставщика при договоре обговоренном в валюте - вы поставщику ВСЕГДА будете должны 100 долларов, если купили у него товар за сто долларов. НЕЗАВИСИМО ОТ ТОГО, каков сейчас курс долаара. поэтому если вы купили товар на 100 долларов когда доллар был по 50 рублей, а теперь когда доллар по 500 рублей - то да, вы будете должны заплатить поставщику не 5000 рублей, а 50 000 рублей. Потому что лохи. И никак эти 50 000 долга перед поставщиком не уменьшить. этот долг в 100 долларов, выраженный в рублях - в рублях будет колебаться вместе с куросм доллара. разница рублевая будет гулять между долгом поставщику и вашими внереализационными доходами и расходами.
   Злопчинский
 
20 - 04.09.16 - 12:37
себестоимость же товара - она зафиксировалась в рублевом выражении в момент принятия товара на баланс (5000 рублей) и больше не изменится.
   Злопчинский
 
21 - 04.09.16 - 12:40
себестоимость товара вы никак не может поменять.
свой долг перед поставщиком еще скорректировать можно - но это нифига не переоценка. например поставщик может вам по обоюдосторонней договоренности простить часть долга (но с прощенной части вы все равно заплатите налог на прибыль - государство подарков не понимает), а поставщик - не возьмет прощенную часть в расходы (то есть ухудшит свое фин состояние)
   glebkhil
 
22 - 04.09.16 - 12:40
как тут поставить хайд? я выложу код рабочего нового документа и выделю что менялось в нем, помогите его переделать от оригинала (что имеется у меня), такое условие мне поставила бухгалтерия, так же под этот документ создан новый регистр накопления.
   Злопчинский
 
23 - 04.09.16 - 12:43
(22) автор - тут люди вежливые, кроме меня.
еще раз: если товар находится в вашей собственности - его переоценка - то есть снижение или увеличение его себсетоимости и/или долна перед поставщиком В НИКУДА - невозможна.

что в этой фразе непонятного?
   Злопчинский
 
24 - 04.09.16 - 12:46
автор, ты так и не сказал, что ты понимаешь под "переоценкой"?
- изменение прайсовых цен (предлагаемых покупателям)?
- изменение розничной цены (печатаемой на ценниках)?
- что-то иное? (что именно?)

без внятного изложения никто твой бред и бред твоего буха не будет смотреть даже
   glebkhil
 
25 - 04.09.16 - 12:48
>автор, ты так и не сказал, что ты понимаешь под "переоценкой"?
- изменение прайсовых цен (предлагаемых покупателям)?
- изменение розничной цены (печатаемой на ценниках)?
- что-то иное? (что именно?) 

без внятного изложения никто твой бред и бред твоего буха не будет смотреть даже
переоценка закупочной цены
   Злопчинский
 
26 - 04.09.16 - 12:49
(25) "Переоценка закупочной цены"
- проиллюстрируй на примере с цифрами, если уж тебе непонятно написанное выше.. будем разбираться
   Джинн
 
27 - 04.09.16 - 12:50
(25) Невозможна по правилам бухучета. Да и здравого смысла.
   Злопчинский
 
28 - 04.09.16 - 12:51
единственный внятный вариант переоценки закупочной цены - это товар, находящийся в вашей собственнотси - вернуть поставщику (если он пойдет вам навстречу и захочет его принять) и купить этот товар у поставщика на новых условиях (невыгодных для поставщика - оно ему надо?)
   Злопчинский
 
29 - 04.09.16 - 12:53
(25) я удачно впарил тебе товар, ты мне должен (если пересчитатьь на доллары) - 100 долларов. Теперь ты говоришь - а давай я буду тебе должен не 100 долларов, а 70! я тебе отвечаю - с какого хрена? в договоре записано что оценка долна - в долларах. значит в долларах. как был должен мне 100 долларов, так и будешь должен. а где ты возбмешь рубли/гривны эквивалентыне ста долларам на момент когда подойдет время рассчитываться - это твои личные проблемы
   Злопчинский
 
30 - 04.09.16 - 12:54
единственный вменяемый вариант - выйти на майдан, скинуть правительство, выполнить действия которые приведут к обесцениванию доллара и в этот момент когда подошло время расплаты - расплатиться с поставщиком за жквивалент 100 долларов по копеечной рублевой/гривновой сумме...
   glebkhil
 
31 - 04.09.16 - 12:55
просто у нас в стране договор консигнации редко используется, используется обычный договор поставки товара с оплатой только за товар, который реализовали и тот товар что остался за мной необходимо переоценить. Поставщик сам переоценивает нам товар и необходимо ввести корректировки в базе документом переоценки. Но документ который существует в базе может переоценивать товар принятый на консигнацию. К примеру мне поставщик отгрузил на 1000 рублей, на 500 мы продали остальной остался у нас. 500 заплатили поставщику, поднялся курс и остаток товара нам поставщик поднимает на 5 процентов, соответственно остаток товара нам нужно переоценить на 5 процентов. К тому же изначально в базе товар от этого поставщика приходовался по одному договору, но партии товаров были с разными услоявими оплаты (отсрочка и реализация) и встал вопрос переоценки некоторых партий на реализации
   Злопчинский
 
32 - 04.09.16 - 12:58
(31) "просто у нас в стране договор консигнации редко используется, используется обычный договор поставки товара с оплатой только за товар, который реализовали и тот товар что остался за мной необходимо переоценить. "
- реализовали вы товар или нет - это ваше личное дело. когда придет время оплаты - в ыдолжны заплатить. такие условия как ты прописал это завуалированная схема комиссии. но если она НЕ ОФОРМЛЕНА как комиссия - то это договор купли-продажи со всеми вытекающими отсюда последствиями.
   Злопчинский
 
33 - 04.09.16 - 13:00
(31) "Поставщик сам переоценивает нам товар и необходимо ввести корректировки в базе документом переоценки."

нагло врешь. если это не договор комиссии, и "поставщик сам переоценил вам товар" - он должен вам дать бухгалтерский/налоговый документ, на основании которого вы провизведете КОРРЕКТИРОВКУ стоимости товаров и долга поставщика. НО ЭТО НЕ ПЕРЕОЦЕНКА. такая корректировка влечет за собой определнные бухгалтерские/налоговые последствия как на стороне поставщика так и на ваше йстороне.
 
 
   glebkhil
 
34 - 04.09.16 - 13:00
>- реализовали вы товар или нет - это ваше личное дело. когда придет время оплаты - в ыдолжны заплатить. такие условия как ты прописал это завуалированная схема комиссии. но если она НЕ ОФОРМЛЕНА как комиссия - то это договор купли-продажи со всеми вытекающими отсюда последствиями.

Вот и нужно что б можно было переоценить партию товара по договору купли-продажи. Стандартный документ переоценки не дает этой возможности
   Джинн
 
35 - 04.09.16 - 13:00
(31) В пятый раз - невозможно по правилам бухучета. Даже украинского.
   Злопчинский
 
36 - 04.09.16 - 13:01
если такого документа от поставщика нет - идите нафиг с ос совей "переоценкой" - оснований для нее - НЕТ.
   glebkhil
 
37 - 04.09.16 - 13:02
>нагло врешь. если это не договор комиссии, и "поставщик сам переоценил вам товар" - он должен вам дать бухгалтерский/налоговый документ, на основании которого вы провизведете КОРРЕКТИРОВКУ стоимости товаров и долга поставщика. НО ЭТО НЕ ПЕРЕОЦЕНКА. такая корректировка влечет за собой определнные бухгалтерские/налоговые последствия как на стороне поставщика так и на ваше йстороне.

Документ предоставляется, но в базе изначально велся этот поставщик по договору купли-продажи, и данные партии нужно переоценить.
   Злопчинский
 
38 - 04.09.16 - 13:03
(34) еще раз - тупой? читать не умеешь?
товар находящийся В ВАШЕЙ СОБСТВЕННОСТИ - поменять его себестоимость и свой долг перед поставщиком в ОДНОСТОРОННЕМ порядке - невозможно. Только по договоренности с поставщиком - по соответсвующим бух/нал документам. Нет таких документов - вы в пролете.
   Злопчинский
 
39 - 04.09.16 - 13:04
(37) кщк раз для тупых.
у вас с поставщиком товар получен по договору комиссии или купли продажи? КАК ПРОВЕДЕН В БУХУЧЕТЕ? если проведен как договор купли-продажи - сосите хрен. Переводите его на договор комиссии с исправлением всего и вся по этому договору задним числом с предоставлением уточняющих налоговых деклараций по прибыли и по НДС и еще куча всего
   Джинн
 
40 - 04.09.16 - 13:04
(37) Господи, да снимите кастрюлю с головы наконец!

Читайте П(С)БУ 9, п.9
   glebkhil
 
41 - 04.09.16 - 13:05
>еще раз - тупой? читать не умеешь?
товар находящийся В ВАШЕЙ СОБСТВЕННОСТИ - поменять его себестоимость и свой долг перед поставщиком в ОДНОСТОРОННЕМ порядке - невозможно. Только по договоренности с поставщиком - по соответсвующим бух/нал документам. Нет таких документов - вы в пролете.

Да при чем тут бух учет, просто нужно снять ограничение в документе переоценки, что б можно было переоценить товар с любым договором
   Злопчинский
 
42 - 04.09.16 - 13:08
(41) ты в принципе не понимаешь сущности не то что выполянемых операций. а даже сущности учета и к чему это приведет.

единственный нормальный вариант - спиши весь товар который у тебя на остатках по этому договору купли-продажи документом списания, документом корректировки занули долги по этому товару перед поставщиком. оформи текущей датой приход этого товара по договору комиссии на нужную сумму/цену. далее работа йпо договору комиссии.
   Джинн
 
43 - 04.09.16 - 13:08
(41) Да при том, что это не только норма бухучета. Такой же принцип что на Украине, что в России, что в МСФО, что в здравом смысле. И архитектура конфигураций построена именно на нем.
   Злопчинский
 
44 - 04.09.16 - 13:09
если это договор комиссии - то он и должен отражаться как договор комиссии, а не договор купли-продажи.
   Злопчинский
 
45 - 04.09.16 - 13:14
Договор комиссии - товар находится в собственности комитента. цена по которой вы его у себя держите - это оговоренная договором комиссии оценка материальной ответственности . как вариант это может быть оговоренная договором цена продажи товара конечному потребителю или другим оптовикам. но это ВОЛЕИЗЪЯВЛЕНИЕ комитента (от вас тут ничего не зависит и никак на ваше финансовое состояние не влияет). это его товар, комитентовский. именно поэтому вы можете делать переоценку - просто исполняя ПРИКАЗ КОМИТЕНТА по управлению товаром комитента (ибо так записано в договоре комиссии - что вы всего лишь исполняете приказы комитента - продать товар по такой-то цене).
   glebkhil
 
46 - 04.09.16 - 13:17
>если это договор комиссии - то он и должен отражаться как договор комиссии, а не договор купли-продажи.

данный договор не приходует на 28 счет а приходует на 0,  бухам важно что б приходовалось на 28, вот и использовали договор купли-продажи. И вот встала заморочка с переоценкой
   Джинн
 
47 - 04.09.16 - 13:19
(46) Подарите бухам П(С)БУ 9
   glebkhil
 
48 - 04.09.16 - 13:22
>Подарите бухам П(С)БУ 9

Ну так они вели учет товара с поставщиком, по такой схеме. Так возможно снять ограничение в документе переоценки?
   glebkhil
 
49 - 04.09.16 - 13:24
есть у бухгалтера готовый документ, который можно внедрить, он работает. Но бухгалтер использует чью то стороннюю разработку и хочет и зменить код до неузнаваймости, возможно его изменить, если я скину код?
 
 Рекламное место пустует
   hhhh
 
50 - 04.09.16 - 13:38
(49) здесь вообще-то чтут уголовный кодекс
   glebkhil
 
51 - 04.09.16 - 13:40
>здесь вообще-то чтут уголовный кодекс

Я территориально в Одессе нахожусь, до России это далеко
   hhhh
 
52 - 04.09.16 - 13:44
(51) надо сделать тогда код точь в точь как в типовой.
   glebkhil
 
53 - 04.09.16 - 13:46
>надо сделать тогда код точь в точь как в типовой.

он как в типовой, просто некоторые моменты изменены, вот бухгалтера интересует изменить этот код еще, что б не был похож на вариант, который попал к нему
   Горогуля
 
54 - 04.09.16 - 13:49
о, заовнокодить типовой код до неузнаваемости? это можно
   glebkhil
 
55 - 04.09.16 - 14:01
>о, заовнокодить типовой код до неузнаваемости? это можно
так это копия типового, документ будет создаваться новый в конфигураторе
   Злопчинский
 
56 - 04.09.16 - 14:07
(51)  мы в курсе что одесса это отдельное государство и там кладут с прибором на уголовный кодекс, даже на свой собственный ;-)
   glebkhil
 
57 - 04.09.16 - 14:09
>мы в курсе что одесса это отдельное государство и там кладут с прибором на уголовный кодекс, даже на свой собственный ;-)

в этом вся Одесса))) тут любят обмануть государство и придумать схему свою))
   Александр_Тверь
 
58 - 04.09.16 - 14:12
Прямо заинтриговали, что из этого выйдет :)
Надо - значит надо, коли готовы делать (или платить тому, кто будет делать) то проблем нет.

Хоть код какой-нибудь для затравки выложите.
   Злопчинский
 
59 - 04.09.16 - 14:12
(46)  автор упорно маскируется
Таки непонятно
- если со слов автора договор комиссии то почему бухам важно чтобы это падало на баланс (28 счет?) а не на забаланс
- если это всетаки договор куплипродажи то что за бред про переоценку

Такое впечатление что там толпа цыган - и в торговле и в бухгалтерии - главное заболтать

Предлагаю модераторам утопить ветку ввиду полной невиеняемости темы или пусть автор сведет задачу к сугубо технической без упоминания типовой конфиги и хотелок искурочить здравый смысл
   Злопчинский
 
60 - 04.09.16 - 14:13
(57)  лучше остапа бендера почитайте - он не зря чтил уголовный кодекс
   Злопчинский
 
61 - 04.09.16 - 14:13
уогда встанет вопрос что тут за мутные схемы - все сразу скажут мы не мы, это программист и программа
   glebkhil
 
62 - 04.09.16 - 14:14
>Прямо заинтриговали, что из этого выйдет :) 
Надо - значит надо, коли готовы делать (или платить тому, кто будет делать) то проблем нет.

Хоть код какой-нибудь для затравки выложите.


как под хайд кинуть? я полностью код документа кину
   Горогуля
 
63 - 04.09.16 - 14:15
(62) СТОЙ!!
   Горогуля
 
64 - 04.09.16 - 14:16
ты сейчас не видел тэг для кода [ 1 c ], а догадался выложить *.txt на помойку
   Горогуля
 
65 - 04.09.16 - 14:16
+(64) но лично я за ним не пойду
   glebkhil
 
66 - 04.09.16 - 14:16
>ты сейчас не видел тэг для кода [ 1 c ], а догадался выложить *.txt на помойку

я еще ничего не выкладывал
   Александр_Тверь
 
67 - 04.09.16 - 14:17
(62) а зачем весь? Выкладывай где, по твоему мнению, нужно что-то изменить. А мы тебе будем рассказывать стоит это делать или нет.
   glebkhil
 
68 - 04.09.16 - 14:17
>но лично я за ним не пойду

спрашиваю про зайд, что б код можно было раскрыть тут, а не что б он занял всю страницу
   Злопчинский
 
69 - 04.09.16 - 14:19
(68)  ты код вставь он сам схлопнется
   Горогуля
 
70 - 04.09.16 - 14:20
(68) не, я уже на сегодня отработал. если там чуть сложнее чем "Если Договор.ВидДоговора=СПоставщиком", то мне лениво
   Горогуля
 
71 - 04.09.16 - 14:20
(69) если миста не сглючит
   glebkhil
 
72 - 04.09.16 - 14:28
Выкладываю. В движения добавлен регистр накопления hi_ТоварыПолученые

Где изменялся типовой код указано комментариями "+ начинаем" и "- заканчиваем", то есть между этими комментариями делались правки


1. Процедура выполняет заполнение табличной части принятыми на реализацию

Процедура ЗаполнитьТоварыУпр(ДокументОснование = Неопределено) Экспорт

    Запрос = Новый Запрос;

    Если РегистрыСведений.УчетнаяПолитика.ПолучитьПоследнее(Дата).ВестиПартионныйУчетПоСкладам Тогда
        ВремСклад = Склад;
    Иначе
        ВремСклад = Справочники.Склады.ПустаяСсылка();
    КонецЕсли;

    Если ТипЗнч(ДокументОснование) = Тип("ДокументСсылка.ПоступлениеТоваровУслуг") Тогда
        ИмяДокумента = "ПоступлениеТоваровУслуг";
    ИначеЕсли ТипЗнч(ДокументОснование) = Тип("ДокументСсылка.ПоступлениеТоваровУслугВНТТ") Тогда
        ИмяДокумента = "ПоступлениеТоваровУслугВНТТ";
    КонецЕсли;

    // Установим параметры запроса

    Запрос.УстановитьПараметр("Склад", ВремСклад);
    Запрос.УстановитьПараметр("ДоговорКонтрагента",  ДоговорКонтрагента);
    Запрос.УстановитьПараметр("СтатусПартии",       Перечисления.СтатусыПартийТоваров.Купленный);
    Запрос.УстановитьПараметр("ДокументОснование",  ДокументОснование);
    
    Если НЕ ЗначениеЗаполнено(Сделка) Тогда
        Запрос.УстановитьПараметр("Сделка",             Неопределено);
    Иначе
        Запрос.УстановитьПараметр("Сделка",             Сделка);
    КонецЕсли;

    Запрос.Текст =
    "ВЫБРАТЬ
    |    Остатки.Номенклатура,
    |    Остатки.ХарактеристикаНоменклатуры,
    |    Остатки.СерияНоменклатуры,
    |    Остатки.ДокументОприходования,
    |    МАКСИМУМ(ВЫБОР КОГДА Остатки.СтоимостьОстаток ЕСТЬ NULL ТОГДА
    |        0
    |    ИНАЧЕ
    |        Остатки.СтоимостьОстаток
    |    КОНЕЦ)                                       КАК СтоимостьОстаток,
    |    МАКСИМУМ(ВЫБОР КОГДА Остатки.КоличествоОстаток ЕСТЬ NULL ТОГДА
    |        0
    |    ИНАЧЕ
    |        Остатки.КоличествоОстаток
    |    КОНЕЦ)                                       КАК КоличествоОстаток,
    |    МАКСИМУМ(ВЫБОР КОГДА Полученные.СуммаВзаиморасчетовОстаток ЕСТЬ NULL ТОГДА
    |        0
    |    ИНАЧЕ
    |        Полученные.СуммаВзаиморасчетовОстаток
    |    КОНЕЦ)                                       КАК СуммаВзаиморасчетовОстаток,
    |    МАКСИМУМ(ВЫБОР КОГДА Полученные.КоличествоОстаток ЕСТЬ NULL ТОГДА
    |        0
    |    ИНАЧЕ
    |        Полученные.КоличествоОстаток
    |    КОНЕЦ)                                       КАК КоличествоПолученных,
    |    Остатки.Номенклатура.ЕдиницаХраненияОстатков КАК ЕдиницаХраненияОстатков
    |ИЗ
    |    РегистрНакопления.ПартииТоваровНаСкладах.Остатки(, 
    |            Склад          = &Склад 
    |            И СтатусПартии = &СтатусПартии
    |" + ?(ЗначениеЗаполнено(ДокументОснование), "
    |            И Номенклатура В (ВЫБРАТЬ РАЗЛИЧНЫЕ Документ." + ИмяДокумента + ".Товары.Номенклатура
    |                            ИЗ Документ." + ИмяДокумента + ".Товары 
    |                            ГДЕ Документ." + ИмяДокумента + ".Товары.Ссылка = &ДокументОснование)
    |            И ДокументОприходования = &ДокументОснование
    |", "       И ДокументОприходования.ДоговорКонтрагента = &ДоговорКонтрагента") + "
    |                                                    ) КАК Остатки
    | "+ ?(НЕ ЗначениеЗаполнено(ДокументОснование), "" ,"    ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ." + ИмяДокумента + ".Товары КАК ПоступлениеТоваровУслугТовары
    |    ПО Остатки.Номенклатура = ПоступлениеТоваровУслугТовары.Номенклатура И ПоступлениеТоваровУслугТовары.Ссылка = Остатки.ДокументОприходования" ) + "
    |ЛЕВОЕ СОЕДИНЕНИЕ 
    |   (ВЫБРАТЬ
    |        Полученные.Номенклатура КАК Номенклатура,
    |        Полученные.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,
    |        ВЫБОР КОГДА Полученные.Номенклатура.ВестиПартионныйУчетПоСериям = Истина ТОГДА Полученные.СерияНоменклатуры ИНАЧЕ ЗНАЧЕНИЕ(Справочник.СерииНоменклатуры.ПустаяСсылка) КОНЕЦ КАК СерияНоменклатуры,
    |         Сумма(Полученные.СуммаВзаиморасчетовОстаток) КАК СуммаВзаиморасчетовОстаток,
    |         Сумма(Полученные.КоличествоОстаток) КАК КоличествоОстаток
    |    ИЗ
    |        РегистрНакопления.hi_ТоварыПолученные.Остатки(, 
    |            ДоговорКонтрагента = &ДоговорКонтрагента 
    |            И Сделка           = &Сделка
    |" + ?(ЗначениеЗаполнено(ДокументОснование), "
    |            И Номенклатура В (ВЫБРАТЬ РАЗЛИЧНЫЕ Документ." + ИмяДокумента + ".Товары.Номенклатура
    |                            ИЗ Документ." + ИмяДокумента + ".Товары 
    |                            ГДЕ Документ." + ИмяДокумента + ".Товары.Ссылка = &ДокументОснование)", "") + ") КАК Полученные
    |     СГРУППИРОВАТЬ ПО
    |        Полученные.Номенклатура,
    |        Полученные.ХарактеристикаНоменклатуры,
    |        ВЫБОР КОГДА Полученные.Номенклатура.ВестиПартионныйУчетПоСериям = Истина ТОГДА Полученные.СерияНоменклатуры ИНАЧЕ ЗНАЧЕНИЕ(Справочник.СерииНоменклатуры.ПустаяСсылка) КОНЕЦ
    | ) КАК Полученные
    |    ПО Остатки.Номенклатура = Полученные.Номенклатура
    |       И Остатки.ХарактеристикаНоменклатуры = Полученные.ХарактеристикаНоменклатуры
    |       И Остатки.СерияНоменклатуры = Полученные.СерияНоменклатуры
    |ГДЕ
    |    Остатки.КоличествоОстаток > 0
    |    //И Полученные.КоличествоОстаток > 0

    |
    |СГРУППИРОВАТЬ ПО
    |    Остатки.Номенклатура,
    |    Остатки.ХарактеристикаНоменклатуры,
    |    Остатки.СерияНоменклатуры,
    |    Остатки.ДокументОприходования
    |";

    РезультатЗапроса = Запрос.Выполнить();

    ВалютаУправленческогоУчета          = глЗначениеПеременной("ВалютаУправленческогоУчета");
    СтруктураКурсаУправленческогоУчета  = МодульВалютногоУчета.ПолучитьКурсВалюты(ВалютаУправленческогоУчета, Дата);
    КурсВалютаУправленческогоУчета      = СтруктураКурсаУправленческогоУчета.Курс;
    КратностьВалютаУправленческогоУчета = СтруктураКурсаУправленческогоУчета.Кратность;
    
    Выборка = РезультатЗапроса.Выбрать();
    Пока Выборка.Следующий() Цикл

        СтрокаТабличнойЧасти = Товары.Добавить();

        СтрокаТабличнойЧасти.Номенклатура               = Выборка.Номенклатура;
        СтрокаТабличнойЧасти.ХарактеристикаНоменклатуры = Выборка.ХарактеристикаНоменклатуры;
        СтрокаТабличнойЧасти.СерияНоменклатуры          = Выборка.СерияНоменклатуры;
        СтрокаТабличнойЧасти.ЕдиницаИзмерения           = Выборка.ЕдиницаХраненияОстатков;
        СтрокаТабличнойЧасти.Коэффициент                = Выборка.ЕдиницаХраненияОстатков.Коэффициент;
        СтрокаТабличнойЧасти.Количество                 = Выборка.КоличествоОстаток;

        Если Выборка.КоличествоПолученных = 0 Тогда
            СтрокаТабличнойЧасти.СуммаСтарая = 0;
        Иначе
            СтрокаТабличнойЧасти.СуммаСтарая = МодульВалютногоУчета.ПересчитатьИзВалютыВВалюту(
                                               Выборка.СуммаВзаиморасчетовОстаток * Выборка.КоличествоОстаток / Выборка.КоличествоПолученных,
                                               ДоговорКонтрагента.ВалютаВзаиморасчетов,
                                               ВалютаДокумента,
                                               КурсВзаиморасчетов,
                                               ЗаполнениеДокументов.КурсДокумента(ЭтотОбъект, мВалютаРегламентированногоУчета),
                                               КратностьВзаиморасчетов,
                                               ЗаполнениеДокументов.КратностьДокумента(ЭтотОбъект, мВалютаРегламентированногоУчета));
        КонецЕсли;

        СтрокаТабличнойЧасти.ЦенаСтарая = СтрокаТабличнойЧасти.СуммаСтарая / СтрокаТабличнойЧасти.Количество;
        СтрокаТабличнойЧасти.Сумма      = СтрокаТабличнойЧасти.СуммаСтарая;
        СтрокаТабличнойЧасти.Цена       = СтрокаТабличнойЧасти.ЦенаСтарая;
        
        СтрокаТабличнойЧасти.СтавкаНДС = СтрокаТабличнойЧасти.Номенклатура.СтавкаНДС;
        // + начинаем

        СтрокаТабличнойЧасти.НалоговоеНазначение = Справочники.НалоговыеНазначенияАктивовИЗатрат.НДС_Облагаемая
        // - заканчиваем

    КонецЦикла;

КонецПроцедуры// ЗаполнитьТоварыУпр()


2. Проверяет правильность заполнения шапки документа.

Процедура ПроверитьЗаполнениеШапки( СтруктураШапкиДокумента, Отказ, Заголовок)

    // Укажем, что надо проверить:

    СтруктураОбязательныхПолей = 
        Новый Структура("Организация, ВалютаДокумента, Контрагент, ДоговорКонтрагента, КурсВзаиморасчетов, КратностьВзаиморасчетов");

    Если ОтражатьВБухгалтерскомУчете Тогда
       Если СтруктураШапкиДокумента.ЕстьНДС Тогда
            СтруктураОбязательныхПолей.Вставить("СчетУчетаНДС");
            СтруктураОбязательныхПолей.Вставить("СчетУчетаНДСПодтвержденный");
        КонецЕсли;
    КонецЕсли;
        
    // Сделка должна быть заполнена, если учет взаиморасчетов ведется по заказам.

    Если ЗначениеЗаполнено(ДоговорКонтрагента) Тогда

        Если ДоговорКонтрагента.ВедениеВзаиморасчетов = Перечисления.ВедениеВзаиморасчетовПоДоговорам.ПоЗаказам Тогда
            СтруктураОбязательныхПолей.Вставить("Сделка", 
                "По выбранному договору установлен способ ведения взаиморасчетов ""по заказам (счетам)""! 
                |Заполните поле ""Заказ поставщику:""!");
        ИначеЕсли ДоговорКонтрагента.ВедениеВзаиморасчетов = Перечисления.ВедениеВзаиморасчетовПоДоговорам.ПоСчетам тогда
            СтруктураОбязательныхПолей.Вставить("Сделка", 
                "По выбранному договору установлен способ ведения взаиморасчетов ""по заказам (счетам)""! 
                |Заполните поле ""Счет поставщика:""!");
        КонецЕсли;

    КонецЕсли;

    // Теперь позовем общую процедуру проверки.

    ЗаполнениеДокументов.ПроверитьЗаполнениеШапкиДокумента(ЭтотОбъект, СтруктураОбязательныхПолей, Отказ, Заголовок);

    Если  СтруктураШапкиДокумента.ОтражатьВБухгалтерскомУчете
        И СтруктураШапкиДокумента.ЕстьНДС Тогда
        // начали + 

        //Если НЕ СтруктураШапкиДокумента.СхемаНалоговогоУчета = Справочники.СхемыНалоговогоУчетаПоДоговорамКонтрагентов.СКомитентом_НК Тогда

        //     

        //     ОбщегоНазначения.СообщитьОбОшибке("В договоре комиссии указана неправильная схема налогового учета! Используйте схему для периода с 2011 года!",Отказ,Заголовок);

        //     

        //ИначеЕсли НЕ СтруктураШапкиДокумента.СложныйНалоговыйУчет Тогда

        //          

        //     ОбщегоНазначения.СообщитьОбОшибке("По договорам комиссии с 2011 года в конфигурации реализован только ""сложный налоговый учет"". Установите соответствующий флаг в договоре с контрагентом!",Отказ,Заголовок);

        //     

        // КонецЕсли;

        // закончили - 

    КонецЕсли;

    //Организация в документе должна совпадать с организацией, указанной в договоре взаиморасчетов.

    УправлениеВзаиморасчетами.ПроверитьСоответствиеОрганизацииДоговоруВзаиморасчетов(Организация, ДоговорКонтрагента, СтруктураШапкиДокумента.ДоговорОрганизация, Отказ, Заголовок);

КонецПроцедуры// ПроверитьЗаполнениеШапки()


3. По результату запроса по шапке документа формируем движения по регистрам

Процедура ДвиженияПоРегистрам(РежимПроведения, СтруктураШапкиДокумента, ТаблицаПоТоварам, Отказ, Заголовок)

    ДвиженияПоРегистрамУпр(РежимПроведения, СтруктураШапкиДокумента, ТаблицаПоТоварам, Отказ, Заголовок);
    ДвиженияПоРегиструСписанныеТовары(РежимПроведения, СтруктураШапкиДокумента, ТаблицаПоТоварам, Отказ, Заголовок);

    ТаблицаПоВторомуСобытиюНал = ДвиженияПоРегистрамНалоговогоУчета(СтруктураШапкиДокумента, ТаблицаПоТоварам,Отказ);
    
    ДвиженияПоРегистрамРегл(РежимПроведения, СтруктураШапкиДокумента, ТаблицаПоВторомуСобытиюНал, ТаблицаПоТоварам, Отказ, Заголовок);
    
    УчетнаяПолитика = РегистрыСведений.УчетнаяПолитика.ПолучитьПоследнее(Дата);
    
    // + начали

    //Если ОтражатьВУправленческомУчете Тогда

    //        ЗаписьРегистрации = ПринадлежностьПоследовательностям.ПартионныйУчет.Добавить();

    //        ЗаписьРегистрации.Период = Дата;

    //        ЗаписьРегистрации.Регистратор = Ссылка;

    //КонецЕсли;

    // - закончили 


    Если УчетнаяПолитика.СписыватьПартииПриПроведенииДокументов Тогда
        
        УправлениеЗапасамиПартионныйУчет.ДвижениеПартийТоваров(Ссылка, Движения.СписанныеТовары.Выгрузить());
        
    Иначе
        
        // В неоперативном режиме границы последовательностей сдвигаются назад, если они позже документа.

        Если РежимПроведения = РежимПроведенияДокумента.Неоперативный Тогда
            УправлениеЗапасамиПартионныйУчет.СдвигГраницыПоследовательностиПартионногоУчетаНазад(Дата, Ссылка, Организация);
        КонецЕсли;
        
    КонецЕсли;

КонецПроцедуры// ДвиженияПоРегистрам()


4.Процедура ДвиженияПоРегистрамРегл(РежимПроведения, СтруктураШапкиДокумента, ТаблицаПоВторомуСобытиюНал, ТаблицаПоТоварам, Отказ, Заголовок)
    
    Если Не СтруктураШапкиДокумента.ОтражатьВБухгалтерскомУчете Тогда
        Возврат;    
    КонецЕсли;     
    
    Если СтруктураШапкиДокумента.Внешнеэкономический Тогда
        Возврат;    
    КонецЕсли;     
    
    // Проводки по товарам

    Для каждого СтрокаТаблицы Из ТаблицаПоТоварам Цикл
        // + начали

        Проводка = Движения.Хозрасчетный.Добавить();
        
        Проводка.Период       = СтруктураШапкиДокумента.Дата;
        Проводка.Организация  = СтруктураШапкиДокумента.Организация;
        Проводка.Содержание   = "Переоценка ТМЦ";
        
        Проводка.НалоговоеНазначениеДт = СтрокаТаблицы.НалоговоеНазначение;
        
        Проводка.СчетДт       = СчетДт;
        ОбщегоНазначения.УстановитьСубконто(Проводка.СчетДт,Проводка.СубконтоДт,"Номенклатура", СтрокаТаблицы.Номенклатура,Истина, Заголовок);
        //ОбщегоНазначения.УстановитьСубконто(Проводка.СчетДт,Проводка.СубконтоДт,"НоменклатурныеПозиции", СтрокаТаблицы.НоменклатурнаяПозиция,, Заголовок);

        ОбщегоНазначения.УстановитьСубконто(Проводка.СчетДт,Проводка.СубконтоДт,"Склады",  СтруктураШапкиДокумента.Склад);
        
        // Для товаров, принятых на комиссию партия прописывается всегда 

        //Если (ПартионныйУчетБУ) ИЛИ (УправлениеЗапасамиПартионныйУчет.КомиссионныйТовар(СтрокаТаблицы.СчетУчетаБУ)) Тогда 

        ОбщегоНазначения.УстановитьСубконто(Проводка.СчетДт,Проводка.СубконтоДт,"Партии", hiОснование,, Заголовок);
        //КонецЕсли;

        
        Проводка.КоличествоДт = СтрокаТаблицы.Количество;
        Проводка.Сумма = (СтрокаТаблицы.СуммаВзаиморасчетовНовая - СтрокаТаблицы.СуммаСтараяВал)-СтрокаТаблицы.СуммаНДСРегл;
        Проводка.СчетКт = СчетКт;
        ОбщегоНазначения.УстановитьСубконто(Проводка.СчетКт,Проводка.СубконтоКт,"Контрагенты",        СтруктураШапкиДокумента.Контрагент, Истина, Заголовок);
        ОбщегоНазначения.УстановитьСубконто(Проводка.СчетКт,Проводка.СубконтоКт,"Договоры",           СтруктураШапкиДокумента.ДоговорКонтрагента);
        ОбщегоНазначения.УстановитьСубконто(Проводка.СчетКт,Проводка.СубконтоКт,"ДокументыРасчетовСКонтрагентами", СтрокаТаблицы.СделкаНУ);
        
        Если Проводка.СчетКт.Валютный Тогда
            Проводка.ВалютаКт        = СтруктураШапкиДокумента.ВалютаВзаиморасчетов;
            Проводка.ВалютнаяСуммаКт = СтрокаТаблицы.ПроводкиСуммаБезНДСВал;
        КонецЕсли;
        // - закончили

        
        // кредит по НДС наступает с 2011 года в момент поставки товаров и меняется при изменении суммы компенсации товаров

        Если СтрокаТаблицы.ПроводкиСуммаНДСРегл <> 0 Тогда
            
            Проводка = Движения.Хозрасчетный.Добавить();

                Проводка.Период      = Дата;

                Проводка.Организация = СтруктураШапкиДокумента.Организация;
                Проводка.Содержание  = "НДС - налоговый кредит (корректировка)";

                Проводка.СчетДт          = СтруктураШапкиДокумента.СчетУчетаНДСПодтвержденный;
                ОбщегоНазначения.УстановитьСубконто(Проводка.СчетДт,Проводка.СубконтоДт,"Контрагенты",        СтруктураШапкиДокумента.Контрагент, Истина);
                ОбщегоНазначения.УстановитьСубконто(Проводка.СчетДт,Проводка.СубконтоДт,"Договоры",           СтруктураШапкиДокумента.ДоговорКонтрагента);
                ОбщегоНазначения.УстановитьСубконто(Проводка.СчетДт,Проводка.СубконтоДт,"ДокументыРасчетовСКонтрагентами", СтрокаТаблицы.СделкаНУ);
                
                Проводка.СчетКт      = СчетКт;
                ОбщегоНазначения.УстановитьСубконто(Проводка.СчетКт,Проводка.СубконтоКт,"Контрагенты",        СтруктураШапкиДокумента.Контрагент, Истина, Заголовок);
                ОбщегоНазначения.УстановитьСубконто(Проводка.СчетКт,Проводка.СубконтоКт,"Договоры",           СтруктураШапкиДокумента.ДоговорКонтрагента);
                ОбщегоНазначения.УстановитьСубконто(Проводка.СчетКт,Проводка.СубконтоКт,"ДокументыРасчетовСКонтрагентами", СтрокаТаблицы.СделкаНУ);

                Проводка.Сумма       = СтрокаТаблицы.ПроводкиСуммаНДСРегл;
                
        КонецЕсли;// Проводки по НДС

        
    КонецЦикла;            
    
КонецПроцедуры

5. Процедура ЗаполнитьКолонкиРегистраСписанныеТоварыПоТоварамУпр(РежимПроведения, СтруктураШапкиДокумента, ТаблицаПоТоварам, Отказ, Заголовок, ТаблицаДвижений)
    
    ТаблицаДвижений.ЗаполнитьЗначения(ОтражатьВУправленческомУчете,"ОтражатьВУправленческомУчете");
    // + начали

    //ТаблицаДвижений.ЗаполнитьЗначения(Перечисления.СтатусыПартийТоваров.НаКомиссию,"ДопустимыйСтатус3");

    ТаблицаДвижений.ЗаполнитьЗначения(Перечисления.СтатусыПартийТоваров.Купленный,"ДопустимыйСтатус3");
    // - закончили

    ТаблицаДвижений.ЗаполнитьЗначения(Подразделение,"Подразделение");
    
КонецПроцедуры

6.Процедура ОбработкаЗаполнения(Основание)

    Если ТипЗнч(Основание) = Тип("ДокументСсылка.ПоступлениеТоваровУслуг") 
     Или ТипЗнч(Основание) = Тип("ДокументСсылка.ПоступлениеТоваровУслугВНТТ")Тогда
    

        ЗаполнениеДокументов.ЗаполнитьШапкуДокументаПоОснованию(ЭтотОбъект, Основание);

        Сделка = Основание.Сделка;

        Если Не ДоговорКонтрагента.ВидДоговора = Перечисления.ВидыДоговоровКонтрагентов.СПоставщиком Тогда
            Возврат;
        КонецЕсли;
        // + начали

        hiОснование = Основание;
        // - закончили 

        Если Основание.Проведен Тогда
            ЗаполнитьТоварыУпр(Основание);
        КонецЕсли;
        
        СчетДт = ПланыСчетов.Хозрасчетный.ТоварыНаСкладе;
        СчетКт = ПланыСчетов.Хозрасчетный.РасчетыСОтечественнымиПоставщиками;
        
    КонецЕсли;

КонецПроцедуры// ОбработкаЗаполнения()
   Горогуля
 
73 - 04.09.16 - 14:29
ну я же говорил...
а ещё можно кинуть сюда все вызываемые общие модули
   glebkhil
 
74 - 04.09.16 - 14:45
регистр накопления который используется

Перем мПериод          Экспорт;// Период движений

Перем мТаблицаДвижений Экспорт;// Таблица движений


// Выполняет приход по регистру.

//
// Параметры:

//  Нет.
//

Процедура ВыполнитьПриход() Экспорт

    ОбщегоНазначения.ВыполнитьДвижениеПоРегистру(ЭтотОбъект, ВидДвиженияНакопления.Приход);

КонецПроцедуры// ВыполнитьПриход()


// Выполняет расход по регистру.

//
// Параметры:

//  Нет.
//

Процедура ВыполнитьРасход() Экспорт

    ОбщегоНазначения.ВыполнитьДвижениеПоРегистру(ЭтотОбъект, ВидДвиженияНакопления.Расход);

КонецПроцедуры// ВыполнитьРасход()


// Выполняет движения по регистру.

//
// Параметры:

//  Нет.
//

Процедура ВыполнитьДвижения() Экспорт

    Загрузить(мТаблицаДвижений);

КонецПроцедуры// ВыполнитьДвижения()


// Процедура контролирует остаток по данному регистру по переданному документу

// и его табличной части. В случае недостатка товаров выставляется флаг отказа и 
// выдается сообщегние.

//
// Параметры:

//  ДокументОбъект    - объект проводимого документа, 
//  ИмяТабличнойЧасти - строка, имя табличной части, которая проводится по регистру, 

//  СтруктураШапкиДокумента - структура, содержащая значения "через точку" ссылочных реквизитов по шапке документа,
//  Отказ             - флаг отказа в проведении,

//  Заголовок         - строка, заголовок сообщения об ошибке проведения.
//

Процедура КонтрольОстатков(ДокументОбъект, ИмяТабличнойЧасти, СтруктураШапкиДокумента, СтатусПолучения, Отказ, Заголовок) Экспорт
    
    Если ДокументОбъект[ИмяТабличнойЧасти].Количество() = 0 Тогда
        Возврат;
    КонецЕсли;
    
    МетаданныеДокумента = ДокументОбъект.Метаданные();
    ИмяДокумента        = МетаданныеДокумента.Имя;
    ИмяТаблицы          = ИмяДокумента + "." + СокрЛП(ИмяТабличнойЧасти);
    ЕстьСерия           = ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента("СерияНоменклатуры", МетаданныеДокумента, ИмяТабличнойЧасти);
    ЕстьХарактеристика  = ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента("ХарактеристикаНоменклатуры", МетаданныеДокумента, ИмяТабличнойЧасти);
    ЕстьКоэффициент     = ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента("Коэффициент", МетаданныеДокумента, ИмяТабличнойЧасти);

    // Текст вложенного запроса, ограничивающего номенклатуру при получении остатков

    ТекстЗапросаСписокНоменклатуры = "
        |ВЫБРАТЬ РАЗЛИЧНЫЕ
        |    Номенклатура 
        |ИЗ
        |    Документ." + ИмяТаблицы + "
        |ГДЕ
        |    Ссылка = &ДокументСсылка";

    Запрос = Новый Запрос;

    // Установим параметры запроса

    Запрос.УстановитьПараметр("ДокументСсылка",     СтруктураШапкиДокумента.Ссылка);
    Запрос.УстановитьПараметр("ДоговорКонтрагента", СтруктураШапкиДокумента.ДоговорКонтрагента); 
    Если ЗначениеЗаполнено(СтруктураШапкиДокумента.Сделка) Тогда
        Запрос.УстановитьПараметр("Сделка", СтруктураШапкиДокумента.Сделка);
    Иначе
        Запрос.УстановитьПараметр("Сделка", Неопределено);
    КонецЕсли;
    Запрос.УстановитьПараметр("СтатусПолучения",    СтатусПолучения);

    ТекстЗапроса = "
    |ВЫБРАТЬ// Запрос, контролирующий остатки на складах

    |    Док.Номенклатура.Представление                         КАК НоменклатураПредставление,
    |    Док.Номенклатура.ЕдиницаХраненияОстатков.Представление КАК ЕдиницаХраненияОстатковПредставление,
    |   %ПОЛЕ_Док_Характеристика%                              КАК ХарактеристикаНоменклатуры,
    |    ПРЕДСТАВЛЕНИЕ(%ПОЛЕ_Док_Характеристика%)               КАК ХарактеристикаНоменклатурыПредставление,
    |   %ПОЛЕ_Док_Серия%                                       КАК СерияНоменклатуры,
    |    ПРЕДСТАВЛЕНИЕ(%ПОЛЕ_Док_Серия%)                        КАК СерияНоменклатурыПредставление,
    |    %ПОЛЕ_Док_Количество%                                  КАК ДокументКоличество,
    |    ЕСТЬNULL(МАКСИМУМ(Остатки.КоличествоОстаток), 0)       КАК ОстатокКоличество
    |ИЗ 
    |    Документ." + ИмяТаблицы + " КАК Док
    |
    |ЛЕВОЕ СОЕДИНЕНИЕ
    |    РегистрНакопления.hi_ТоварыПолученные.Остатки(,
    |        Номенклатура В (%ВыборкаПоНоменклатуре%)
    |        И ДоговорКонтрагента = &ДоговорКонтрагента
    |        И Сделка             = &Сделка
    |        И СтатусПолучения    = &СтатусПолучения
    |    ) КАК Остатки
    |ПО 
    |    Док.Номенклатура                = Остатки.Номенклатура
    |  // СОЕДИНЕНИЕ_Характеристика_Остатки

    |  // СОЕДИНЕНИЕ_Серия_Остатки

    |
    |ГДЕ
    |    Док.Ссылка  =  &ДокументСсылка
    |
    |СГРУППИРОВАТЬ ПО
    |    Док.Номенклатура,
    |   %ПОЛЕ_Док_Характеристика%,
    |   %ПОЛЕ_Док_Серия%
    |
    |ИМЕЮЩИЕ
    |    ЕСТЬNULL(МАКСИМУМ(Остатки.КоличествоОстаток), 0) < %ПОЛЕ_Док_Количество%
    |
    |ДЛЯ ИЗМЕНЕНИЯ
    |    РегистрНакопления.hi_ТоварыПолученные.Остатки// Блокирующие чтение таблицы остатков регистра для разрешения коллизий многопользовательской работы

    |";

    Если ЕстьХарактеристика Тогда
        ТекстЗапроса = СтрЗаменить(ТекстЗапроса, "%ПОЛЕ_Док_Характеристика%",            "Док.ХарактеристикаНоменклатуры");
        ТекстЗапроса = СтрЗаменить(ТекстЗапроса, "// СОЕДИНЕНИЕ_Характеристика_Остатки", " И Док.ХарактеристикаНоменклатуры = Остатки.ХарактеристикаНоменклатуры");

    Иначе
        ТекстЗапроса = СтрЗаменить(ТекстЗапроса, "%ПОЛЕ_Док_Характеристика%",            "Неопределено");
        ТекстЗапроса = СтрЗаменить(ТекстЗапроса, "// СОЕДИНЕНИЕ_Характеристика_Остатки", "");

    КонецЕсли;
    Если ЕстьСерия Тогда
        ТекстЗапроса = СтрЗаменить(ТекстЗапроса, "%ПОЛЕ_Док_Серия%",            "Док.СерияНоменклатуры");
        ТекстЗапроса = СтрЗаменить(ТекстЗапроса, "// СОЕДИНЕНИЕ_Серия_Остатки", " И Док.СерияНоменклатуры = Остатки.СерияНоменклатуры");

    Иначе
        ТекстЗапроса = СтрЗаменить(ТекстЗапроса, "%ПОЛЕ_Док_Серия%",            "Неопределено");
        ТекстЗапроса = СтрЗаменить(ТекстЗапроса, "// СОЕДИНЕНИЕ_Серия_Остатки", "");

    КонецЕсли;
    
    ТекстЗапроса = СтрЗаменить(ТекстЗапроса, "%ПОЛЕ_Док_Количество%", ?(ЕстьКоэффициент,
        "СУММА(Док.Количество * Док.Коэффициент / Док.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент)",
        "СУММА(Док.Количество)"));
    ТекстЗапроса = СтрЗаменить(ТекстЗапроса, "%ВыборкаПоНоменклатуре%", ТекстЗапросаСписокНоменклатуры);
    
    Если глЗначениеПеременной("ИспользоватьУправляемыеБлокировки")  Тогда
        Запрос.Текст = 
            "ВЫБРАТЬ
            |Док.Номенклатура КАК Номенклатура"
            + ?(ЕстьХарактеристика, ", Док.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры ","")
            + "
            |ИЗ 
            |    Документ." + ИмяТаблицы + " КАК Док
            |
            |ГДЕ 
            |    Док.Ссылка  =  &ДокументСсылка";
            
        РезультатЗапросаДляБлокировки = Запрос.Выполнить();
        Если НЕ РезультатЗапросаДляБлокировки.Пустой() Тогда
            СтруктураПараметровБлокировки = Новый Структура(
                "ТипТаблицы,ИмяТаблицы,ИсточникДанных"
                ,"РегистрНакопления"
                ,"hi_ТоварыПолученные"
                ,РезультатЗапросаДляБлокировки);
                
            СтруктураЗначенийБлокировки = Новый Структура(
                "ДоговорКонтрагента, СтатусПолучения" 
                , СтруктураШапкиДокумента.ДоговорКонтрагента
                , СтатусПолучения);
            
            СтруктураИсточникаДанных = Новый Структура("Номенклатура", "Номенклатура");            
            Если ЕстьХарактеристика Тогда
                СтруктураИсточникаДанных.Вставить("ХарактеристикаНоменклатуры","ХарактеристикаНоменклатуры");
            КонецЕсли;
            
            ОбщегоНазначения.УстановитьУправляемуюБлокировку(СтруктураПараметровБлокировки,СтруктураЗначенийБлокировки,СтруктураИсточникаДанных, Отказ, Заголовок);
        КонецЕсли;
    КонецЕсли;
    
    Запрос.Текст = ТекстЗапроса;
    Выборка = Запрос.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл

        СтрокаСообщения = "Остатка " + 
            УправлениеЗапасами.ПредставлениеНоменклатуры(Выборка.НоменклатураПредставление, 
                                      ?(ЕстьХарактеристика, Выборка.ХарактеристикаНоменклатурыПредставление, ""),
                                      ?(ЕстьСерия, Выборка.СерияНоменклатурыПредставление, "")) +
            " полученного по договору """ + СокрЛП(СтруктураШапкиДокумента.ДоговорКонтрагента) + ?(НЕ ЗначениеЗаполнено(СтруктураШапкиДокумента.Сделка), "",
            " и по сделке " + СокрЛП(СтруктураШапкиДокумента.Сделка)) +
            """ недостаточно.";

        УправлениеЗапасами.ОшибкаНетОстатка(СтрокаСообщения, Выборка.ОстатокКоличество, Выборка.ДокументКоличество,
            Выборка.ЕдиницаХраненияОстатковПредставление, Отказ, Заголовок);

    КонецЦикла;

КонецПроцедуры// КонтрольОстатков()
   Злопчинский
 
75 - 04.09.16 - 14:52
Мудня полная
Если ведется торговый управленческий учет и к бухии не имеем отношения - о чем и говорил сам автор - то не ипите мозг. Любым доступным способом переведите все с договора куплипродажи на договор комиссии и юзайте типовые механизмы

Сделать переоценку договора куплипродажи в восьмерке даже я тупой старый клюшечник смогу. Тупо любой доступной корректировкой проведу изменение долга перед поставщиком и тупо любой доступной корректировкой сделаю изменение себестоимости

Все. Профит.
   glebkhil
 
76 - 04.09.16 - 14:55
>Мудня полная 
Если ведется торговый управленческий учет и к бухии не имеем отношения - о чем и говорил сам автор - то не ипите мозг. Любым доступным способом переведите все с договора куплипродажи на договор комиссии и юзайте типовые механизмы

Сделать переоценку договора куплипродажи в восьмерке даже я тупой старый клюшечник смогу. Тупо любой доступной корректировкой проведу изменение долга перед поставщиком и тупо любой доступной корректировкой сделаю изменение себестоимости

Все. Профит.

Я вариант с изменением договора тоже предлогал бухам, но вот они уперлись что нужен именно такой документ и что б он переоценивал товар, который на 28 счету, а не на 0 как по договору консигнации
   Злопчинский
 
77 - 04.09.16 - 14:55
Итого имею в результате нужное значение долга согласованное с поставщиком и нужная сумма запасов товаров - то есть то что ПО СУЩЕСТВУ надо топикстартеру

А что жто по учету - комиссия или договор куплипродажи - в данном соучае полный пофиг, ибо учета как такового у автора нет. У него стоит задача не учет вести, а иметь те цифры которые ему нужны
   Злопчинский
 
78 - 04.09.16 - 15:02
(76)  попроси буха  хамнаписать проводки по переоценке в корреспонденции с 28 счетом

Если это балансовый счет а я в этом почти не сомневаюсь то вариант переоценки в данном случае полюбасику сведется к корректировке взаиморасчетов, скидкам, бонусам, то есть тривиальному буховскому дт-кт, то есть ничто никуда не исчезнет. И если бухи надеются что таким образом они снизят както свой долг или высокую себестоимость или иным образом скорректируют тот или иной показатель/счет бухгалтерского балансового у ета - то не выйдет, вся дельта такой корректировки тем или иным образом ляжет в счет доходов или расходов компании,

Автор так и не сказал по учету проходит как договор купли продажи или както иначе? Здесь мы однозначно понимаем что по учету эквивалентно понятию Правильно. То есть то что показано по учету мы считаем правильным. Если по учету как выясняется показано неправильно - то неправильное в правильное просто так без последствий превратить не удастся
   Злопчинский
 
79 - 04.09.16 - 15:02
Автор озвучь наименование вашего 28 счета
   Злопчинский
 
80 - 04.09.16 - 15:05
(76)  я также привел вариант и без изменения сути договора
Но если в торговой программе можно по договору купли продажи нужную тебе корректировку-переоценку провести в полпинка - потому что торговая система есть незамкнутая система построенная на регистрах, которые не привязаны к принципу двойной записи - то по бухии такую торговую переоценку ты не сумеешь отразить просто так - куда-то эта лельта должна упасть в бухучете, она никуда не исчезнет
   glebkhil
 
81 - 04.09.16 - 15:05
>Итого имею в результате нужное значение долга согласованное с поставщиком и нужная сумма запасов товаров - то есть то что ПО СУЩЕСТВУ надо топикстартеру

А что жто по учету - комиссия или договор куплипродажи - в данном соучае полный пофиг, ибо учета как такового у автора нет. У него стоит задача не учет вести, а иметь те цифры которые ему нужны

схема как работает у нас. У нас есть управленческая база и УТП, где работает бухгалтерия. управленческая в 1с 7 для менеджеров, между собой базы не связаны, в 7ке ведется как серый так и белый учет (для менеджеров). с поставщиком, товар которого на реализации, ему отчет по проданному отправляется раз в две недели. По проданному поставщик потом присылает документы, но так как бывает проплата не сразу, то поставщик делает иногда переоценки (с колебанием курса), и получается что бухгалтеру нужно ввести переоценку. Но так они сделали что приходуют на 28 счет, какая то договоренность в документообороте с поставщиком есть.

наименование 28 счета 
На счету 28 "Товары" ведется учет движения товарно-материальных ценностей, которые поступили на предприятие с целью продажи. Этот счет используют в основном сбыте, торговые и заготовительные предприятия и организации, а также предприятия общественного питания.
   glebkhil
 
82 - 04.09.16 - 15:09
>я также привел вариант и без изменения сути договора
Но если в торговой программе можно по договору купли продажи нужную тебе корректировку-переоценку провести в полпинка - потому что торговая система есть незамкнутая система построенная на регистрах, которые не привязаны к принципу двойной записи - то по бухии такую торговую переоценку ты не сумеешь отразить просто так - куда-то эта лельта должна упасть в бухучете, она никуда не исчезнет

я может быть и лучше обьяснил, но не являюсь программистом 1с. В штате программистов нет, а фирма запросила сильно большую стоимость за новый документ. На что руководство решило не идти. Тот код документа что я кидал сюда работает, но в случае если нет решения, его попросили изменить внешне
   Горогуля
 
83 - 04.09.16 - 15:14
кстати, цифры в скобках в начале поста - это бонусные баллы, которые начисляются за ответ на какой-то конкретный пост без его цитирования целиком. от этого растёт длина полоски. автор, попробуй пользоваться этой методикой
   glebkhil
 
84 - 04.09.16 - 15:19
(83) не знал, спасибо
   Джинн
 
85 - 04.09.16 - 15:57
(81) Да неважно серая у Вас база, белая или в соответствии с требования ЕС радужная. Важно то, что есть принципы учета. Общепринятые. Закрепленные как нормами, так и практикой делового оборота.

Какой смысл считать всех идиотами, руководствующимися какими-то "левыми" принципами, а свой ларек законодателем стандартов учета?

Почему не сделать сразу правильно, как у людей? Откуда неуемное стремление сделать все через жпо?
   glebkhil
 
86 - 04.09.16 - 16:17
(85) А я не говорил что схема как у меня на предприятии правильная, сам знаю что это все не правильно, но в силу каких то обстоятельств они потупили так и из этого появилась такая проблема. И для решения проблемы им нужен документ этот.
   Злопчинский
 
87 - 04.09.16 - 16:51
(86)  еще раз
Для совсем тупых

Ты говоришь про схему комиссионной торговли, упоминая отчет о продажах который вы даете поставщику

Но при этом ты не упоминаешь ничего про свое комиссионное вознаграждение

При этом внезапно после того как вы дали отчет поставщику по проданной комиссии возникает 28 счет - аналог российского 41 Товары - и потом возникает потребность с этим счетом что-то делать в части какойто муйневой переоценки

Итак понятно что в бухучете у вас ничего про комиссионную торговлю нет

А пофакту вы прикрываясь схемой комиссионной торговли берете у поставщика товар под честное слово - так как договора комиссии у вас нет - продаете жтот товар - и только по проданному товару поставщик вам лелает поставку, которую вы отражаете у себя в учете как обычную куплюпродажу и из нее продаете по учету покупателям

Де бре у вас купляпродажа
Дефакто у вас комиссионная схема которой вы пытаетесь снизить собственные издержки - возвращая поставщику непроданный товар и проводя сделку закупки товара у поставщика не тогда когда она состоялась а по факту того что жтот товар продан

Таковая схема имеет право на жизнь, но плохо пахнет и есть риски попасть на штрафы и проблемы с обоих сторон сделки от налоговой

Теперь так как лебре у вас жто проходит по учету как купляпродажа - то никакой переоценки не может быть в принципе. Свой товар который у вас появился на балансе после отрадения сделки куплипродажи по леюре - переоценки не подлежит

То что ты и твои бухгалтера называют переоценкой таковой неявляется и показывает молную мутность как и тебя - это еще полбеды - но и мутность ваших бухгалтеров.

Твоя так называемая переоценка проводимая потому что при оформлении сделки куплипродажи по деюре вы лажаете с подсчетом стоимости такой сделки ибо вы там все изобретатели велосипедов и времени на нормальный учет у вас не остается - так вот облажавшись с оценкой стоимости сделки деюре исправить жто можно толтко одним способом - выпустить новые новые документы по сделке купли продажи при жтом изничтожив старые документв по куплепродаже на 28счет. Но это не всегда возможно. Закрыт период, сдана бух и нал отчетность и прочее. В этом случае производится корректировка стоимости сделки вполне себе бухгалтерскими и налоговыми правилами - условия таких корректировок - путем предоставления скидок, наценок, премий и штрафов должны быть однозначно прописаны в жтом самом договоре купли продажи. Получив от поставщика дебет или кредит ноту, корректировочный счф или прочее что положено по бу/ну - только на основании таких документов вы вправе провести корректировку как стоимости закупленных товаров так и своего долга перед поставщиком. Но при жтом скорее всего потребуется слача уточненных деклараций всяких по бу/ну - тут надо уже конкретно смотреть правила ведения бу/ну

Для отражения таких корректировок существуют стандартные документы в конфиге.
Приплетать сюда как ето левые переоценки - верх непрофессионализма
Вполне лопускаю что я не в полной мере просек вашу схему серобелого учета или могут быть особенности специфических договоров консигнации но могу с большой долей уверенности предположить что если возник у ет на счете 28 - то примерно все как я описал выше
И если вы думаете что вы особо умные и изобрели нивипенно чоткую схему наипалова государства то спешу вас обрадовать - ничего нового вы не придумали.
И такая схема канает ровно до того момента пока за вас всерьез не возьмется налоговая или вы не потеряете - пожар - кража - прочее - товар поставщика и тогда вы все забегаете вместе споставщиком как ужаленные и будете судиться и отбиваться от бандюков
   Злопчинский
 
88 - 04.09.16 - 16:54
(86)  документ бесполезно делать
Доя корректировки сделок по куплепродаже в конфиге должны быть нужные штатные служебные документы и обычные дркументы
Ну и все таки зотелось бы услышать начальника транспортного цеха в части полной схемы проводок по такой нужной вам "переоценке"

Как франч я бы за такую работу запросил бы овер дофига денег потому что кроме работы придется еще и ваших бухов учить и учет выправлять ибо скорее всего не взлетит на том гуане которое у вас в бухучетк
   glebkhil
 
89 - 04.09.16 - 16:59
(87) ну вот и запросили у бухов кучу денег, и те пока нажали стоп кран
   Злопчинский
 
90 - 04.09.16 - 17:32
(89)  потому что мутаки
Распишите для начала нужную схему проводок и потом смотрите как ее можно реализрвать имеющимися возможностями


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует