Вход | Регистрация

1С:Предприятие ::

Метки: 

v7: Вопрос по группировкам в запросе

Я
   BORG
 
14.10.15 - 15:29
При написании запроса возникла проблема с обходом по группировкам...после выполнения запроса видна только одна группировка, подскажите плз кто знает или помнит с чем это связано..может это просто глюк 7-ки при работе с запросами

сам запрос, сделанный через конструктор...
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)

    |Период с ВыбНачПериода по ВыбКонПериода;
    |Обрабатывать НеПомеченныеНаУдаление;
    |Без итогов;
    |ПродажаСоСклада = Документ.ПродажаСоСклада.ТекущийДокумент;
    |Покупатель = Документ.ПродажаСоСклада.Покупатель;
    |Товар = Документ.ПродажаСоСклада.Товар;
    |Колво = Документ.ПродажаСоСклада.Колво;
    |СуммаСоСкидкой = Документ.ПродажаСоСклада.СуммаСоСкидкой;
    |Функция КолвоСумма = Сумма(Колво);
    |Функция ВсегоСумма = Сумма(СуммаСоСкидкой);
    |Группировка Покупатель;
    |Группировка Товар без упорядочивания без групп;        
    |"//}}ЗАПРОС

    ;
    // Если ошибка в запросе, то выход из процедуры

    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;    
    
    Пока Запрос.Группировка(1) = 1 Цикл
        Таб.ВывестиСекцию("Покуп");
         Пока Запрос.Группировка(2) = 1 Цикл            
            Таб.ВывестиСекцию("Товар");    
        КонецЦикла;
    КонецЦикла;

так вот при выполнении не происходит обход по группировкам, хотя данные выбраны, но почему то 1с-ка видит только одну группировку по "Товар". Т.е. если я пишу Пока Запрос.Группировка() = 1 Цикл тогда все работает но у меня группировка идет только по товарам. При чем пытался другие виды группировок указать, например по документу, все равно видит только одну группировку по товару и все.
Помню давно еще возникала такая проблема, а вот как ее решали уже не помню:)..может выгружали запрос в таблицу и потом делали обход, а может есть какой нюанс.
Заранее благодарен
 
  Рекламное место пустует
   Ёпрст
 
1 - 14.10.15 - 15:51
(0) Без итогов
   Ёпрст
 
2 - 14.10.15 - 15:52
читать сп на ночь, много думать
   BORG
 
3 - 14.10.15 - 16:00
(1) Спасибо большое, я уже и сам допер, посмотрев что может быть лишним в запросе и почитав что это может значить:)
Просто когда постоянно с чем то работаешь, то концентрация внимания выше на всякие мелочи и нюансы, а так забывается...


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует