Вход | Регистрация


1С:Предприятие ::

Метки: 

Изменить дату в регистре сведений

Я
   starV
 
11.04.14 - 13:56
Доброго времени суток!!!
Народ можно ли  в  регистре заменит дату  на 01,04,2014
которое ровна на 02,04,2014,
с помощью внешней обработки.
 
 
   ИА1С
 
1 - 11.04.14 - 13:58
Все можно)))) Пиши обработку)))) А какой хотя бы регистр? Хотя бы тип)))) И ключевой вопрос, ЗА ЧЕМ?
   ДенисЧ
 
2 - 11.04.14 - 13:59
(0) Я не против...
   Рэйв
 
3 - 11.04.14 - 14:00
(0)
1.НаборЗаписей
2.Отбор
3.НаборЗаписей.Прочитать();
4. Для Каждого Зап Из НаборЗаписей Цикл Зап.Период='20140401000'; Конеццикла
5.НаборЗаписей.Записать(Истина);
   Рэйв
 
4 - 11.04.14 - 14:01
ну и условие проверять где 02.04.2014
   Ненавижу 1С
 
5 - 11.04.14 - 14:01
ЗАЧЕМ?
   starV
 
6 - 11.04.14 - 14:28
еще примерый есть
   Wobland
 
7 - 11.04.14 - 14:31
(6) ВнешняяОбработка1.epf
   13_Mult
 
8 - 11.04.14 - 14:39
(0) Не лезли бы вы в регистры, пока целы они ! ))
   13_Mult
 
9 - 11.04.14 - 14:41
(0) Поменяй например дату регистратора (Документа или что там ещё), запиши по новой.
   starV
 
10 - 11.04.14 - 14:49
не судите строга  сделала что я могла 
ПО 1с знании маловато

Процедура ЗаписьПрограммно()
    Запрос = Новый Запрос;
    Запрос.Текст =  
    "ВЫБРАТЬ
    |    Расписание.СрезПоследних.Период
    |ИЗ
    |    РегистрСведений.РасписаниеСрезПоследних КАК РасписаниеСрезПоследних"
    
    Выборка = Запрос.Выполнить().Выбрать();
    
    Пока Выборка.Следующий() Цикл
        
        Если РасписаниеСрезПоследних.Период='201404020000' тогда
            Отбор
            НаборЗаписей.Прочитать();
            Для Каждого Зап Из НаборЗаписей Цикл Запись.Период='201404010000';
                Запись = НаборЗаписей.Добавить();   
            КонецЕсли; 
            
        КонецЦикла;
        
        НаборЗаписей.Записать(истина); 
        
        
    КонецПроцедуры


не могу по новый написать легче изменит данные слишком много данных вы это имели введу  (0)
 
 
   Wobland
 
11 - 11.04.14 - 14:49
теперь без фото не взлетит
   Wobland
 
12 - 11.04.14 - 14:50
Рэйв кому трудился? какое слово непонятно?
   13_Mult
 
13 - 11.04.14 - 14:57
Пол: Мужской?!
(11) +1 Без фотки не взлетит
   John83
 
14 - 11.04.14 - 14:58
(10) да все нормально - можешь запускать :)
   13_Mult
 
15 - 11.04.14 - 14:59
   Ненавижу 1С
 
16 - 11.04.14 - 15:01
(15) это по 7.7
   starV
 
17 - 11.04.14 - 15:03
нет по 8,2
   Wobland
 
18 - 11.04.14 - 15:03
(17) это он не тебе
   13_Mult
 
19 - 11.04.14 - 15:09
Сейчас все испорчу
http://help1c.com/faq/view/1361.html
   starV
 
20 - 11.04.14 - 16:15
Можно ли сделать так 
    Запись.Период = ДатаЗаписи-'000000010000';
но ошбибка
Запись.Период = ДатаЗаписи-<<?>>'000000010000'; (Проверка: Толстый клиент (обычное приложение))
   Ненавижу 1С
 
21 - 11.04.14 - 16:18
(20) тебе надо вычесть день?
пиши ДатаЗаписи-86400



Список тем форума
Рекламное место пустует   Рекламное место пустует
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует