Вход | Регистрация

1С:Предприятие ::

Метки: 

v7: Расшифровка в отчете 1с 7.7

Я
   9451523
 
10.04.14 - 14:23
Уважаемые форумчане
Помогите с расшифровкой в отчете, программировать в 1с начал недавно,
вот дополз до расшифровок. Мне нужно что бы таблице с отчетом при нажатии клавиши enter на ячейке открывался его исходный документ то есть надо установить расшифровку в свойствах ячейки , как это все грамотно реализовать?
Вот код отчета:
Процедура ВывестиСписок()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос

    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(ВывестиСписок)

    |Период с ВыбНачПериода по ВыбКонПериода;
    |ПоступлениеМатериалов =   
        Документ.ПоступлениеМатериалов.ТекущийДокумент;
    |Группировка ПоступлениеМатериалов упорядочить по     ПоступлениеМатериалов.ДатаДок, ПоступлениеМатериалов.НомерДок, ПоступлениеМатериалов.ДатаНомерСчетаФактуры, ПоступлениеМатериалов.Контрагент, ПоступлениеМатериалов.Сумма, ПоступлениеМатериалов.НДС, ПоступлениеМатериалов.Всего;
    |"//}}ЗАПРОС

    ;
    // Если ошибка в запросе, то выход из процедуры

    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;

    // Подготовка к заполнению выходных форм данными запроса

    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("ВывестиСписок");
    // Заполнение полей "Заголовок"

    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка(1) = 1 Цикл
        // Заполнение полей ПоступлениеМатериалов

        Таб.ВывестиСекцию("ПоступлениеМатериалов");
    КонецЦикла;
    // Вывод заполненной формы

    Таб.ТолькоПросмотр(1);
    Таб.Показать("ВывестиСписок", "");
КонецПроцедуры

Расшифровка нужна только на ячейку где группируются данные по ПоступлениеМатериалов.ДатаНомерСчетаФактуры
С уважением Дамир
 
  Рекламное место пустует
   Ёпрст
 
1 - 10.04.14 - 14:26
в поле Расшифровка напиши Запрос.ПоступлениеМатериалов 

наслаждайся
   9451523
 
2 - 10.04.14 - 14:37
Ёпрст ты гений
не думал что все так просто

Спасибо


Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует