Вход | Регистрация

1С:Предприятие ::

Метки: 

v7: Напомните по 77. Бухитоги

Я
   егаис
 
10.04.14 - 14:04
Есть код типа:
    БИ = СоздатьОбъект("БухгалтерскиеИтоги"); 
    БИ.ИспользоватьСубконто(ВидыСубконто.Контрагенты);
    БИ.ИспользоватьСубконто(ВидыСубконто.Договоры);                   
    БИ.ВыполнитьЗапрос(НачГода(ФинансовыйПериод),ФинансовыйПериод,"62.1",,,3,,);    

    БИ_Н06 = СоздатьОбъект("БухгалтерскиеИтоги"); 
    БИ_Н06.ИспользоватьСубконто(ВидыСубконто.Договоры);
    БИ_Н06.ВыполнитьЗапрос(НачГода(ФинансовыйПериод),ФинансовыйПериод,"Н06.01");    
    БИ_Н06.ВыбратьСубконто(1);

БИ.ВыбратьСубконто(1);
Пока БИ.ПолучитьСубконто(1) = 1 Цикл 
БИ.ВыбратьСубконто(2);
Пока БИ.ПолучитьСубконто(2) = 1 Цикл 
Если БИ_Н06.ПолучитьСубконто(1,,БИ.Субконто(2)) > 0 Тогда
СуммаНДС = БИ.ДО() - БИ_Н06.КО();
КонецЕсли;
КонецЦикла;
КонецЦикла;

Вот не находит и все по БИ_Н06.ПолучитьСубконто(1,,БИ.Субконто(2))
Не помню, разве есть ньюансы по подчиненным справочникам в значении субконто?
 
  Рекламное место пустует
   Chai Nic
 
1 - 10.04.14 - 14:05
Очень советую ставить вместо номера субконто - вид субконто. Это не влияет на работу алгоритма, зато реально улучшает понятность кода.
   егаис
 
2 - 10.04.14 - 14:06
(1) это для примера, код там другой, много разных счетов с неявно определенными видами субконто. Расписывать лень было )
   егаис
 
3 - 10.04.14 - 14:12
Кто-нибудь сэмулируйте у себя сабж на базе бухии 77.
   егаис
 
4 - 10.04.14 - 14:18
тип итогов в запросе никак не влияет (
сдулись, снеговики? :))
   егаис
 
5 - 10.04.14 - 14:19
БИ = СоздатьОбъект("БухгалтерскиеИтоги"); 
    БИ.ИспользоватьСубконто(ВидыСубконто.Контрагенты);
    БИ.ИспользоватьСубконто(ВидыСубконто.Договоры);                   
    БИ.ВыполнитьЗапрос('01.01.14','30.04.14',"62.1",,,3,,);    

    БИ_Н06 = СоздатьОбъект("БухгалтерскиеИтоги"); 
    БИ_Н06.ИспользоватьСубконто(ВидыСубконто.Договоры);
    БИ_Н06.ВыполнитьЗапрос('01.01.14','30.04.14',"Н06.01",,,3);    
    БИ_Н06.ВыбратьСубконто(ВидыСубконто.Договоры);

    БИ.ВыбратьСубконто(ВидыСубконто.Контрагенты);
    Пока БИ.ПолучитьСубконто(ВидыСубконто.Контрагенты) = 1 Цикл 
        БИ.ВыбратьСубконто(ВидыСубконто.Договоры);
        Пока БИ.ПолучитьСубконто(ВидыСубконто.Договоры) = 1 Цикл 
            Если БИ_Н06.ПолучитьСубконто(ВидыСубконто.Договоры,,БИ.Субконто(ВидыСубконто.Договоры)) > 0 Тогда
                СуммаНДС = БИ.ДО() - БИ_Н06.КО();  
                Сообщить(СуммаНДС);
            КонецЕсли;
        КонецЦикла;
    КонецЦикла;

нифуя
   егаис
 
6 - 10.04.14 - 14:23
вот это попался называется
Вид субконто другой у Н0601 - "Основание", но с тем же типов "Справочник.Договоры". Спасибо )


Список тем форума
Рекламное место пустует   Рекламное место пустует
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует