Вход | Регистрация

1С:Предприятие ::

Метки: 

Не удаляет элемент в отборе.

Я
   coolspawn
 
10.04.14 - 13:57
При нажатии на кнопку очистки, в динамическом списке не удаляет элемент, а тока очищает значение в отборе... Где я делаю нет так? V8.3

&НаКлиенте
Процедура ТекПартнерОчистка(Элемент, СтандартнаяОбработка)
    
Для Каждого ЭлементОтбора Из Платежи.Отбор.Элементы Цикл
      Если ЭлементОтбора.Представление = "По контрагенту" Тогда
         Платежи.Отбор.Элементы.Удалить(ЭлементОтбора); 
     КонецЕсли;
КонецЦикла;
  
КонецПроцедуры

может это еше одна фишка 8.3?
 
  Рекламное место пустует
   Zamestas
 
1 - 10.04.14 - 14:00
(0) Все там с отборами нормально - ты сам отбор как устанавливал?
   coolspawn
 
2 - 10.04.14 - 14:02
(1) По учебнику.... :)
&НаКлиенте
Процедура Фильтр(Команда)
    Для Каждого ЭлементОтбора Из Платежи.Отбор.Элементы Цикл
      Если ЭлементОтбора.Представление = "По контрагенту" Тогда
         Платежи.Отбор.Элементы.Удалить(ЭлементОтбора);
      КонецЕсли;
  КонецЦикла;
  
  
  Если НЕ Элементы.ТекПартнер.Пустая() Тогда
      ЭлементОтбора = Платежи.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
      ЭлементОтбора.ЛевоеЗначение  = Новый ПолеКомпоновкиДанных("Контрагент");
      ЭлементОтбора.ВидСравнения   = ВидСравненияКомпоновкиДанных.Равно;
      ЭлементОтбора.Использование  = Истина;
      ЭлементОтбора.ПравоеЗначение = Объект.ТекПартнер;
      ЭлементОтбора.Представление  = "По контрагенту";
   КонецЕсли;

  
КонецПроцедуры
   coolspawn
 
3 - 10.04.14 - 14:04
может в галке сохранения пользовательских настроек проблема? Она стоит, но не снимается в свойствах списка..
   Zamestas
 
4 - 10.04.14 - 14:05
(2) Отладчиком проверь что бы условие 
"Если ЭлементОтбора.Представление = "По контрагенту" Тогда"
сработало.
   coolspawn
 
5 - 10.04.14 - 14:07
(4) сразу сделал... все отрабатывавет, и даже отбор без этой строки показывает.. но в настройке списка строка все равно есть
   Zamestas
 
6 - 10.04.14 - 14:07
(5) Я стараюсь не удалять отбор, а через
ЭлементОтбора.Использование = Ложь;
выключть.
   coolspawn
 
7 - 10.04.14 - 14:09
Использование отключал - та же финя, в отладчике = ложь, в настройках - стоит галка
   coolspawn
 
8 - 10.04.14 - 14:11
такое впечатление, что после отработки процедуры происходит затык (системный) она тихо откатывается назад и оставляет без изменений.
   Zamestas
 
9 - 10.04.14 - 14:16
(8) Не знаю - у меня все работает.
   coolspawn
 
10 - 10.04.14 - 14:37
Перезагрузил конфигуратор, перезапустил клиента - взлетело. Не раз замечаю глюки при отладке и забывание очистки кэша...
 
  Рекламное место пустует


Список тем форума
Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует