Вход | Регистрация

1С:Предприятие ::

Метки: 

ОЧ. НУЖНА помощь -> плззззззз

Я
   Lucky
 
24.12.03 - 14:53
Есть небольшая задачка, люди плз подскажите:
Делаю поиск кандидата по названию судна(кто был на этом судне) и  по периоду
С поиском по названию вроде все ясно:
if op.Ship=Ship then
tabzn.newline();                
tabzn.kod=kan.code; 
tabzn.kand=kan.currentitem(); 

а вот как сделать так поиск учитывал период?
в справочнике  где учитывается пребывание моряков на судне реквизиты begin и end не периодические.

if (op.Ship=Ship) and  ->>> ??? 
tabzn.newline();                 
tabzn.kod=kan.code; 
tabzn.kand=kan.currentitem();
 
  Рекламное место пустует
   Черт
 
1 - 24.12.03 - 15:03
Ты в 1С работаешь?
   Lucky
 
2 - 24.12.03 - 15:06
Пытаюсь научиться, попутно выполняя поставленные задачи
   skunk
 
3 - 24.12.03 - 15:10
Справочник моряков он подчинен справочнику корабль или как
   Lucky
 
4 - 24.12.03 - 15:10
Я сделал это так
if op.Ship=Ship then
if (op.begin<=begin)and(op.end>=begin) or
   (op.begin>=begin)and(op.end>=end_)

но может в 1С есть какаято специальная процедура для работы с периодом???
   Lucky
 
5 - 24.12.03 - 15:12
(3) да
   skunk
 
6 - 24.12.03 - 15:14
(0)Ты помоему намудрил с логикой у себя в конфигурации. Или у меня догяняй не работает. Как у тебя моряки зависят от коробля.
   Черт
 
7 - 24.12.03 - 15:16
Тогда попутный вопрос, тебе нужно искать конкретного кандидата или выбрать всех в этом периоде?
А как я понял, то 
if (op.Ship=Ship) and  (Спр.ДатаНачала<=НужнаяДата) И (НужнаяДата <= Спр.КонечнаяДата) Тогда
.........
   Lucky
 
8 - 24.12.03 - 15:17
У каждого моряка есть свой Sea Exp, т.е. Справочник Sea EXP подчинен справочнику Candidates - (ПЕРЕПУТАЛ ;-))
   Lucky
 
9 - 24.12.03 - 15:19
(7) Всех кто попадает в период и кто был на op.Ship=Ship
   skunk
 
10 - 24.12.03 - 15:37
//*******************************************

Процедура Сформировать()
    Моряк.ВыбратьЭлементы();
    Пока Моряк.ПолучитьЗначение() > 0 Цикл
        Если ((Моряк.ДатаСписания < ДатаНачала) Или (Моряк.ДатаПоступления > ДатаКонца)) Тогда
            Продолжить;
        КонецЕсли;
        Если Моряк.Корабель <> Корабель.ТекущийЭлемент() Тогда
            Продолжить;
        КонецЕсли;
        ...........
        Делаешь что тебе надо
        ...........
    КонецЦикла;
КонецПроцедуры
 
  Рекламное место пустует
   Lucky
 
11 - 24.12.03 - 15:56
(10) Самое огромное спасибо ;-) Попробуем


Список тем форума
Рекламное место пустует   Рекламное место пустует
Чтобы обнаруживать ошибки, программист должен иметь ум, которому доставляет удовольствие находить изъяны там, где, казалось, царят красота и совершенство.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует