Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Обмен данными: не переносятся штрихкода

Обмен данными: не переносятся штрихкода
Я
   devochka_1c
 
26.01.13 - 13:24
Добрый день!
Написал свой план обмена по дисконтным картам (УТ 10.3 перенос информации из одной базы в другую, будет постоянный обмен (идентичные конфигурации, не риб))
Пишу правила.
Возникла проблемка со штрихкодами. Не переносится код информационной карты (т.е. штрихкод).

Пробывала в ПКС "Код карты" в обработчике ПередВыгрузкой написать код
[code1c]НаборЗаписейШтриходов = РегистрыСведений.Штрихкоды.СоздатьНаборЗаписей();
НаборЗаписейШтриходов.Отбор.Владелец.Установить(Источник.Ссылка);
НаборЗаписейШтриходов.Прочитать();
Если НаборЗаписейШтриходов.Количество() > 0 Тогда
  Значение = НаборЗаписейШтриходов[0].Штрихкод;
Иначе
  Значение = "";
КонецЕсли;
[/code1c]
Но после выгрузки\загрузки в другую базу там у информационной карты код карты (т.е. штрихкод) не заполнен.
Еще пробовала вот такой вариант: в ПКО "Информационные карты" в обработчике После выгрузки добавить вот такой код[code1c]  Набор = РегистрыСведений.Штрихкоды.СоздатьНаборЗаписей();
    Набор.Отбор.Владелец.Значение      = Источник;
    Набор.Отбор.Владелец.Использование = Истина;
    Набор.Прочитать();
   
    Для Каждого Запись Из Набор Цикл
       
        Структура = Новый Структура;
        Структура.Вставить("Владелец", Запись.Владелец);
        Структура.Вставить("ЕдиницаИзмерения", Запись.ЕдиницаИзмерения);
        Структура.Вставить("Качество", Запись.Качество);
        Структура.Вставить("СерияНоменклатуры", Запись.СерияНоменклатуры);
        Структура.Вставить("ТипШтрихкода", Запись.ТипШтрихкода);
        Структура.Вставить("ХарактеристикаНоменклатуры", Запись.ХарактеристикаНоменклатуры);
        Структура.Вставить("Штрихкод", Запись.Штрихкод);
        Структура.Вставить("Активность", Запись.Активность);
       
        ВыгрузитьПоПравилу(Структура, , , , "Штрихкоды");
    КонецЦикла;[/code1c]
Один раз данный код срабатывает, но при повторных обменах (если, например, изменить наименование Информационной карты) валятся ошибки, но оно и понятно, т.к. в регистре сведений по данной карте уже есть запись, а оно пытается еще одну туда записать....


Подскажите, пожалуйста, как решить данную задачу?
 
 
   devochka_1c
 
1 - 26.01.13 - 14:55
Кто подскажет?
   cw014
 
2 - 26.01.13 - 15:17
У ПКО Штрихкоды поставь галку "не запоминать загруженные объекты"
   devochka_1c
 
3 - 26.01.13 - 15:28
(2)Галка "не запоминать загруженные объекты" стоит. Не помогло.
   devochka_1c
 
4 - 26.01.13 - 16:53
Еще варианты?
   devochka_1c
 
5 - 26.01.13 - 19:42
вопрос актуален
   devochka_1c
 
6 - 28.01.13 - 15:15
У кого-нибудь есть варианты?
   zladenuw
 
7 - 28.01.13 - 15:28
(0) в ПКО после загрузке
Если ОбъектНайден Тогда
    Отказ  = Истина;
КонецЕсли;

Почитай справочную информацию о обработчиках
   zladenuw
 
8 - 28.01.13 - 15:29
(7) или второй вариант в ПКО поставить галку .не замещать существующие данные, а только создавать новые
   devochka_1c
 
9 - 29.01.13 - 11:59
(7), (8) Данное решение не помогает, штрих-кода тогда вообще перестают переноситься...
   devochka_1c
 
10 - 29.01.13 - 12:00
(9) при этом такой штрихкод не занят
 
 Рекламное место пустует
   devochka_1c
 
11 - 30.01.13 - 12:39
Вопрос решен.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует