Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Редактирование в таблице значений.

v7: Редактирование в таблице значений.
Я
   OZFIN
 
25.01.13 - 14:33
Добрый день.
Ситуация такая: на форме есть таблица значений, в неё загружаются данные из дбф-файла, но эти записи нельзя редактировать. Может кто-нибудь знает как сделать так, чтобы эту таблицу можно было редактировать?
 
 
   Индус
 
1 - 25.01.13 - 14:36
добавить командную панель?
   ДенисЧ
 
2 - 25.01.13 - 14:36
кто-нибудь знает :-)
Вешай процедуру на свою таблицу, в ней лови текущаястрока/текущаяколонка, получай данные и давай зверю их редактировать
   Индус
 
3 - 25.01.13 - 14:38
Псомотри обр-ку загрузки из экселя стандартную
   OZFIN
 
4 - 25.01.13 - 14:41
(2) Можешь дать пример такой процедуры?
   Kreont
 
5 - 25.01.13 - 14:43
Для ТЗ на форму ставишь формулу:Коректировка()

в примере только число, но можно тип узнавать какой надо и делать нужный диалог:

Процедура Коректировка()  
ТекСтрока = ТЗ.ТекущаяСтрока(); 
Если ПустоеЗначение(ТЗ) = 1 Тогда
    Возврат;
КонецЕсли;
НовоеЗначение = ТЗ.ПолучитьЗначение(ТЗ.ТекущаяСтрока(),ТЗ.ТекущаяКолонка(,)); 
Если ВвестиЧисло(НовоеЗначение,"Новое значение ",20,5,) = 0 Тогда
Возврат;
КонецЕсли;  
ТЗ.УстановитьЗначение(ТекСтрока,ТЗ.ТекущаяКолонка(,),НовоеЗначение);
КонецЕсли;
СкладТаблица.ТекущаяСтрока(ТекСтрока);
КонецПроцедуры
   Kreont
 
6 - 25.01.13 - 14:43
+не так скопипастил, в конце:
ТЗ.ТекущаяСтрока(ТекСтрока);
КонецПроцедуры
   Ёпрст
 
7 - 25.01.13 - 14:44
   monsterZE
 
8 - 25.01.13 - 14:45
например:

Процедура ИзменитьЗначение()
    
    Значение = ТЗ.ПолучитьЗначение(ТЗ.ТекущаяСтрока(),"Значение");
    
    Если ВвестиСтроку(Значение,"Введите новое значение",30,,)=1 Тогда
        ТЗ.УстановитьЗначение(ТЗ.ТекущаяСтрока(),"Значение",Значение);
    КонецЕсли;    
    
КонецПроцедуры
   OZFIN
 
9 - 25.01.13 - 14:50
(8) Спасибо большое, всё получилось.
   monsterZE
 
10 - 25.01.13 - 14:51
(9) осталось только потом ее обратно в дбф слить =)
 
 Рекламное место пустует
   OZFIN
 
11 - 25.01.13 - 14:53
(10) Сложности были только с редактированием. Ещё раз спасибо Вам.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует