Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

УФ. как сообщить пользователю в отдельном окне

УФ. как сообщить пользователю в отдельном окне
Я
   vde69
 
25.01.13 - 08:42
сделал подписку на событие "проведение" в модуле (серверный) анализирую документ и вывожу дополнительные сообщение, но проблемма что вывод идет в окно сообщений привязаных к документу, и если пользователь нажал кнопку "Провести и закрыть" то мое окно только мелькает и все...

сейчас код такой:

Если СтрокаСообщения <> "" Тогда 
    Сообщение = Новый СообщениеПользователю();
    Сообщение.Текст = "=> " + "
                        |" + СтрокаСообщения;
    Сообщение.Поле = "";
    Сообщение.УстановитьДанные(ДокументОбьект);
    Сообщение.Сообщить();
КонецЕсли;
 
 
   vde69
 
1 - 25.01.13 - 09:37
ап
   Wobland
 
2 - 25.01.13 - 09:39
#Если Не Сервер Тогда
 
Предепреждение?
   Cube
 
3 - 25.01.13 - 09:42
(0)
Если СтрокаСообщения <> "" Тогда 
    Сообщение = Новый СообщениеПользователю();
    Сообщение.Текст = "=> " + "
                        |" + СтрокаСообщения;
    Сообщение.Поле = "";
    Сообщение.УстановитьДанные(ДокументОбьект);
    Сообщение.Сообщить();
    Отказ = Истина;
КонецЕсли;

Если Отказ Тогда
   //Не проводить
 
КонецЕсли;
   vmv
 
4 - 25.01.13 - 09:43
что-то делаем на сервере в транзакциях и тп.
...
мСообщения.Довавить("=> " + Символы.ПС + СтрокаСообщения)
что-то делаем на сервере в транзакциях и тп.
...
мСообщения.Довавить("=> " + Символы.ПС + СтрокаСообщения)
Возврат мСообщения;

....

уже на клиенте выводим сообщения куда хочь, тоть в окно с роликом с конями
   vde69
 
5 - 25.01.13 - 09:44
(2) предупреждение не пойдет, транзакция :)
(3) мне отказывать не нужно! это просто дополнительные сведения для пользователя
   vde69
 
6 - 25.01.13 - 09:45
(4) все должно отрабатывать в подписке на событие, менять обьекты нельзя
   Cube
 
7 - 25.01.13 - 09:48
(6) Ну так укажи другой объект для привязки сообщений
   ptiz
 
8 - 25.01.13 - 09:48
(6) ТабДок.Показать()
   Cube
 
9 - 25.01.13 - 09:50
(8) Ага, на сервере... :)
   kosts
 
10 - 25.01.13 - 09:51
Это на обычных формах, ищи что-то подобное для управляемых...

Если МассивСообщений.Количество() > 0 Тогда
        #Если ТолстыйКлиентОбычноеПриложение Тогда
 
            ОбработкаКомментариев = глЗначениеПеременной("глОбработкаСообщений");
            ОбработкаКомментариев.УдалитьСообщения();
            ОбработкаКомментариев.ДобавитьСообщение(Заголовок, Перечисления.ВидыСообщений.Раздел);
            Для каждого ЭлементМассива Из МассивСообщений Цикл
                ОбработкаКомментариев.ДобавитьСообщение(ЭлементМассива.ТекстСообщения, ЭлементМассива.ВидСообщения, ЭлементМассива.РасшифровкаСообщения);
            КонецЦикла;
            ОбработкаКомментариев.ПоказатьСообщения();
        #Иначе
 
            Для каждого ЭлементМассива Из МассивСообщений Цикл
                ОбщегоНазначения.СообщитьОбОшибке(ЭлементМассива.ТекстСообщения, Отказ, Заголовок);
            КонецЦикла; 
        #КонецЕсли 
 
    КонецЕсли;

 
 Рекламное место пустует
   vmv
 
11 - 25.01.13 - 09:54
(6) У объекта есть Дополнительные свойства, создаеещь там свойство с ключом "СтруктураСообщений" и все - даже возращать ничего не надо - туда сваливай всякие "чмоки, оки и ура"

потом выводи на клиенте прочитав из допсвойств объекта эту структуру

так делают правильные чуваки, гении выбират более дурацкий способ
   vde69
 
12 - 25.01.13 - 09:56
(11) как вывести на клиенте из доп свойст если нельзя код обьекта и формы менять?
   ssh2006
 
13 - 25.01.13 - 09:56
(11) не взлетит
   Cube
 
14 - 25.01.13 - 09:56
(11) На клиенте нет доп. свойств уже... Они затираются...
   Wobland
 
15 - 25.01.13 - 09:57
(5) в качестве бреда. пишешь своё сообщение в какую=нибудь общедоступную строку, в конце проверяешь на заполненность и показываешь
   vmv
 
16 - 25.01.13 - 09:59
(11) тогда возврат Объект.ДополнительныеСвойства.СтруктураСообщений

и все

а сами допсвойства нужны чтобы не думать где и в каких объектах бродит объект, там где нодо прессуем ссобщения.

я так 100 раз делал, а то и флаг на своих формах ставлю - "Выводить сообщени". Они сообираться, но есть выбор читать или не читать, если там нет с признаком ВАжное
   vmv
 
17 - 25.01.13 - 10:00
(15) это именно бред)
   Cube
 
18 - 25.01.13 - 10:00
(15) Не взлетит. "в конце" - это на клиенте, а "нельзя код обьекта и формы менять"...

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует