Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Выгрузка в XML

Выгрузка в XML
Я
   ВежливаяТварь
 
24.01.13 - 14:07
Добрый день. Столкнулся с весьма проблематичной задачей. Никогда раньше не работал с выгрузкой данных в xml, а теперь мне надо определенный документ выгрузить в xml. Не могли бы Вы скинуть пример подобной выгрузки. В нете ничего подобного не нашел, сейчас ковыряю обработку выгрузки, загрузки xml, но что- то подсказывает мне, что это надолго.
 
 
   salvator
 
1 - 24.01.13 - 14:08
(0) Думаю, правила как минимум нужны еще.
   rasswet
 
2 - 24.01.13 - 14:09
плохо искал. еще гугли.
   Йохохо
 
3 - 24.01.13 - 14:12
обработка в типовых ВыгрузкаДанныхCommerceML
   ВежливаяТварь
 
4 - 24.01.13 - 14:14
Наверное глупый вопрос: Ещё такой момент я так понял что бы записать документ мы записываем каждый атрибут этого документа отдельной строкой?
   Йохохо
 
5 - 24.01.13 - 14:24
(4) спроси у того, кто будет грузить
   Йохохо
 
6 - 24.01.13 - 14:24
*загружать
   Wobland
 
7 - 24.01.13 - 14:25
Процедура ВыгрузитьОбъектНажатие(Элемент)
    
    Если НЕ ЗначениеЗаполнено(ОбъектВыгрузки) ИЛИ ОбъектВыгрузки.Количество() = 0 ИЛИ ПустаяСтрока(ИмяФайлаВыгрузки) Тогда
        Возврат;
    КонецЕсли;
    ЗаписьXML = Новый ЗаписьXML;
    ЗаписьXML.ОткрытьФайл(ИмяФайлаВыгрузки);
    ЗаписьXML.ЗаписатьНачалоЭлемента("body");
    Для мСчетчик = 0 По ОбъектВыгрузки.Количество() - 1 Цикл
        мОбъект = ОбъектВыгрузки[мСчетчик].Значение;
        ЗаписатьXML(ЗаписьXML, мОбъект.ПолучитьОбъект());
    КонецЦикла;
    ЗаписьXML.ЗаписатьКонецЭлемента();
    ЗаписьXML.Закрыть();
    
КонецПроцедуры
   Рэйв
 
8 - 24.01.13 - 14:26
Как из одной базы перенести документ в другую базу?
// Выгрузить в файл xml. 
 
ЗаписьXML=Новый ЗаписьXML(); 
ЗаписьXML.ОткрытьФайл("c:\doc.xml"); 
ЗаписьXML.ЗаписатьНачалоЭлемента("Root"); 

 // Получить объект по ссылке. 
 
ВыгружаемыйОбъект=Документ.ПолучитьОбъект(); 

 // С помощью средств сериализации записать объект в файл. 
 
ЗаписатьXML(ЗаписьXML,ВыгружаемыйОбъект); 

ЗаписьXML.ЗаписатьКонецЭлемента(); 
ЗаписьXML.Закрыть(); 

ЧтениеXML=Новый ЧтениеXML(); 
ЧтениеXML.ОткрытьФайл("c:\doc.xml"); 

 // Текущим становится элемент Root. 
 
ЧтениеXML.Прочитать(); 

 // Текущим становится элемент с документом. 
 
ЧтениеXML.Прочитать(); 

 // Проверить сможет ли с данным значением "справиться" 
 
// система сериализации в данной базе. 
Если ВозможностьЧтенияXML(ЧтениеXML) Тогда 

   // Получить ДокументОбъект.РеализацияТоваровУслуг 
 
    ЗагружаемыйОбъект=ПрочитатьXML(ЧтениеXML); 
    
    ЗагружаемыйОбъект.Записать(); 
КонецЕсли; 

ЧтениеXML.Закрыть(); 

(С)Габец
   ВежливаяТварь
 
9 - 24.01.13 - 14:27
Огромное спасибо. Сейчас покапаюсь.
   ВежливаяТварь
 
10 - 24.01.13 - 15:10
Ещё такой вопрос. Когда я выгружаю документ, я так понял он выгружает только GUIDы объектов которые к нему привязаны(Например контрагента). Для того, что бы выгрузить контрагента его нужно отдельным элементом выгружать?
 
 Рекламное место пустует

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует