Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

УТ 10.3 Установка цен номенклатуры.

УТ 10.3 Установка цен номенклатуры.
Я
   kasazanov
 
24.01.13 - 12:38
Конфа УТ10.3

Пишу обработку которая создаст документ УстановкаЦенНоменклатуры на основании документа ОприходованиеТоваров.

Проблема такая: Когда я начинаю программно добавлять ТЧ в документ то при его открытии выходит ошибка "Поле объекта не обнаружено (цена)" это из за какой то необычной ТЧ документа УстановкиЦенНоменклатуры, кто знает УТ10.3 подскажите в чем фишка этого документа и как туда добавить программно ТЧ.

Документ = Документы.УстановкаЦенНоменклатуры.СоздатьДокумент();
    Документ.Дата = СсылкаНаОбъект.Дата;
    ДобавитьТипЦен = Документ.ТипыЦен.Добавить();
    Для каждого стр ИЗ Документ.ТипыЦен Цикл
        стр.ТипЦен = ТипЦен;
    КонецЦикла;
    
    ДобавитьТовар = Документ.Товары.Добавить();
    
         Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    ОприходованиеТоваровТовары.Ссылка,
    |    ОприходованиеТоваровТовары.ЕдиницаИзмерения,
    |    ОприходованиеТоваровТовары.Номенклатура,
    |    ОприходованиеТоваровТовары.ХарактеристикаНоменклатуры
    |ИЗ
    |    Документ.ОприходованиеТоваров.Товары КАК ОприходованиеТоваровТовары
    |ГДЕ
    |    ОприходованиеТоваровТовары.Ссылка = &Ссылка";
    Запрос.УстановитьПараметр("Ссылка", СсылкаНаОбъект);
    Выборка = Запрос.Выполнить().Выбрать();
    

    
    Пока Выборка.Следующий() Цикл
    ДобавитьЭлемент = Документ.Товары.Добавить();
    ДобавитьЭлемент.Номенклатура = Выборка.Номенклатура;
    ДобавитьЭлемент.ЕдиницаИзмерения = Выборка.ЕдиницаИзмерения;
    ДобавитьЭлемент.Валюта = ТипЦен.ВалютаЦены;
   //ДобавитьЭлемент.Цена = Выборка.Цена;
 
    КонецЦикла;
 
 
   cw014
 
1 - 24.01.13 - 12:40
А в пофигураторе не посмотреть никак, как поле называется?
   DrShad
 
2 - 24.01.13 - 12:40
фишка этого документа в том, что у него две ТЧ, а на морде сводная талица
   cw014
 
3 - 24.01.13 - 12:41
Простите, а где у вас в выборке "Цена"?
   Утконос
 
4 - 24.01.13 - 12:41
а где у тебя в запросе цена ?  Выборка.Цена;
   kasazanov
 
5 - 24.01.13 - 12:41
(1) смотрел там в ТЧ всего 2 реквизита. Поэтому и туплю че да как.

(2) а как правильно туда что то добавить?
   Утконос
 
6 - 24.01.13 - 12:41
ДобавитьТовар = Документ.Товары.Добавить(); и это на кой ?
   DrShad
 
7 - 24.01.13 - 12:42
(5) нужно заполнить обе ТЧ
   cw014
 
8 - 24.01.13 - 12:43
(5) Не игнорируй сообщения (3) и (4). В них твоя ошибка
   kasazanov
 
9 - 24.01.13 - 12:47
(3) (4) Просто убрал из запроса цену и ниже присвоил ей число руками чтобы посмотреть что будет, все равно выдается ошибка
изначально вариант был такой, который тоже не работает.

Документ = Документы.УстановкаЦенНоменклатуры.СоздатьДокумент();
    Документ.Дата = СсылкаНаОбъект.Дата;
    ДобавитьТипЦен = Документ.ТипыЦен.Добавить();
    Для каждого стр ИЗ Документ.ТипыЦен Цикл
        стр.ТипЦен = ТипЦен;
    КонецЦикла;
    
   //ДобавитьТовар = Документ.Товары.Добавить();
 
    
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    ОприходованиеТоваровТовары.Ссылка,
    |    ОприходованиеТоваровТовары.ЕдиницаИзмерения,
    |    ОприходованиеТоваровТовары.Номенклатура,
    |    ОприходованиеТоваровТовары.ХарактеристикаНоменклатуры,
    |    ОприходованиеТоваровТовары.Цена
    |ИЗ
    |    Документ.ОприходованиеТоваров.Товары КАК ОприходованиеТоваровТовары
    |ГДЕ
    |    ОприходованиеТоваровТовары.Ссылка = &Ссылка";
    Запрос.УстановитьПараметр("Ссылка", СсылкаНаОбъект);
    Выборка = Запрос.Выполнить().Выбрать();
    

    
    Пока Выборка.Следующий() Цикл
    ДобавитьЭлемент = Документ.Товары.Добавить();
    ДобавитьЭлемент.Номенклатура = Выборка.Номенклатура;
    ДобавитьЭлемент.ЕдиницаИзмерения = Выборка.ЕдиницаИзмерения;
    ДобавитьЭлемент.Валюта = ТипЦен.ВалютаЦены;
    ДобавитьЭлемент.Цена = Выборка.Цена;
    КонецЦикла;
    
    
    
    Документ.Записать();
   Godofsin
 
10 - 24.01.13 - 12:48
(9) в документе есть процедура заполнить, посмотри как там реализовано
 
 Рекламное место пустует
   Godofsin
 
11 - 24.01.13 - 12:49
+ (10) заполнить по поступлению
   hhhh
 
12 - 24.01.13 - 12:52
(9) а тип цен-то не заполнили, ну вы приколист!
   kasazanov
 
13 - 24.01.13 - 12:53
(12) ну вроде вначале я его заполнял. или это не то?
   hhhh
 
14 - 24.01.13 - 12:55
(13) ну эти две табличные части между собой связываются как? Вроде через поле типа цен.
   kasazanov
 
15 - 24.01.13 - 12:58
(14) Ты реально крут, все заработало ))
   kasazanov
 
16 - 24.01.13 - 12:58
Всем спасибо.
   DrShad
 
17 - 24.01.13 - 13:00
(15) а в (2) тебе что не понятно?
   kasazanov
 
18 - 24.01.13 - 13:05
(17) Да сразу не вкурил просто.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует