Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Работа с файлами в тонком/веб -клиенте

Работа с файлами в тонком/веб -клиенте
Я
   ТоненькийКлиент
 
23.01.13 - 20:22
Пытаюсь нагнуть УПП (1.3.34, пл. 8.2.17.153)для работы в тонком/веб клиенте.
Впервые занялся прикреплением файлов к документу "Событие" (хотя бы к нему). Сделал всё по правилам :-)
ввёл 2 реквизита (Вложение=ХЗ, ИмяВложения=Строка)
в модуле УФ-формы вписал
       
&НаКлиенте
Процедура ЗагрузитьСДиска(Команда)
    
    АдресВХранилище = "";
    ВыбранноеИмяФайла = "";
    
    Если ПоместитьФайл(АдресВХранилище, , ВыбранноеИмяФайла, , УникальныйИдентификатор) Тогда
        
        Файл = Новый Файл(ВыбранноеИмяФайла);
        
        ИмяВложения = Файл.Имя;
        СсылкаНаФайлВоВременномХранилище = АдресВХранилище;
        
        Модифицированность = Истина;
        
    КонецЕсли;
                       
КонецПроцедуры

&НаКлиенте
Процедура СохранитьНаДиск(Команда)
    
    Если Объект.ИмяВложения = "" Тогда
        Предупреждение("Нет вложения");
        
    Иначе    
        СсылкаНаФайлВИБ = ПолучитьНавигационнуюСсылку(Объект.Ссылка, "Вложение");
        ПолучитьФайл(СсылкаНаФайлВИБ, Объект.ИмяВложения); 
    КонецЕсли;    
    
КонецПроцедуры

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
    
   // Получить файл из хранилища и поместить его в объект
 
    Если ЭтоАдресВременногоХранилища(СсылкаНаФайлВоВременномХранилище) Тогда
        ДвоичныеДанные = ПолучитьИзВременногоХранилища(СсылкаНаФайлВоВременномХранилище);
        ТекущийОбъект.Вложение = Новый ХранилищеЗначения(ДвоичныеДанные, Новый СжатиеДанных(9));
        
        ТекущийОбъект.ИмяВложения = ИмяВложения;
    КонецЕсли;
    
КонецПроцедуры    


&НаСервере
Процедура ПриЗаписиНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
    
   // Удалить файл из временного хранилища
 
    Если ЭтоАдресВременногоХранилища(СсылкаНаФайлВоВременномХранилище) Тогда
        УдалитьИзВременногоХранилища(СсылкаНаФайлВоВременномХранилище);
    КонецЕсли;    
        
КонецПроцедуры

В итоге в отладчике он вообще не выходит на процедуру ПередЗаписьюНаСервере() и в итоге ни хрена не работает.
Я недавно с УФ , скажите, куда копать?
Спасибо!
 
 
   ДенисЧ
 
1 - 23.01.13 - 20:23
сервер не в режиме отладки...
   ТоненькийКлиент
 
2 - 23.01.13 - 20:23
отлаживал в тонком и вебе
   ТоненькийКлиент
 
3 - 23.01.13 - 20:24
(1) можно чуть подробнее!
   ТоненькийКлиент
 
4 - 23.01.13 - 20:25
это типа как здесь:
http://1c-v8-create.livejournal.com/4019.html
?
   Живой Ископаемый
5 - 23.01.13 - 20:27
2(4) не пробуй пока не ответит
   ТоненькийКлиент
 
6 - 23.01.13 - 20:28
(5) не буду)))
все равно сейчас в файловом режиме парюсь
   ТоненькийКлиент
 
7 - 23.01.13 - 20:36
ап, что ли...
   Живой Ископаемый
8 - 23.01.13 - 20:42
что ап?
   ТоненькийКлиент
 
9 - 23.01.13 - 20:45
(8)жду, может, ответит кто...
   ТоненькийКлиент
 
10 - 23.01.13 - 20:59
помогите!))
 
 Рекламное место пустует
   Живой Ископаемый
11 - 23.01.13 - 21:05
тебе уже помогли, что еще нужно? денег выслать?
   ТоненькийКлиент
 
12 - 23.01.13 - 21:29
(11) если помогли - это (1)+(4), то оно не срабатывает.
спасибо и на этом, конечно.
   Живой Ископаемый
13 - 23.01.13 - 22:03
То есть ты запустил сервер в режиме отладки,  пригрозил его,  запустил отдадут и и поставил точку останова внутри ссерверной процедуры,  и все равно отладка на ней в нее не заходит?
   nunzio
 
14 - 23.01.13 - 22:16
(13) "все равно сейчас в файловом режиме парюсь".
проверь в отладке (подключения) есть ли у тебя сервер.
   ТоненькийКлиент
 
15 - 24.01.13 - 14:07
(14) а как это сделать?
   ТоненькийКлиент
 
16 - 24.01.13 - 14:10
(15) в отладка-подключение сервер есть
   ИсчадиеADO
 
17 - 24.01.13 - 14:50
событие в модуле с формочкой увязано?
   ИсчадиеADO
 
18 - 24.01.13 - 14:52
(0) ты процедуру ПередЗаписьюНаСервере не методом ли копипаста вводил?
   ТоненькийКлиент
 
19 - 24.01.13 - 15:44
(18) почти что копипастом...
как увязать? т.е. специально нужно к "записать" привязать эту мою ПередЗаписьюНаСервере?
   ТоненькийКлиент
 
20 - 24.01.13 - 15:52
да что ж за херня-то...
   ТоненькийКлиент
 
21 - 24.01.13 - 16:00
как всегда , все поумничали и свалили...
   ТоненькийКлиент
 
22 - 24.01.13 - 17:29
ап
   ТоненькийКлиент
 
23 - 24.01.13 - 17:46
что нужно сделать с управляемой формой, чтобы при команде "Записать" шло исполнение процедуры ПередЗаписьюНаСервере???
   rphosts
 
24 - 24.01.13 - 17:53
у тебя форма есть?
   ТоненькийКлиент
 
25 - 24.01.13 - 17:54
есть!
   rphosts
 
26 - 24.01.13 - 17:55
какого типа форма-то(списка, документа, выбора, ....)?
   ТоненькийКлиент
 
27 - 24.01.13 - 17:55
специально созданная для документа "Событие" управляемая форма
   ТоненькийКлиент
 
28 - 24.01.13 - 17:55
(26) элемента, т.е. документа
   rphosts
 
29 - 24.01.13 - 17:56
а она назначена как основная форма документа?
   ТоненькийКлиент
 
30 - 24.01.13 - 17:56
(29) назначена!
   ТоненькийКлиент
 
31 - 24.01.13 - 17:57
   ТоненькийКлиент
 
32 - 24.01.13 - 17:58
выгр и загр - это как раз кнопки для команд ЗагрузитьСДиска(Команда)
и Сохранить...
   Goggy
 
33 - 24.01.13 - 18:00
(30) А процедура привязана к обработчику формы?
 
 
   rphosts
 
34 - 24.01.13 - 18:00
(31) имя не кошерное! Вот то у тебя в синонме всем фиолетово, а практику использования таких имён прекращай!
   ТоненькийКлиент
 
35 - 24.01.13 - 18:01
(34) из-за этого не идет обращение к НаСервере?
   rphosts
 
36 - 24.01.13 - 18:03
(35) это общая рекомендация, а ещё рекомендую пользоваться поиском, например всё что ту  советовали было дня 3 назад: v8: Отбор в управляемой форме
   rphosts
 
37 - 24.01.13 - 18:08
да, выгр-загр - не стоковые команды а ваши самопальные, в коде есть что-то типа:
ЭтаФорма.Записать();
   ТоненькийКлиент
 
38 - 24.01.13 - 18:18
(36) огромное спасибо!
   rphosts
 
39 - 24.01.13 - 18:27
(38) помогло?
   ТоненькийКлиент
 
40 - 24.01.13 - 18:31
очень!
   ТоненькийКлиент
 
41 - 24.01.13 - 18:32
всё-таки дело было в "рассинхронизации"


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует