Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Удаление документов и движений закрытых для записи и редактирования

Удаление документов и движений закрытых для записи и редактирования
Я
   vladimirpetrov11
 
23.01.13 - 14:30
Добрый день! Подскажите каким методом можно удалить строки из документов и регистров, если они закрыты для редактирования. (находятся в прошлом расчетном периоде).
 
 
   vladimirpetrov11
 
1 - 23.01.13 - 14:31
Т.е. на данный момент нельзя с ними провести никакие операции
   PR
 
2 - 23.01.13 - 14:31
(0) Программным
   vladimirpetrov11
 
3 - 23.01.13 - 14:33
(2) Если программа ругается при попытки программным путем записать, провести и пр., то и удалить она наврядли даст....
   pessok
 
4 - 23.01.13 - 14:35
ОбменДанными = Истина;

но я этого тебе не советовал
   pessok
 
5 - 23.01.13 - 14:36
если уж так хочется получить по чану от ГБ, то в настройках ограничения можно снять галку "Ограничивать для пользователей с полными правами", или как-то так, и уже после этого портить отчетность прошлых периодов и последовательности
   Stim
 
6 - 23.01.13 - 14:37
нельзя просто так взять и удалить
   vladimirpetrov11
 
7 - 23.01.13 - 15:03
Да там документ не распределенной оплаты. В том то и дело, что  он отчетность портит, а на расчет в лицевых на самом деле не влияет. 3 регистра к нему привязаны (к доку) из которых и берется инфа для некоторых отчетов((((
   vladimirpetrov11
 
8 - 23.01.13 - 15:03
То есть додумались провести документ с лицевыми и не распределенной оплатой, вот теперь ломаю голову-че делать
   Maxus43
 
9 - 23.01.13 - 15:04
(8) пусть бух ломает голову. ЕСли решит - удалить строки из дока и провести его опять - её проблемы. Технически никаких препятсвий для этого нет
   vladimirpetrov11
 
10 - 23.01.13 - 15:10
А где обычно в модуле ставят болокировку в зависимости от периода. Как найти быб. Заремарить, пометить на удаление-автоматом с регистров сведения удалятся и вернуть блок?
 
 Рекламное место пустует
   vladimirpetrov11
 
11 - 23.01.13 - 15:12
Это где-то при запуске системы должно быть...Найти никак не могу(
   vladimirpetrov11
 
12 - 23.01.13 - 15:15
(9) У нас бухгалтер сидит на заводе, программа стоит в другом отделе в городе. Она прогу даже в глаза не видела. Ей выгружают отчеты и передают и всё
   Maxus43
 
13 - 23.01.13 - 15:20
(10) что за ересь? сервис - установка даты запрета изменения данных - снимай дату запрета, изменяй, ставь обратно
   Maxus43
 
14 - 23.01.13 - 15:21
или (5), там же
   vladimirpetrov11
 
15 - 23.01.13 - 15:46
(13) Макс объясни пожалуйста на пальцах. Я понимаю, что для вас это проще простого))

Открыть 1с управляемое приложение, нажать туда-то,туда-то.. Я не найду никак. Пока такого не делал. Может даже в конфигураторе заблокирован доступ к этим настройкам, как посмотреть?
   Maxus43
 
16 - 23.01.13 - 15:47
конфа какая?
   lefthander
 
17 - 23.01.13 - 15:48
(12) а в чем тогда необходимость менять данные закрытого периода?
   vladimirpetrov11
 
18 - 23.01.13 - 15:48
Расчет квартплаты и бухгалтерия ЖКХ
   Ranger_83
 
19 - 23.01.13 - 15:49
Сделать сторно в открытом периоде
   vladimirpetrov11
 
20 - 23.01.13 - 15:50
(19) Раньше можно было, с новым обновлением нельзя. Даже период открывали-заблокированы доки
   vladimirpetrov11
 
21 - 23.01.13 - 15:50
http://s017.radikal.ru/i425/1301/49/d83f8f35006e.jpg

Вот окно которое открывается, чтобы вы поняли про что я
   vladimirpetrov11
 
22 - 23.01.13 - 15:51
Справа сверху в окошке документы оплаты. Один из них мне нужно удалить вместе с регистрами
   vladimirpetrov11
 
23 - 23.01.13 - 15:52
(17) Проблема в том, что отчеты не верные из-за косячного дока
   Maxus43
 
24 - 23.01.13 - 15:52
(21) в сервис и администрирование нет ничего про дату запреда? я хз, у меня нет такой конфы, незнаю как они устанавливают дату или блокируют доки
   vladimirpetrov11
 
25 - 23.01.13 - 15:53
(24) Техподдержку опять добивать значит буду завтра(( эх
   lefthander
 
26 - 23.01.13 - 15:55
Качнем - посмотрим
   lefthander
 
27 - 23.01.13 - 15:55
редакция 3.0?
   vladimirpetrov11
 
28 - 23.01.13 - 15:56
(27) Неет. Вторая
   vladimirpetrov11
 
29 - 23.01.13 - 15:57
   lefthander
 
30 - 23.01.13 - 15:59
могу только 3 версию посмотреть... 2 не получится.
   pessok
 
31 - 23.01.13 - 16:00
(25) на самом деле в модуле формы документа, ПриОткрытии() там идет проверка на доступность редактирования. (это шоб кнопички были активными) + проверяется подписка на событие в ПередЗаписью() модуля объекта. Но это на ОФ, как там сделали разрабы твоей конфы - хз. Но про подписку и ПередЗаписью() - наверняка в точку
   vladimirpetrov11
 
32 - 23.01.13 - 16:00
(30) Эх, жаль. Всё равно спасибо!
   vladimirpetrov11
 
33 - 23.01.13 - 16:01
(31) Так вот именно, в модулях в приоткрытии нефига нетуу. Не всё так просто(
 
 
   pessok
 
34 - 23.01.13 - 16:01
(33) ПередЗаписью() модуля _объекта_ проверяется подписка на событие
   vladimirpetrov11
 
35 - 23.01.13 - 16:04
(34)  

Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
    Если ПараметрыЗаписи.РежимЗаписи=РежимЗаписиДокумента.Проведение Тогда
        Если Не Объект.ОтложенноеРаспределение Тогда
            Отказ=(Объект.Состав.Итог("Сумма")<>Объект.РаспределеннаяОплата.Итог("Сумма") И Объект.ТипОперации=ТипОперацииОплата);
            Если Отказ Тогда
                Сообщить("Итоговая сумма на вкладке состав (" +Объект.Состав.Итог("Сумма")+ ") не совпадает с суммой распределённой оплаты ("+Объект.РаспределеннаяОплата.Итог("Сумма")+"). Необходимо распределить оплату по видам расчетов, либо скорректировать суммы так, чтобы итоги совпадали", СтатусСообщения.ОченьВажное);
            КонецЕсли;
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры
   vladimirpetrov11
 
36 - 23.01.13 - 16:05
А это при открытии:


&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
   // МеханизмВнешнегоОборудования
 
    Если ИспользоватьПодключаемоеОборудование
        И МенеджерОборудованияКлиент.ОбновитьРабочееМестоКлиента() Тогда
        
        ОписаниеОшибки = "";
        
        ПоддерживаемыеТипыВО = Новый Массив();
        ПоддерживаемыеТипыВО.Добавить("СканерШтрихкода");
        
        Если Не МенеджерОборудованияКлиент.ПодключитьОборудованиеПоТипу(УникальныйИдентификатор, ПоддерживаемыеТипыВО, ОписаниеОшибки) Тогда
            ТекстСообщения = НСтр("ru = 'При подключении оборудования произошла ошибка:
                |""%ОписаниеОшибки%"".'");
            ТекстСообщения = СтрЗаменить(ТекстСообщения, "%ОписаниеОшибки%", ОписаниеОшибки);
            ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения);
        КонецЕсли;
        
    КонецЕсли;
   // Конец МеханизмВнешнегоОборудования
 
    
    ПроверитьОтложенноеРаспределение();
    
КонецПроцедуры
   vladimirpetrov11
 
37 - 23.01.13 - 16:05
Проверка на подключение штрих считывателей и метода распределения оплаты и всё
   pessok
 
38 - 23.01.13 - 16:09
(37) значит просто смотри подписки
   hhhh
 
39 - 23.01.13 - 16:09
(21) ну вот у вас в левом верхнем углу кружок 1С, а рядом с ним второй кружок с треугольником, нажмите его и там самое нижнее должно быть "Все функции".
   pessok
 
40 - 23.01.13 - 16:11
+(38) что-то типа ПередЗаписьюДокументаДатаЗапретаРедактирования
   Serg_1960
 
41 - 23.01.13 - 16:11
Хмм... конфигурацию автора - не знаю. Но если там есть регистр сведений ГраницыЗапретаИзмененияДанных - я знаю что надо делать :)

PS: в типовых через Операции можно просмотреть состав справочников, документов и регистров.
   pessok
 
42 - 23.01.13 - 16:12
но вообще да, (39) прав, надо типовым механизмом, тем, которым ставили дату запрету, её же и снять
   vladimirpetrov11
 
43 - 24.01.13 - 08:31
Ну вот окно, выбираю документ-доступен только метод "Открыть":

http://s019.radikal.ru/i602/1301/ba/2ed309bc6e75.jpg
   vladimirpetrov11
 
44 - 24.01.13 - 08:32
(41) Ищу
   vladimirpetrov11
 
45 - 24.01.13 - 08:32
(41) Есть такой))
   vladimirpetrov11
 
46 - 24.01.13 - 08:34
(41) Как правильно сделать, чтобы не нарушить целостность и безболезненно удалить док и его записи в регистрах?


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует