Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Подключение из базы 1с 8 к базе 1с 8

Подключение из базы 1с 8 к базе 1с 8
Я
   palm1c
 
23.01.13 - 14:15
Добрый день.
Есть две базы 1с 8.
Есть обработка, которая подключается к базе 1с 8.
В обработке есть поле "Путь к базе".
Проблема в том, что раньше база была файловая, а теперь SQL.
Обработку не представляется возможным изменить, так как она защищена паролем.

Вопрос: Можно ли, и какую нужно подсунуть строку, для того, чтобы обработка подключалась к базе на сервере. Я понимаю, что методик подключения может быть несколько.

Спасибо.
 
 
   DrShad
 
1 - 23.01.13 - 14:16
никак и ничего ты туда не подсунешь
   Vladal
 
3 - 23.01.13 - 14:19
А обработка подразумевает подключение только к файловой базе?
Свяжитесь с автором.
   shuhard
 
4 - 23.01.13 - 14:20
»
   DrShad
 
5 - 23.01.13 - 14:21
(3) там не подключение, а собирается строка подключения по-другому
   Vladal
 
7 - 23.01.13 - 14:23
(5) Я в курсе. Сам собираю такие строки по крупицам:

Если флСкуль Тогда СтрокаПодключения = "Srvr = """ + ...
Иначе СтрокаПодключения = "File = """ + ...

а еще есть Виндоуз-авторизация

Потому в (3) и спросил - предусмотрел ли автор сие?
   Vladal
 
8 - 23.01.13 - 14:24
Может, кому пригодится, в копилочку:

Если ФлSqlФормат Тогда
    
    Если флWindowsАвторизация Тогда
        СтрокаПодключения = "Srvr = """ + ИмяСервера + """;Ref = """ + ИмяБазы + """;";
    Иначе
        СтрокаПодключения = "Srvr = """ + СокрЛП(ИмяСервера) + """;Ref = """ + СокрЛП(ИмяБазы) + """;Usr = """ + СокрЛП(Пользователь) + """;PWD = """ + СокрЛП(Пароль) + """;";
    КонецЕсли;
    
Иначе
    
    Если флWindowsАвторизация Тогда
        СтрокаПодключения = "File = """ + ПутьКФайловойБазеДанных + """";
    Иначе
        СтрокаПодключения = "File = """ + ПутьКФайловойБазеДанных + """;Usr = """ + СокрЛП(Пользователь) + """;PWD = """ + СокрЛП(Пароль) + """;";
    КонецЕсли;
    
КонецЕсли;

V81 = Новый COMОбъект("V81.ComConnector");

Попытка
    ВнешняяБД = V81.Connect(СтрокаПодключения);
    Возврат ВнешняяБД;
Исключение
    Возврат Ложь;
КонецПопытки;
   DrShad
 
10 - 23.01.13 - 14:26
(9) ну так писал не для того чтоб воровали
 
 Рекламное место пустует
   Vladal
 
Модератор
11 - 23.01.13 - 14:26
shuhard, предупреждение. Флейм в разделах 1С и IT не допускается.
   pessok
 
12 - 23.01.13 - 14:26
(10) дык кто спорит?
   Vladal
 
Модератор
13 - 23.01.13 - 14:27
(10) Недоказанный факт
   DrShad
 
14 - 23.01.13 - 14:28
(11) а где флейм-то? термины выучи
   DrShad
 
15 - 23.01.13 - 14:29
(14) Флейм - (от англ. Flame - разразиться (чем-л.), "взорваться"). - Бурная реакция на подначивание. В другом значении: болтовня вне темы ветки, зачастую не очень осмысленная.

Бурная реакция на подначивание.
   Vladal
 
Модератор
17 - 23.01.13 - 14:30
(15) Ты сам ответил на вопрос. Болтовня не по теме.
+ 8-й пункт правил.
   palm1c
 
18 - 23.01.13 - 14:32
Спасибо всем, тема закрыта. Буду писать свою обработку, которая делает то же самое.
Как я понял из (8) Нельзя подсунуть в строку строку подключения к серверной базе.
   Vladal
 
19 - 23.01.13 - 14:33
(18) В закрытом модуле - нет, не поменяешь.
А так в отладчике можно менять значения переменных.
   pessok
 
20 - 23.01.13 - 14:33
(18) вообще крайней странно, что строка подключения пробита жестко в обработку. может там хотя бы из какого-то файла она вытаскивается? ну это просто нелепо...
   palm1c
 
21 - 23.01.13 - 14:35
(20) Да нет, всё время вбивали путь к файловой базе.
   palm1c
 
22 - 23.01.13 - 14:36
(19) Разве я могу посмотреть закрытый модуль в отладчике?
   pessok
 
23 - 23.01.13 - 14:39
(21) ну так может быть он все таки учел это. надо бы посмотреть на значения переменных
(22) модуль - нет, значения переменных - да


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует