Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Вопрос по КД

Вопрос по КД
Я
   Голубушка
 
23.01.13 - 12:16
Формирую и выгружаю из 77ТИС документ в УТ 11 загружаю документ "Заказ клиента" . При выгрузке указываю  РежимЗаписи="Проведение" , т.е. при загрузке выполняется Объект.Записать(РежимЗаписи, РежимПроведения) - Объект.Записать(РежимЗаписи.Проведение, РежимПроведения.Неоперативный), запись и проведение выполняются в одной транзакции. В модуле документа "Заказ клиента" отрабатывают две процедуры ПередЗаписью и ОбработкаПроведения, так вот в процедуре ПередЗаписью Организация документа заполнена , а в ОбработкаПроведения уже нет ?? что происходит ?
 
 
   DrShad
 
1 - 23.01.13 - 12:23
у тебя объект не записался
   Defender aka LINN
 
2 - 23.01.13 - 12:23
Организация очищается. Всегда ваш, К.О.
   Голубушка
 
3 - 23.01.13 - 12:24
(1) по всей видимости да , но причину понять не могу
   Голубушка
 
4 - 23.01.13 - 12:25
(2) нет
   Defender aka LINN
 
5 - 23.01.13 - 12:36
(4) Тогда мы ВНИМАТЕЛЬНО слушаем вашу версию
   Голубушка
 
6 - 23.01.13 - 12:38
прохожу всю процедуру ПередЗаписью , Отказ Ложь до конца, т.е. объект должен записаться , и организация заполнена .. следующий шаг захожу в ОбработкаПроведения и тут организация уже пустая
   Голубушка
 
7 - 23.01.13 - 12:39
(5) в том то и дело , что нет версии , чтоб очистить организацию нужно что то сделать , а для этого ничего не делается
   Alex S D
 
8 - 23.01.13 - 12:39
подписка?
   Голубушка
 
9 - 23.01.13 - 12:43
в V8Exchan82.epf .. отрабатывает код

                Попытка
                    
                    НужноЗаписатьОбъект = НужноЗаписатьОбъект ИЛИ (РежимЗаписи <> РежимЗаписиДокумента.Запись);
                    
                    РежимОбменДанными = РежимЗаписи = РежимЗаписиДокумента.Запись;
                    
                    ПровестиГенерациюКодаНомераПриНеобходимости(ГенерироватьНовыйНомерИлиКодЕслиНеУказан, Объект, 
                        ИмяТипаОбъекта, НужноЗаписатьОбъект, РежимОбменДанными);
                    
                    Если НужноЗаписатьОбъект Тогда
                     // РежимОбменДанными=?(ЗагружатьДанныеВРежимеОбмена,ЗагружатьДанныеВРежимеОбмена,РежимОбменДанными);                        
 
                        УстановитьОбменДаннымиЗагрузка(Объект, РежимОбменДанными);
                        Если Объект.Проведен Тогда
                            Объект.ПометкаУдаления = Ложь;
                        КонецЕсли;
                        
                        Объект.Записать(РежимЗаписи, РежимПроведения);
                        
                    КонецЕсли;                    
                        
                Исключение
                        
                   // не смогли выполнить необходимые действия для документа
 
                    ЗаписатьДокументВБезопасномРежиме(Объект, ТипОбъекта);

...

так он у меня в исключение уходит , понятно , что не записывает док , а потом записывает в безопасном режиме без проведения
   DrShad
 
10 - 23.01.13 - 12:46
кроме ПередЗаписью еще есть ПриЗаписи
 
 Рекламное место пустует
   Голубушка
 
11 - 23.01.13 - 12:47
РежимОбменДанными = РежимЗаписи = РежимЗаписиДокумента.Запись;

у меня ложь и соответсвенно вся ПередЗаписью отрабатывается , если кто не знает в процедуре на входе

    Если ОбменДанными.Загрузка Тогда
        Возврат;
    КонецЕсли;

но так как РежимЗаписи="Проведение" , то входит в процедуру ОбменДанными.Загрузка=Ложь
   DrShad
 
12 - 23.01.13 - 12:47
(9) что и требовалось доказать
   DrShad
 
13 - 23.01.13 - 12:48
(11) и правильно делает ибо проводить в режиме обмена данными нельзя
   Голубушка
 
14 - 23.01.13 - 12:52
(13), чёй то нельзя, если надо то можно , этот эфект возникает когда гружу на сервер , если локально , то все отрабатывает правильно
   Голубушка
 
15 - 23.01.13 - 12:53
а грузить нужно именно в тонком клиенте и на сервер
   cw014
 
16 - 23.01.13 - 12:55
(15) тебе в (10)
   Голубушка
 
17 - 23.01.13 - 12:57
(10) ну вообще то в моем модуле ее нет , но хорошо сейчас заведу и попробую посмотреть
   cw014
 
18 - 23.01.13 - 12:59
(17) Да не в твоем модуле, а в модуле документа
   Голубушка
 
19 - 23.01.13 - 13:08
(18) ну естественно в МО документа .. ввела ПриЗаписи .. Отказ всегда и везде  Ложь, т.е. док должен записаться , а в исключение (9) уходит потому что не может провестись .. , а провестись не может так как слетает Организация .. заколдованный круг какой то ..

что еще может произойти между записью и проведением , если мы выставляем режим записи проведение?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует