Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

не могу найти субконто по коду

не могу найти субконто по коду
Я
   koketka
 
23.01.13 - 10:56
Загружаю остатки по счетам из другой базы
При загрузке субконто никак не могу найти по коду нужный элемент как то подругому надо а как не знаю Делала так 
Суб2 = Пров.СчетДт.ВидыСубконто[1].ВидСубконто.НайтиПоКоду(Субконто2); 
где субконто2 код элемента
 
 
   1Сергей
 
1 - 23.01.13 - 10:59
Нужно Субконто или вид Субконто?
   Schwonder
 
2 - 23.01.13 - 10:59
Месье знает толк в извращениях
   Schwonder
 
3 - 23.01.13 - 11:00
Нахрена это всё?
   koketka
 
4 - 23.01.13 - 11:01
короче подцепляю из файла счет и код субконта
а в проводке не могу присвоить код?
   koketka
 
5 - 23.01.13 - 11:02
Суб2 = Пров.СчетДт.ВидыСубконто[1].ВидСубконто.НайтиПоКоду(Субконто2);
Пров.СубконтоДт[Пров.СчетДт.ВидыСубконто[1].ВидСубконто] = Суб1;
   koketka
 
6 - 23.01.13 - 11:03
Суб2 = Пров.СчетДт.ВидыСубконто[1].ВидСубконто.НайтиПоКоду(Субконто2); 
Пров.СубконтоДт[Пров.СчетДт.ВидыСубконто[1].ВидСубконто] = Суб2;
   koketka
 
7 - 23.01.13 - 11:03
Суб2 = Пров.СчетДт.ВидыСубконто[1].ВидСубконто.НайтиПоКоду(Субконто2); 
Пров.СубконтоДт[Пров.СчетДт.ВидыСубконто[1].ВидСубконто] = Суб2 ; - опечатка
   DrShad
 
8 - 23.01.13 - 11:04
(4) а где гарантия что тип субконто одинаков?
   Nzn
 
9 - 23.01.13 - 11:04
Код вида субконто?
   Schwonder
 
10 - 23.01.13 - 11:04
По коду искать надо в соответствующем менеджере...
 
 Рекламное место пустует
   DrShad
 
11 - 23.01.13 - 11:04
имхо ТС не дорос до создания универсальной загрузки
   koketka
 
12 - 23.01.13 - 11:04
Если Счет.ВидыСубконто.Количество()> 0 Тогда
                Если Справочники.ТипВсеСсылки().СодержитТип(Пров.СчетДт.ВидыСубконто[0].ВидСубконто.ТипЗначения.Типы()[0]) = Истина Тогда
                    Суб1 = Пров.СчетДт.ВидыСубконто[0].ВидСубконто.ПолучитьОбъект().Метаданные()..НайтиПоКоду(Субконто1); 
                ИначеЕсли Перечисления.ТипВсеСсылки().СодержитТип(Пров.СчетДт.ВидыСубконто[0].ВидСубконто.ТипЗначения.Типы()[0]) = Истина  Тогда
                    Суб1 = ИмяПеречисленияПоСинониму(Субконто1,Пров.СчетДт.ВидыСубконто[0].ВидСубконто)
                КонецЕсли;
                Пров.СубконтоДт[Пров.СчетДт.ВидыСубконто[0].ВидСубконто] = Суб1;
            КонецЕсли;
   Рэйв
 
13 - 23.01.13 - 11:05
Вид=Пров.СчетДт.ВидыСубконто[1].ВидСубконто;
Пров.СубконтоДт.Вставить(Вид,Суб1);
   koketka
 
14 - 23.01.13 - 11:07
(13) а как я по коду нужный элемент найду?
   Рэйв
 
15 - 23.01.13 - 11:08
(14)
Ссылка=Справочник.Какойто.Найтипокоду(Код);
Если ссылка.Пустая() Тгда
   Сообщить("Фиг вам. Нет такого.");
КонецЕсли;
   koketka
 
16 - 23.01.13 - 11:11
(14) В том и дело что какойто я не знаю справочника
например для счетам 62.01 это контрагент для 10 склады
определяется в зависимости от счета!
   koketka
 
17 - 23.01.13 - 11:11
я хотела универсальную обработку
   DrShad
 
18 - 23.01.13 - 11:11
(17) подрасти еще годика два
   Schwonder
 
19 - 23.01.13 - 11:12
Универсальные так не делаются))))
   cw014
 
20 - 23.01.13 - 11:13
ВидСубконто = ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.НайтиПоКоду(Субконто1);

Пров.СубконтоДт[ВидСубконто] = Суб1;
   Рэйв
 
21 - 23.01.13 - 11:13
Ссылка=Справочники[Суб1.Метаданные().Имя].Найтипокоду(Код);
   Schwonder
 
22 - 23.01.13 - 11:14
(0) А откуда данные в файле появились?
   Schwonder
 
23 - 23.01.13 - 11:14
(21) А если составной тип %). Теоретически и такое может быть.
   Schwonder
 
24 - 23.01.13 - 11:15
О типе надо задумываться на этапе формирования файла, если чё.
   Рэйв
 
25 - 23.01.13 - 11:15
(23)Ну и что?...Главное чтобы тип содержался
   Рэйв
 
26 - 23.01.13 - 11:16
Суб1 то уже определенного типа
   DrShad
 
27 - 23.01.13 - 11:16
(21) так у нее нет еще Суб1
   Рэйв
 
28 - 23.01.13 - 11:17
(27)Пусть делает, чтобы уже был:-) ...Ладно, я на обед
   Nzn
 
29 - 23.01.13 - 11:18
(24) ++++
   DrShad
 
30 - 23.01.13 - 11:19
(28) в (24) правильный совет, а по-сему дальнейшее наматывание соплей на кулак в этой ветке бесполезно

ТС - возвращайся к истокам, т.е. к формированию файла выгрузки
   Schwonder
 
31 - 23.01.13 - 11:19
(0) Откуда, всё-таки, файл?
   koketka
 
32 - 23.01.13 - 11:20
да из такойже базы
   koketka
 
33 - 23.01.13 - 11:20
выгружаю в ексель
 
 
   Schwonder
 
34 - 23.01.13 - 11:22
Получи данные, потом попробуй ЗначениеВФайл(), ЗначениеИзФайла(). И не парься.
   koketka
 
35 - 23.01.13 - 11:22
ок
   DrShad
 
36 - 23.01.13 - 11:23
(34) гы, не взлетит
   DrShad
 
37 - 23.01.13 - 11:24
+(36) у нее только конфы одинаковы, а уиды объектов уже другие
   Schwonder
 
38 - 23.01.13 - 11:25
(37) Может из вчерашнего бэкапа. Откуда ты значешь.. Попробовать стоит.
   DrShad
 
39 - 23.01.13 - 11:26
(38) и как тогда новые объекты из Источника отразятся в Приемнике? :)))))
   Schwonder
 
40 - 23.01.13 - 11:28
(39) Если это бэкап, то источник старше чем приемник, и объектов новых в нем нету.
   Schwonder
 
41 - 23.01.13 - 11:29
+(40) Древнее имел ввиду))
   DrShad
 
42 - 23.01.13 - 11:31
(40) вот уж не факт
   Schwonder
 
43 - 23.01.13 - 11:32
(42) Ну а если есть, то всякие там "НайтиПоКоду()" тоже лажанут..
   DrShad
 
44 - 23.01.13 - 11:34
(43) ну так вот и нужно в файл вывести всю необходимую инфу для однозначной идентификации объекта
   Schwonder
 
45 - 23.01.13 - 11:36
(44) Ты перегибаешь))) См. (32).
   DrShad
 
46 - 23.01.13 - 11:38
(45) она же хочет УНИВЕРСАЛЬНУЮ
   Schwonder
 
47 - 23.01.13 - 11:40
(46) Универсальную она пока не осилит.
   koketka
 
48 - 23.01.13 - 11:42
Да мальчики я тупая ничего у меня ничего не получается! Надо еще раз книгу по 1с прочитать! спасибо вам, что не прошли мимо!
   DrShad
 
49 - 23.01.13 - 11:48
(48) в книгах такие плюшки не описаны - они приходят с опытом
 
 Рекламное место пустует
   DrShad
 
50 - 23.01.13 - 11:51
да и как бы уже не актуально такие обработки писать - почитай лучше мануал по КД
   koketka
 
51 - 23.01.13 - 11:55
"мануал по КД" а это что такое
   DrShad
 
52 - 23.01.13 - 11:59
КД - Конвертация данных
мануал - руководство пользователя, инструкция, справка
   Nzn
 
53 - 23.01.13 - 11:59
(51) Конвертация данных
Существуют различные подходы к организации обмена данными между различными информационными базами. Один из таких подходов - организация обмена данными при помощи правил обмена. Для организации обмена данными достаточно разработать правила по которым необходимо переносить данные из одной информационной базы в другую. Когда правила обмена готовы, с их помощью из информационной базы источника можно выгрузить необходимую информацию в файл обмена из которого в свою очередь эти данные можно загрузить в информационную базу приемник


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует