Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Не формируется реестр документов

v7: Не формируется реестр документов
Я
   SorokaV
 
22.01.13 - 20:33
Проблема следующая
На 2-х разных компьютерах находится одна и та же 1с 7.7 с абсолютно идентичной базой данных. При формировании обработки "реестр документов" например расходных накладных на одном компьютере открывает обработку, а в другом выдает ошибку:
ТаблПослед.Значение=Последовательность.ПолучитьАтрибут(МетаПослед.Идентификатор);
{Обработка.ГрупповаяОбработкаДокументов.Форма.Модуль(57)}: Неверное имя атрибута
В Чем прикол ? Подскажите
Процедура:
Процедура ТаблицаПоследовательностей(ТаблПослед)
    
   // колонки таблицы восстанавливаемых последовательностей
 
    ТаблПослед=СоздатьОбъект("ТаблицаЗначений");
    ТаблПослед.НоваяКолонка("Имя", "Строка");               // идентификатор последовательности
 
    ТаблПослед.НоваяКолонка("Значение");                   // ссылка на последовательность
 
    ТаблПослед.НоваяКолонка("УстановитьТА", "Число", 1, 0);   // используются оперативные итоги
 
    
   // строки таблицы восстанавливаемых последовательностей
 
    Для Номер=1 по Метаданные.Последовательность() Цикл
        МетаПослед=Метаданные.Последовательность(Номер);
        ТаблПослед.НоваяСтрока();
        ТаблПослед.Имя=МетаПослед.Идентификатор;
        ТаблПослед.Значение=Последовательность.ПолучитьАтрибут(МетаПослед.Идентификатор);
        
        Если МонопольныйРежим()=1 Тогда
            Для Ном=1 По МетаПослед.ВлияющиеДвижения.Количество() Цикл
                Движение=МетаПослед.ВлияющиеДвижения.Получить(Ном).ПолныйИдентификатор();
                
               // регистры влияют на проведение документов последовательности
 
               // при их перепроведении имеет смысл устанавливать ТА на документ
 
               // для оптимизации получения документами данных из регистров
 
                Если Лев(Движение, 7)="Регистр" Тогда
                    ТаблПослед.УстановитьТА=1;
                КонецЕсли;
            КонецЦикла;
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры
 
 
   Zaval
 
1 - 22.01.13 - 20:42
Язык системы - русский, кодовая таблица БД - "+текущая системная.."
   SorokaV
 
2 - 22.01.13 - 20:48
Кодовая такая и стоит
Язык системы в смысле ? Операционной ?
Винда на украинском языке стоит. Может в этом причина ?
Если да то другую винду ставить ?
   Злопчинский
 
3 - 22.01.13 - 21:12
нахрена в реестре документов последовательности? или в Украйне свой особый путь?
   SorokaV
 
4 - 22.01.13 - 21:18
А я знаю? Кстати некоторіе отчеты тоже не могут формироваться из-за этого (например "продажи")
   Zaval
 
5 - 22.01.13 - 22:04
[Винда на украинском языке стоит. Может в этом причина ? ]

Да, очень старая хохма.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует