Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

список узлов dom

список узлов dom
Я
   tolok_d
 
22.01.13 - 17:26
Здравствуйте, уважаемые гении 1с.
Подскажите пожалуйста, работаю с ДокументDOM, написал функцию перехода на любой уровень ДокументDOM.

Функция ПереходНаУровеньВниз(ДокументDOM, Глубина = 1)
    ДочерниеУзлы = ДокументDOM.ДочерниеУзлы;
    Для Уровень = 1 По Глубина Цикл
 // вот здесь нужно написать уловие добавления узлов, но как????
 
        Для каждого Элем Из ДочерниеУзлы Цикл
            ДочерниеУзлы = Элем.ДочерниеУзлы;
        КонецЦикла; 
    КонецЦикла;  
    
    Возврат ДочерниеУзлы;
КонецФункции

Она работает, но как видно с текста, она возвращает дочерные узлы последнего в xml узла. А хотелось бы чтобы она возвращала все узлы n-го уровня. Зачем такие изощрения? просто в ДокументDOM нельзя узнать глубину, можно только родителя и детей, ну это вы, наверняка, знаете. Подскажите какой метод добавляет узлы в список узлов.
 
 
   mikecool
 
1 - 22.01.13 - 17:27
он нас обозвал гением 1с. наша прелессть, съедим его целикомс
   tolok_d
 
2 - 22.01.13 - 17:28
(1) ну к уважаемым людям нужно соответственно обращаться)
   mikecool
 
3 - 22.01.13 - 17:30
(0) добавляй их в коллекцию и возвращай ее
   tolok_d
 
4 - 22.01.13 - 17:31
ну как вариант можно через ТЗ это делать, но может есть проще путь?
   pessok
 
5 - 22.01.13 - 17:31
(2) как ты сейчас рискуешь :)
   tolok_d
 
6 - 22.01.13 - 17:31
(3) тоесть только так?( эх, обидно.
   Kreont
 
7 - 22.01.13 - 17:32
(4) а может через ЧтениеXML будет проще читать?
   pessok
 
8 - 22.01.13 - 17:32
(0) каждый раз рекурсивно запихивай в параметры структуру одну и ту же и пиши в нее же
   tolok_d
 
9 - 22.01.13 - 17:32
(5) отчего же?)
   pessok
 
10 - 22.01.13 - 17:33
(9) потому что гладиолус :)
Гений 1С
 
 Рекламное место пустует
   tolok_d
 
11 - 22.01.13 - 17:33
(7) ЧтениеXML не дает родителя и детей, только глубину, тоесть в точности да наоборот(
   mikecool
 
12 - 22.01.13 - 17:35
(6) а что смущает?
   tolok_d
 
13 - 22.01.13 - 17:36
(8) структура точно не подходит, разве что ТЗ
   tolok_d
 
14 - 22.01.13 - 17:37
(12) ну думал может есть какая то недокументированная функция, чтобы не ломать тип значения, мне же потом им пользоваться
   pessok
 
15 - 22.01.13 - 17:38
(13) очень даже красиво можно можно построить вложенную структуру наподобие ДЗ, а потом юзать
   tolok_d
 
16 - 22.01.13 - 17:41
(15) хм... вложенная структура? Интересно. Но там же ключ и значение. а мне ключ не нужен. Или всетаки структура- оптимальное решение?
   pessok
 
17 - 22.01.13 - 17:43
(16) ключ - родитель, значение - ДокументDOM
как-то так
   tolok_d
 
18 - 22.01.13 - 17:44
(17) спасибо огромное)
   Йохохо
 
19 - 22.01.13 - 18:25
(18) ты не из edisoft? сознавайся
   Aprobator
 
20 - 22.01.13 - 18:28
(0) где последнего то? А параметр функции Глубина зачем тогда?
   Aprobator
 
21 - 22.01.13 - 18:29
а - увидел. Ну так пихай их в массив и возвращай.
   Йохохо
 
22 - 22.01.13 - 18:39
(21) не, скоро будет вопрос про рекурсию


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует